We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 27519
    • 275 Posts
    I seem to have an issue with components that want to access the MODX database. When they do, there appears a 500 Internal server error in my Javascript Console.

    The error occurs with various components like Batcher, Gallery and Cliche.

    For Batcher the error is:

    POST http://www.peatbogfaeries.com/assets/components/batcher/connector.php 500 (Internal Server Error)
    iext-base.js:7
    Ext.lib.Ajax.k.requestext-base.js:7
    Ext.extend.requestext-all.js:7
    Ext.extend.doRequestext-all.js:7
    Ext.extend.requestext-all.js:7
    Ext.data.Store.Ext.extend.executeext-all.js:7
    Ext.data.Store.Ext.extend.loadext-all.js:7
    MODx.grid.Gridmodx.grid.js:112
    Batcher.grid.Templatestemplate.grid.js:79
    createext-all.js:7
    [more...]

    For Gallery the error is:

    POST http://www.peatbogfaeries.com/assets/components/gallery/connector.php?action=mgr/album/getNodes&id=root 500 (Internal Server Error)
    iext-base.js:7
    Ext.lib.Ajax.k.requestext-base.js:7
    Ext.extend.requestext-all.js:7
    Ext.extend.requestDataext-all.js:7
    Ext.extend.loadext-all.js:7
    Ext.extend.expandext-all.js:7
    config.listeners.render.fnmodx.tree.js:141
    h.Event.fireext-all.js:7
    [more]

    I haven't included the full stack trace but it appears that when the connector.php script of a component wants to access the database a 500 error occurs.

    In the error log I see:
    [Sun Mar 04 13:49:49 2012] [error] [client 81.154.93.143] SoftException in Application.cpp:256: File "/home/peatb953/public_html/assets/components/batcher/connector.php" is writeable by group, referer: http://www.peatbogfaeries.com/manager/index.php?a=79
    [Sun Mar 04 13:49:49 2012] [error] [client 81.154.93.143] SoftException in Application.cpp:256: File "/home/peatb953/public_html/assets/components/batcher/connector.php" is writeable by group, referer: http://www.peatbogfaeries.com/manager/index.php?a=79

    I have friendly URLs active.

    Anybody any clue as to what is wrong and how to solve this?

    Many thanks! [ed. note: skndn60 last edited this post 14 years, 6 months ago.]
      MODx Revolution / MAMP / OS X
      • 27519
      • 275 Posts
      This is caused by a wrong permission value of connector.php, the script that accesses the database for a component. The value should be 755. After setting the permission to 755 it all worked.
        MODx Revolution / MAMP / OS X