We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28042 ☆ A M B ☆
    • 24,524 Posts
    I once had a nasty situation with a "stuck" TV. If I deleted the TV (it wasn't being used anyway) or unhooked it from its templates, I'd get white-screens on save, and sometimes even on opening any resource that had ever had it. Emptied the cache, checked the database, nothing seemed to help. I finally dug in and emptied all resource values for the TV, then deleted all the templates and created them fresh - duplicating them didn't work - and finally got it all cleared up. Took several days to figure out just what the problem was and get it fixed. Fortunately this was in the Cloud, so restoring to a known good state every time an attempted fix failed was just a couple of mouse clicks.
      Studying MODX in the desert - http://sottwell.com
      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
      Join the Slack Community - http://modx.org
      • 38355
      • 38 Posts
      Quote from: sottwell at Apr 11, 2013, 04:56 AM
      I once had a nasty situation with a "stuck" TV. If I deleted the TV (it wasn't being used anyway) or unhooked it from its templates, I'd get white-screens on save, and sometimes even on opening any resource that had ever had it. Emptied the cache, checked the database, nothing seemed to help. I finally dug in and emptied all resource values for the TV, then deleted all the templates and created them fresh - duplicating them didn't work - and finally got it all cleared up. Took several days to figure out just what the problem was and get it fixed. Fortunately this was in the Cloud, so restoring to a known good state every time an attempted fix failed was just a couple of mouse clicks.

      I got my TV working again... deleted, clear cache, removed the template and created them all again with different names and it work.. something corrupt somewhere...

      Now I just need to get the saving loop solved it is turning into a nightmare
        Revolution 2.2.0
        Developer not a programmer...
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        Can you even save a resource with something like "hello, world" in it, with no template?
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 38355
          • 38 Posts
          Quote from: sottwell at Apr 11, 2013, 06:01 AM
          Can you even save a resource with something like "hello, world" in it, with no template?

          When I click the save button or use Control S the save process starts, with the popup save box, and then goes into an endless loop never stoping. When I hit F5 to refresh the page usually, say 90% of the time, the resource has updated successfully. Sometimes to see the update I need to go Site > Clear Cache but usually not.

          Whether the resource has a template or no template selected makes no difference.

          The save issue is only with resources... I never had an issue saving TVs, chunks etc
            Revolution 2.2.0
            Developer not a programmer...
            • 3749
            • 24,544 Posts
            Have you tried turning off the compress_js and compress_css System Settings and clearing your browser cache and cookies?

            I'm beginning to suspect a corrupted intersect object (which I think is what Susan had), such as a modTemplateVarTemplate or modTemplateVarResource with one of its fields pointing to an object that no longer exists.

            I've been working, on and off, on a package to diagnose this kind of thing.

            Try this (if you haven't already): Create a new Template with no TV access. Create a new Resource in the site root using that new Template. If you still can't save it, my theory probably wrong.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 38355
              • 38 Posts
              Hi BobRay,

              I turned off the compress_js and compress_css and cleared the browser cache and cookies. I also create a new Template with no TV access with a new Resource in the site root using that new Template. Unfortunately still get the saving loop!

              Thanks for all the suggestions!

              damshaw
                Revolution 2.2.0
                Developer not a programmer...
                • 38355
                • 38 Posts
                Hi,

                I have checked the Modx error log again and these error are now showing... these are only after the upgrade to 2.2.7 so not sure if it is related to the save issue...

                [2013-04-12 09:49:15] (ERROR @ /staging/connectors/system/log.php) Could not load class: unknown from mysql.unknown.
                [2013-04-12 09:49:15] (ERROR @ /staging/connectors/system/log.php) unknown::load() is not a valid static method.
                [2013-04-12 09:49:15] (ERROR @ /staging/connectors/system/log.php) Could not load class: unknown from mysql.unknown.
                [2013-04-12 09:49:15] (ERROR @ /staging/connectors/system/log.php) unknown::load() is not a valid static method.
                [2013-04-12 09:49:15] (ERROR @ /staging/connectors/system/log.php) Could not load class: unknown from mysql.unknown.

                **** repeats ****

                <b>Warning</b>: array_search() [<a href='function.array-search'>function.array-search</a>]: Wrong datatype for second argument in <b>/home/residentialloungevps/residentiallounge.com.au/staging/core/components/articles/model/articles/articlesrouter.class.php</b> on line <b>58</b>



                <b>Warning</b>: array_search() [<a href='function.array-search'>function.array-search</a>]: Wrong datatype for second argument in <b>/home/residentialloungevps/residentiallounge.com.au/staging/core/components/articles/model/articles/articlesrouter.class.php</b> on line <b>58</b>

                **** repeats ****




                  Revolution 2.2.0
                  Developer not a programmer...
                  • 3749
                  • 24,544 Posts
                  That's a tough one. I don't know what else to suggest. Sorry.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 38355
                    • 38 Posts
                    Quote from: BobRay at Apr 11, 2013, 08:13 PM
                    That's a tough one. I don't know what else to suggest. Sorry.

                    I was thinking I could transfer the entire website in another instance of MODX but most likely I would take the problem as well... so I guess that would be a last resort... which I am approaching sad
                      Revolution 2.2.0
                      Developer not a programmer...
                      • 27106
                      • 147 Posts
                      Anyone afflicted with this problem should also see this thread:
                      https://forums.modx.com/thread/?thread=80918

                      It turns out that an Apache module called mod_security may block lines such as
                      overflow: auto;
                      and
                      overflow: hidden;
                      . The trick is to replace that code with
                      overflow: aut[[-nothing]]o;
                      and
                      overflow: hidde[[-nothing]]n;
                      . Essentially, replace all instances of auto or hidden.

                      Bizarrely, at several points I also had to replace
                      height: 1px;
                      and
                      width: 1px;
                      with
                      height: 1[[-nothing]]px;
                      and
                      width: 1[[-nothing]]px;
                      .
                        David Walker
                        Principal, Shorewalker DMS
                        Phone: 03 8899 7790
                        Mobile: 0407 133 020