We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 42215
    • 17 Posts
    Hi!

    I'm having a problem with saving resources. When I try to save one (already created before), the "Please wait" popup appears and gets stuck. When I refresh the page, some changes made appear as applied, except unchecking a Resource group.

    I tested this with Chrome 12 and Firefox 8. I think the most interesting is the Firebug error report when saving a resource:

    missing } in XML expression
    http://blah.blah/manager/assets/ext3/ext-all.js
    Line 79
    And the piece of code it points at:
    <font color="#cc0000">'a:5:{s:19:"context_param_alias";a:7:{s:4:"name";s:19:"co...


    Would love to get help with this.
    Some tech info:

    ModX Revolution 2.2.5-pl traditional;
    No addons but from the box;
    Windows Server 2003, Apache 2.2.21
    PHP 5.2.17
    MySQL 5.1.54

    This question has been answered by gadgetto. See the first response.

    • discuss.answer
      • 10378
      • 375 Posts
      Do you have any plugins attached to OnResourceSave event?
      Do you have attached any TemplateVariables to the corresponding template?

      If so try to deactivate any events and detach one TV after another to see which one causes the problem.

      If this doesn't help, your could try to repair your MODx installation!
      [ed. note: gadgetto last edited this post 13 years, 10 months ago.]
        Freelancer @bitego http://www.bitego.com
        ---
        GoodNews - one of the most advanced and integrated Group Mailer premium add-ons for MODX Revolution!
        More infos here: http://www.bitego.com/extras/goodnews/
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        Quote from: bonflash at Nov 30, 2012, 08:34 AM

        No addons but from the box;
        Looks like something is broken in the installation; the Manager's extJS/Smarty is displaying some of its JSON instead of processing it.

        How did you install? Did you extract the files on your local machine and upload all the files? That will often result in corrupted files; it is better to upload the zip archive and extract the files on the server.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 42215
          • 17 Posts
          Thanks for the replies!

          Do you have attached any TemplateVariables to the corresponding template?
          After some more investigating smiley it really was a TV that lead to the error. Access to that TV was restricted to a certain Resource Group.

          What I don't understand is
          1) why the error was present for users who did have access to that Resource Group, and
          2) why is there an error instead of "Access Denied" message.

          it is better to upload the zip archive and extract the files on the server.
          And much faster =) Yes, I uploaded the archive first and then extracted it. Now I'll try installing a parallel Revo site and reproduce the problem there. Will post here whether it helps or not. [ed. note: bonflash last edited this post 13 years, 10 months ago.]
            • 42215
            • 17 Posts
            Seems that the error shows up, when the access to the TV has been changed and the page with the resource the TV is attached to hasn't been refreshed. If I refresh the resource edit page, everything seems to be fine. (But to achieve that I had to reset all the permissions and reassign Resource groups.) By the way, the TVs are still inaccessible by anybody if they are assigned to even a single Resource Group.

            Yet, the issue is clear for me. I hope ModX team will fix the possibility of such error itself.

            gadgetto and sottwell, thanks for your time! [ed. note: bonflash last edited this post 13 years, 10 months ago.]
              • 38355
              • 38 Posts
              I have a very similar problem and there seems to be many out there experiencing the saving loop.

              Save works everywhere but when saving resources. It just loops! You can usually hit F5 and refreash the page and then clear the cache and resource is updated but it is not ideal and it does not work all the time.

              I have reintall Modx and upgraded to 2.2.7 and it was a flawless install.. but still the saving loops...

              I have deleted all files from /core/cache/

              The issue still happens if using the base template with no TV attached

              PHP 5.2.17
              mySQL 5.1.56
              no errors logged

              Client is getting real unhappy... any help would be amazing!!

              damshaw
                Revolution 2.2.0
                Developer not a programmer...
                • 3749
                • 24,544 Posts
                Are there any TVs for the pages that the user might not have access to? The first thing to try is editing your own user Profile and making yourself a sudo user. If that solves it, it's definitely a permissions issue.

                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 38355
                  • 38 Posts
                  Quote from: BobRay at Apr 10, 2013, 09:44 PM
                  Are there any TVs for the pages that the user might not have access to? The first thing to try is editing your own user Profile and making yourself a sudo user. If that solves it, it's definitely a permissions issue.


                  Hi BobRay,

                  I am Sudo user and it is happening to all users... There is defiantly a permission issue somewhere as well. The content editor user group access policy and reset itself 3 times now which is not a good thing.

                  There is also a TV which the editor role has access, it is a image input TV, and they just see the image file name with no browser option. I created and new image tv and the same thing happens.

                  So there is something weird going on somewhere.. I stripped all add-ons which are not crucial like versionx.

                  damshaw [ed. note: damshawthing last edited this post 13 years, 5 months ago.]
                    Revolution 2.2.0
                    Developer not a programmer...
                    • 3749
                    • 24,544 Posts
                    If it's happening to a sudo user, it's *not* a permissions issue, unless MODX can't write to the cache folder, and that should affect all elements too.

                    A few more things to try (if you haven't already).

                    Log out
                    Manually delete all files in the core/cache directory
                    Clear your browser cache and cookies before logging back in

                    If that doesn't do it, go into PhpMyAdmin from cPanel and repair all tables in the DB.

                    Also, see if there's anything in the Error Log (Reports -> Error Log).

                    Endless saves are often caused by either a bad plugin attached to OnBeforeDocFormSave or OnDocFormSave or by mod_security. It would be unusual for mod_security to act on all Resources, but not impossible if there's some word in your templates that it doesn't like (I've seen instances of mod_security choking on the word 'select' and the word 'casino') -- some hosts have weird ideas on what to block.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 38355
                      • 38 Posts
                      Hi,

                      I have striped all TVs to only essential and no TV has user permission.... cleaned up the templates... not that this would solve the saving issue but just dont have any idea so clean code is alway better :/

                      I installed another instance of Modx is another subfolder and it runs perfectly on the same server setting. I nearly though of transfering the entire site to the new install but thought thee must be a better easier way....

                      I hope there is anyway :?

                      I have also

                      • Cleared site cache
                      • Cleared core/cache
                      • mod_security off
                      • repaired DB from phpmyadmin


                      The below errors have only appear since the upgrade from 2.2.6 to 2.2.7

                       [2013-04-11 17:25:29] (ERROR @ /staging/index.php) [OnPageNotFound]<br />
                      <b>Warning</b>:  array_search() [<a href='function.array-search'>function.array-search</a>]: Wrong datatype for second argument in <b>/home/residentialloungevps/residentiallounge.com.au/staging/core/components/articles/model/articles/articlesrouter.class.php</b> on line <b>58</b><br />
                      <br />
                      **** repeats several time ****
                      
                      


                      :(
                        Revolution 2.2.0
                        Developer not a programmer...