We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 41144
    • 15 Posts
    @opengeek, I sure will if I find something more
      • 14162
      • 67 Posts
      I used to get this error also but have managed to resolve it. I found that in my Articles container, I was referencing a non-existent template chunk in Advanced Settings > Latest Posts > Latest Articles Chunk.

      On amending the name of the template chunk to one that existed it stopped the errors.

      Not sure if that's a panacea but worked for me.

      ADDENDUM: I take it back - the error is still occurring. Gah! [ed. note: jimbob72 last edited this post 13 years, 9 months ago.]
        • 15734
        • 70 Posts
        I'm having same issue. Seems to be related to image TVs. I'm running 2.2.5 and 2.2.6 traditional. 2 Sites on same host. Is there anything specific I could check to help troubleshoot this? Thanks.
          • 22303 MODX Staff
          • 10,725 Posts
          Quote from: kevince52 at Jan 03, 2013, 03:58 PM
          I'm having same issue. Seems to be related to image TVs. I'm running 2.2.5 and 2.2.6 traditional. 2 Sites on same host. Is there anything specific I could check to help troubleshoot this? Thanks.
          Yes, provide details about the Media Source configuration and Image TV configuration causing the error...
            • 8921
            • 55 Posts
            Quote from: opengeek at Jan 04, 2013, 08:55 AM
            Yes, provide details about the Media Source configuration and Image TV configuration causing the error...

            I too am having this issue. However, after a day of testing, I have narrowed it down to the exact cause. The issue is 100% with GetResources grabbing an ImageTV. I can reproduce this 100% every time.

            Stock Install: 2.2.6
            GetResources: 1.5.1

            2 Test pages using default ModX template.
            Stock ImageTV assigned to default template (no changes other than name and template).
            Page 1 has a photo uploaded and assigned to ImageTV.
            GetResources call on Page 2: [[!getResources? &parents=`-1` &resources=`1` &includeTVs=`1`]]

            Errors occur whenever Page 2 is reloaded. Remove &includeTVs from the call and no errors are generated.

            Hope this helps. I have a site launching next week that is generating hundreds of these errors per hour during our pre-launch testing. It's going to be ridiculous after launch when I start hitting it with 50k+ visits per day. I think I'm going to have to roll back to 2.2.4 for launch because other sites I have on 2.2.4 don't have this issue.

            ADDITIONAL: The above also happens if the TV type is "File". When I change to a standard text TV and copy/paste in the image URL, this works without error. [ed. note: entica last edited this post 13 years, 8 months ago.]
              • 22303 MODX Staff
              • 10,725 Posts
              This is actually an error with the Media Sources implementation that needs to be addressed, but the best way to avoid it in current releases is to make sure that you use either the prepareTVs or processTVs properties of getResources when using Template Variables that make use of Media Sources (i.e. Image or File TVs). For better performance, I recommend narrowing it down exclusively to the specific Template Variables using getResources' processTVList property.
                • 8921
                • 55 Posts
                Quote from: opengeek at Jan 20, 2013, 03:35 PM
                This is actually an error with the Media Sources implementation that needs to be addressed, but the best way to avoid it in current releases is to make sure that you use either the prepareTVs or processTVs properties of getResources when using Template Variables that make use of Media Sources (i.e. Image or File TVs). For better performance, I recommend narrowing it down exclusively to the specific Template Variables using getResources' processTVList property.

                While I'm sure you're right, I was just reporting what I found the trigger to be (GetResources). I forgot to mention that I had also tried my GR calls with processTVs and still received the error - it didn't seem to make a difference.

                Thank you for your attention to this issue, it's greatly appreciated by myself and I'm sure others in the community.

                EDIT: I will test with processTVs again just to make sure I didn't miss something or somehow mess up my testing.

                EDIT 2: Testing with &processTVs again and I still get the errors. Also, in my testing I found out that the Image TV doesn't even have to be used in the GR template anywhere. It's enough to simply just have it called as part of &includeTVs. [ed. note: entica last edited this post 13 years, 8 months ago.]
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Just a thought. Can anyone experiencing this error confirm the class_key column values of the (modx_)media_sources table are set to something like sources.modFileMediaSource and not simply to modFileMediaSource? If you have any class_key values here that do not begin with sources., this could be the cause of this error in several places.
                    • 36502 ☆ A M B ☆
                    • 491 Posts
                    Hi,
                    I'm having the same problem, I have 5 media sources but all my class_key are: sources.modFileMediaSource

                    :(
                      TilliLab | MODX Ambassador
                      website
                      • 8921
                      • 55 Posts
                      Quote from: opengeek at Jan 21, 2013, 08:18 AM
                      Just a thought. Can anyone experiencing this error confirm the class_key column values of the (modx_)media_sources table are set to something like sources.modFileMediaSource and not simply to modFileMediaSource? If you have any class_key values here that do not begin with sources., this could be the cause of this error in several places.

                      Just checked my table. It only has a single entry and that entry is using sources.modFileMediaSource.