Quote from: opengeek at Jan 04, 2013, 08:55 AMYes, provide details about the Media Source configuration and Image TV configuration causing the error...
I too am having this issue. However, after a day of testing, I have narrowed it down to the exact cause. The issue is 100% with GetResources grabbing an ImageTV. I can reproduce this 100% every time.
Stock Install: 2.2.6
GetResources: 1.5.1
2 Test pages using default ModX template.
Stock ImageTV assigned to default template (no changes other than name and template).
Page 1 has a photo uploaded and assigned to ImageTV.
GetResources call on Page 2: [[!getResources? &parents=`-1` &resources=`1` &includeTVs=`1`]]
Errors occur whenever Page 2 is reloaded. Remove &includeTVs from the call and no errors are generated.
Hope this helps. I have a site launching next week that is generating hundreds of these errors per hour during our pre-launch testing. It's going to be ridiculous after launch when I start hitting it with 50k+ visits per day. I think I'm going to have to roll back to 2.2.4 for launch because other sites I have on 2.2.4 don't have this issue.
ADDITIONAL: The above also happens if the TV type is "File". When I change to a standard text TV and copy/paste in the image URL, this works without error.
[ed. note: entica last edited this post 13 years, 8 months ago.]