We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 34163
    • 11 Posts
    The error is triggered by Manager and front-end pages for me. With Manager, it appears that any page I navigate to triggers somewhere between 3 and 5 entries being written to the log.

    On the front-end, there are pages that trigger the error and pages that don't. I did some testing and this is what I found.

    I created a bare-bones template with no TVs or snippet calls and a resource (page) that uses the template. Added Wayfinder and QuickCrumbs calls to the template, no erorr triggered.
    Added a text TV to the template and some content to it in the resource, no error.
    Added an image TV to the template, but didn't specify an image in the resource. This produced the error. When I specified an image, the error was no longer triggered.
    Removing the image (path) from the resource triggered the error again. Reinstating the image cleared the error.
    Adding more image TVs to the template and performing the above sequence produced the same results.

    I noticed that of the existing resources I have set up in the site, only those that have an image TV reference in a getResources template (chunk) trigger the error. When an image TV is referenced directly within the resource template, and an image is specified, no error is triggered.
      • 22303 MODX Staff
      • 10,725 Posts
      This sounds like a problem with the image TV, but I do not know what. If someone can isolate the issue, it would be very helpful.
        • 34163
        • 11 Posts
        What should 'Default MODX workspace' be set to in the modx_workspaces table? Mine is set to:
        {core_path}

        Should it be an actual path e.g. '/core/' ?

        The reason I ask is that I'm first checking that all the paths I can find in config files etc. are correct.

        Any other suggestions as to what I should look at next are most welcome.

          • 22303 MODX Staff
          • 10,725 Posts
          This has nothing to do with the Workspace. This is an issue with the use of Media Sources.
            • 3749
            • 24,544 Posts
            Quote from: stretched at Nov 01, 2012, 06:54 PM
            What should 'Default MODX workspace' be set to in the modx_workspaces table? Mine is set to:
            {core_path}

            Should it be an actual path e.g. '/core/' ?

            No, that's normal. MODX translates {core_path} and {assets_path} there, and in System Settings.


            ------------------------------------------------------------------------------------------
            PLEASE, PLEASE specify the version of MODX you are using.
            MODX info for everyone: http://bobsguides.com/modx.html
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 41693
              • 8 Posts
              I'll do a fresh install with the old 2.2.4 and stay with it.

              It seems like nobody knows the cause for this issue, i searched all files for this strange query but didn't find anything. Now it's 3 weeks ago and nobody have had an idea sad
                • 34163
                • 11 Posts
                It sounds like the issue here is connected to http://tracker.modx.com/issues/8829 (apologies if I'm stating the obvious). I ran setup again after clearing cache & logs and logging out. Looking at the install.config.log I too have the Duplicate key name 'cache_refresh_idx' message plus a few others:

                [2012-11-02 15:36:50] (ERROR in xPDOManager_mysql::addIndex @ /var/www/*****.com/core/xpdo/om/mysql/xpdomanager.class.php : 329) Error adding index cache_refresh_idx to modResource: Array
                (
                    [0] => 42000
                    [1] => 1061
                    [2] => Duplicate key name 'cache_refresh_idx'
                )
                
                [2012-11-02 15:36:54] (ERROR @ /setup/index.php) xPDOVehicle resolver failed: type php (/var/www/*****.com/core/packages/core/modContext/cd0583f5e190451e0235a81793628054.resolve.core.resolver)
                [2012-11-02 15:36:54] (ERROR @ /setup/index.php) Could not resolve vehicle for object of class modContext; criteria: Array
                (
                    [key] => web
                )
                
                [2012-11-02 15:36:54] (ERROR @ /setup/index.php) xPDOVehicle resolver failed: type php (/var/www/*****.com/core/packages/core/modContext/200977f91595ab9bc0327e1e0ec25f62.resolve.core.resolver)
                [2012-11-02 15:36:54] (ERROR @ /setup/index.php) Could not resolve vehicle for object of class modContext; criteria: Array
                (
                    [key] => mgr
                )
                
                [2012-11-02 15:36:54] (ERROR @ /setup/index.php) xPDOVehicle resolver failed: type php (/var/www/*****.com/core/packages/core/xPDOFileVehicle/ebdf71a63c4ec853b1e8088523de3ffa.resolve.core.resolver)
                [2012-11-02 15:36:55] (ERROR @ /setup/index.php) Error 42S22 executing statement: 
                Array
                (
                    [0] => 42S22
                    [1] => 1054
                    [2] => Unknown column 'modAccessPermission.policy' in 'where clause'
                )
                
                [2012-11-02 15:36:55] (ERROR @ /setup/index.php) Error 42S22 executing statement: 
                Array
                (
                    [0] => 42S22
                    [1] => 1054
                    [2] => Unknown column 'modAccessPermission.policy' in 'where clause'
                )

                  • 22303 MODX Staff
                  • 10,725 Posts
                  8829 is not even a valid bug. It's just a warning indicating the index was already existing on the table; the upgrade can't add it twice.

                  We need to focus on what is triggering the specific error being discussed here, please. All this stuff from setup is irrelevant at the moment. Can someone narrow down what Resources or Extras or Element tags are triggering this error? That is what needs to be done here.
                    • 41144
                    • 15 Posts
                    I've the same error:

                    [2012-11-07 03:51:17] (ERROR @ /index.php) Could not get table name for class: modFileMediaSource
                    [2012-11-07 03:51:17] (ERROR @ /index.php) sources.modMediaSource::getSelectColumns() is not a valid static method.
                    [2012-11-07 03:51:17] (ERROR @ /index.php) Error 42S22 executing query: SELECT `modSnippet`.`id` AS `modSnippet_id`, `modSnippet`.`source` AS `modSnippet_source`, `modSnippet`.`property_preprocess` AS `modSnippet_property_preprocess`, `modSnippet`.`name` AS `modSnippet_name`, `modSnippet`.`description` AS `modSnippet_description`, `modSnippet`.`editor_type` AS `modSnippet_editor_type`, `modSnippet`.`category` AS `modSnippet_category`, `modSnippet`.`cache_type` AS `modSnippet_cache_type`, `modSnippet`.`snippet` AS `modSnippet_snippet`, `modSnippet`.`locked` AS `modSnippet_locked`, `modSnippet`.`properties` AS `modSnippet_properties`, `modSnippet`.`moduleguid` AS `modSnippet_moduleguid`, `modSnippet`.`static` AS `modSnippet_static`, `modSnippet`.`static_file` AS `modSnippet_static_file`, `` FROM `modx_site_snippets` AS `modSnippet` LEFT JOIN `modx_media_sources` `Source` ON `modSnippet`.`source` = `Source`.`id` WHERE `modSnippet`.`name` = ? ORDER BY `modSnippet`.`id` ASC - Array
                    (
                    [0] => 42S22
                    [1] => 1054
                    [2] => Unknown column '' in 'field list'
                    )

                    This happened after I've upgraded from 2.1.5 to 2.2.5 on pretty large site with multiple contexts.
                    I've created blank template with *content in it, no TVs, and then resource test.html with default settings and content of 'ddd'.

                    Now, I disabled all the plugins and the error disappeared. The error showed up again when gateway plugin was activated.
                    After some debugging this line appeared to cause the error:

                    $modx->lexicon->load('cpr:web');

                    It loads lexicon file for frontend with some settings and simple chunks (put it there being bit lazy ;-) ). When I deleted entries and left just one simple string everything is ok. [ed. note: remek555 last edited this post 13 years, 10 months ago.]
                      • 22303 MODX Staff
                      • 10,725 Posts
                      @remek555:

                      Thanks for the diligence in helping track this down.

                      If you have some more details on what those "settings and simple chunks" were, it might be helpful in tracking down the precise cause of this problem. Would be great to see an issue created in the tracker with those details.