I'd find it a bit strange if it was RAM. The set-up I have is running 125mb but I have working ModX installs (thumbnails and all) on much less. I still think it is environment.
maybe. There is definitely something wrong anyway - if this is RAM issue, there should be error message about it returned by phpthumb instead of hard crash
worst thing is that when it crashes, not only manager stops working, but also front end website, which is scary
I tested the same website in 6 different environments, and RAM is the only factor I could find
well, it actually works for me on machine with PHP 5.4.1 /200MB RAM, so e_strict errors were not the cause (but thanks for the link, I will apply the patch anyway)