We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 43230
    • 4 Posts
    This solved a different issue that I had with Modx-Hybridauth. Executing [[!HybridAuth?providers=`Google`]] resulted in a 404 Page not found.

    After looking in the error logs I noticed:

    [error] 23180#0: *11516 FastCGI sent in stderr: "PHP message: PHP Catchable fatal error: Argument 1 passed to xPDOObject::load() must be an instance of xPDO, instance of modX given in /var/www/clients/client0/web1/web/core/xpdo/om/xpdoobject.class.php on line 404" while reading response header from upstream, client: 98.249.228.26, server: ingressprime.com, request: "GET /?action=login&provider=Google HTTP/1.1", upstream: "fastcgi://127.0.0.1:9010", host: "ingressprime.com", referrer: "http://ingressprime.com/"

    After searching through the php files for Hybridauth I noticed a die(); function in function redirect around line 366 in the core/components/hybridauth/model/hybridauth/lib/Auth.php file.

    Adding session_write_close(); just before solved the issue.

    The Auth.php file belongs to the Hybridauth repository so a modified version of the files needs to be distributed with the Extra.

    Thanks to opengeek for the tip.
      • 24865
      • 289 Posts
      /Epic bump

      My fix was disabling APC, thanks for the tip.
      Replacing the files, however, did not work... sad
        @MarkGHErnst

        Developer at Adwise Internetmarketing, the Netherlands.