after updating my modx 2.2.0-pl2 install to 2.2.1-pl I get this error inside the manager javascript of index.php:
<b>Catchable fatal error</b>: Argument 1 passed to xPDOObject::load() must be an instance of xPDO, instance of modX given in <b>/core/xpdo/om/xpdoobject.class.php</b> on line <b>404</b>
So I'm currently unable to use the manager. Anybody with the same issue or an idea about the source?
I created a fresh installation for testing: http://debug.fbx.chsmedien.de/web/ (Issue also occurs)
If you would like to get access message me...
[Solution:]
This error was caused by an corrupted file. Uploading again all modx files and deleting the cache should solve it.
[Update:]
This Issue seems not belong to a corrupted file. It seems to be caused by APC. With APC enabled this error comes back. Disabling APC and running the setup again seems to fix it. But disabling APC can't be a solution...
I am assuming that you're not seeing the manager at all but seeing this at login? If not, please let us know. Additionally, Do you see any 404s when looking in firebug or web inspector?
Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub
I can successful login into the manager and use some pages. On other pages there is a "Uncaught SyntaxError: Unexpected token <" in the console which is in the index.php:
<b>Catchable fatal error</b>: Argument 1 passed to xPDOObject::load() must be an instance of xPDO, instance of modX given in <b>/www/htdocs/w00f207f/modx/core/xpdo/om/xpdoobject.class.php</b> on line <b>404</b><br />
So the manager is not correctly / fully displayed because of this "javascript error" which stops rendering. I can't see any 404.
chsmedien - Digital Marketing Agency
MODX Professional & Ambassador
Well...
I tried a traditional install on an other location on my server, without problems!
Then I tried a "standard" advanced install and my custom install, both without problems on that other location on my server.
I will now copy my error-install to that location and see if this error belongs to the sever.
chsmedien - Digital Marketing Agency
MODX Professional & Ambassador
It seems like it was really just a corrupted file. But this seems not possible since I made another fresh install via wget and that one had the same error.
What I did now is a fresh install and copied my custom files and overwrite the database.
Now I have just one problem left: I can't clear the cache from the manager. There is an (other) "Uncaught SyntaxError: Unexpected token <"
See image: http://cl.ly/FbGx
Firebug says: "<b>Fatal error</b>: Uncaught exception 'UnexpectedValueException' with message ..."
Any idea what could cause this?
chsmedien - Digital Marketing Agency
MODX Professional & Ambassador
I can only thing cache at this moment in time, delete all directories in cache folder, do this from on the server filesystem or shell rather than using the MODx Clear Cache action, then logout and login again.
Well Andrew, Thanks a lot!
The full error message brought some light
I missed the assets/components folder when I copied my files. So the manager couldn't clear the phpthumb cache in that folder... Bad error handling from modx, but now I got it.
THANKS A LOT TO ALL OF YOU!
chsmedien - Digital Marketing Agency
MODX Professional & Ambassador