We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37449
    • 57 Posts
    Fresh install of 2.2.0-pl2 trad
    PHP 5.3.0
    Apache 2.0
    MySql 5.1.36-community
    On my local machine running WAMP

    I want to use a TV to select an image to use on each resource so....

    1. Create a Media Source, copying the FileSystem one and updating basePath and baseUrl - they point to assets/siteimages/
    2. Create a TV, set the input type to Image, output type to Image, set the class, go to the Media Source tab
    3. After much hunting, found I need to double-click the blank "Source" field to bring up the Media Sources - do this and select my PageImage media source
    4. The selection is not saved on the tab, despite repeating the operation
    5. Go to the resource, select the TV
    6. Click the drop down to go and select the file
    7. Change the FileSystem option to PageImage option
    8. Select my image and click OK

    Manager now closes! No error in the error log, no errors anywhere as far as I can see! Manager just simply closes!!

    Anyone else had this and fixed it?

    Thanks
    Daz

      formerly sumodaz on here!
      • 37449
      • 57 Posts
      P.S. This happens in Chrome, FF, IE
        formerly sumodaz on here!
        • 37449
        • 57 Posts
        I have tried with both an upgrade and a fresh install of 2.2.4 and this still happens!

        I don't understand!

        It appears some others are seeing this issue - https://forums.modx.com/thread/73935/editing-image-field-causing-manager-window-close-crash

        Is anyone else??
          formerly sumodaz on here!
          • 22303 MODX Staff
          • 10,725 Posts
          It might be worth sharing all of your Media Source settings that are being used for the Image TV...
            • 1761
            • 20 Posts
            I'm having the same problems with multiple modx installations. The only way arround it is to type it instead of selecting the image.
            I've been looking for a solution but I haven't found it yet. Hope someone knows what the problem is because it's REALLY annoying me... ;-)

            I'm using
            modx 2.2.5-pl
            PHP Version 5.2.11
            MySql 5.0.77

            Some other posts I found...
            https://forums.modx.com/thread?thread=73935
            http://tracker.modx.com/issues/8484
            http://tracker.modx.com/issues/9007
              • 22303 MODX Staff
              • 10,725 Posts
              This is a known issue when opening the manager in a new tab, for example, when opening the manager via a js link in the MODX Cloud Dashboard. You can avoid the problem by opening the manager in a blank window, navigating to it manually. You can follow the issue here, which has already been addressed for the 2.2.6-pl release, coming shortly.