We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10189
    • 109 Posts
    I made a clean install of Revo 2.2.0-pl2 (advanced) on a local Ubuntu dev server, which was then moved to a FreeBSD server with the following setup:

    OS: FreeBSD 8.2-RELEASE-p3
    PHP: 5.3.8
    MySQL: 5.1.43

    $SERVER_['DOCUMENT_ROOT'] reports and "incorrect" path (something other than the path the MODx installation resides in). Not sure how much of an impact that might have (edit: just received confirmation from my host that this is an intentional configuration for the sake of security).

    The caching errors in question: http://pastebin.com/LhrrA161

    From time to time, lexicons seems to fail to load. An example of this is the System Settings page:
    http://dl.dropbox.com/u/817490/Screenshots/n_-~5-c2n23y.png

    as well as these "undefined" errors cropping up every now and then:

    http://dl.dropbox.com/u/817490/Screenshots/4a2pr5v11ayo.png

    Caching settings are set to default and I've made sure that Minify is disabled for the manager.

    Update: I've noticed that these errors occurs on older installations of Revo on the same host, for example 2.1.5 as well as 2.1.3. Both were advanced installs. [ed. note: frippz last edited this post 14 years, 8 months ago.]
      • 10189
      • 109 Posts
      Just found another effect of these errors (I think), which is that sometimes when I try to edit a resource or try to access the System Setting, no content is displayed. All I see is the nav tabs, the tree and a message saying
      Could not find action file at: controllers/default/index.php
        • 10189
        • 109 Posts
        Another update. I just found out that other MODx sites that resides on the same host receives similar errors about caching. I'm starting to think that this really does have something to do with that incorrect DOCUMENT_ROOT.
          • 22303 MODX Staff
          • 10,725 Posts
          A clean install of what release of MODX?

          It really should not be a problem if the DOCUMENT_ROOT does not match your MODX constants (e.g. MODX_BASE_PATH).

          As for you caching issues, those seem to all be generated by database caching. I would disable cache_database unless you have a compelling reason to be using it anyway, but I cannot tell why it is failing from this; have you changed any other cache-related settings?

          I'll see if I can reproduce any of those lexicon or js errors, but this would all appear to be related to caching, be if permissions or other configuration related problems.
            • 10189
            • 109 Posts
            Sorry, forgot to be specific about the version! It's primarily 2.2.0-pl2 (advanced). I've disabled the db cache. Not sure why I had set that to on, really.

            Now, I hope that was the only thing I have changed. Just to be sure, here's whats in effect now:

            http://dl.dropbox.com/u/817490/Screenshots/edw3rjz6rtq1.png

            By the way, the server runs PHP as CGI and when I checked permissions, everything seems to be in order (i.e. all files are owned by the user).

            Also, the phpinfo(); if that's any help: http://www.psykologmfarnstrand.se/a.php

            Edit: disabled db cache and this is the recent error log: http://pastebin.com/U1neUSJW [ed. note: frippz last edited this post 14 years, 8 months ago.]
              • 22303 MODX Staff
              • 10,725 Posts
              It sounds like the cache directory is not writable by the PHP process. Running as CGI is one thing, running with some kind of suexec would mean your user account and the PHP process were running as the same user, but generally, PHP runs as the web server user account and you will need to make it writable by that user.
                • 10189
                • 109 Posts
                I'll double check with my host and get back to you.
                  • 10189
                  • 109 Posts
                  However, I have on several occasions emptied the /core/cache/ directory in order to clear the cache when fiddling with system settings and MODx have been able to recreate the folders within. That seems to show that it does indeed have write access, no?

                  Update: Just got confirmation from my host that they are indeed using suexec. [ed. note: frippz last edited this post 14 years, 8 months ago.]
                    • 10189
                    • 109 Posts
                    Any suggestions about where to start troubleshooting now? I'm out of ideas. sad
                      • 10189
                      • 109 Posts
                      Just for fun, I installed a fresh copy of MODx directly on the server just to see if something might've caused the errors when I transferred the main site from my Ubuntu devserver. The install process went on without any apparent errors, but when I tried to log in to the manager, I got this:

                      Fatal error: Class 'modContext_' not found in /www/web/domain.com/testmodx/core/xpdo/xpdo.class.php on line 717


                      Checking the /core/cache/logs/ dir shows a few logs:

                      /core/cache/logs/error.log

                      /core/cache/logs/install.config.20120121T101855.log
                      /core/cache/logs/install.config.20120121T101857.log
                      /core/cache/logs/install.config.20120121T101904.log


                      As I said before, my host confirms that suexec is used and that everything should be perfectly writable, so what else could cause these errors? [ed. note: frippz last edited this post 14 years, 8 months ago.]