We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36977
    • 36 Posts
    I've recently installed 2.2 and the Articles addon. I've made a new blog, and added a couple of posts. I can view them on my website, but am unable to see them in the manager.

    When I right click on my Blog and select "Manage Articles" the screen just refreshes but only the file structure and top level menu is visible. Am I missing something or is something broken? Surely I should be able to view the articles once created?

    There is nothing displayed on the blogpost under the headings for "tags" and "archives". Given that there are definitly two posts there, complete with several tags, there should be something there too?
      • 36977
      • 36 Posts
      I sorted out the issue with the tags and archive by re-installing the addon Archivist, and TagLister.

      Now the issue of not being able to see the articles in the manager is all that remains.

        • 28215
        • 4,149 Posts
        Please post any errors from your core/cache/logs/error.log file, as well as any browser JS errors.
          shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
          • 36977
          • 36 Posts
          Ok, so not sure what happened, but this morning it has started working! Thanks
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            I think that stale browser cookies are causing a lot of these Articles problems. I've found that not even clearing sessions or logging out is sufficient; there are still cookies for the domain in my browser. Quite a lot of things don't work until I actually close the browser (I have my browser set to only keep cookies for a few domains when I close the browser) or manually remove the cookies.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 38314
              • 45 Posts
              Hi,

              I've got the same problem with Articles 1.4.3 and 2.2.

              @meemal : if you need to edit your articles, and you can't get access from "manage articles", you can search for the title of your article in the "ressources" tab. That's the way I do, waiting the issue to be solved.

              @splittingred :
              These are my last lines of the error.log but there's nothing about "Articles" in the others...
              2012-01-13 08:07:21] (ERROR @ /modx/connectors/workspace/packages.php) MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
              [2012-01-13 08:07:21] (ERROR @ /modx/connectors/workspace/packages.php) MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
              [2012-01-13 08:07:21] (ERROR @ /modx/connectors/workspace/packages.php) Impossible de transférer le paquet getpage-1.2.2-pl.transport.zip vers /homez.383/www/modx/core/packages/.
              [2012-01-13 08:07:21] (ERROR @ /modx/connectors/workspace/packages.php) Impossible de transférer le paquet getpage-1.2.2-pl.transport.zip vers /homez.383/www/modx/core/packages/.


              See attachment too.

              Hope that can help, this module is so nice !
                • 36977
                • 36 Posts
                @squarou Thanks for the handy tip!
                  • 4750
                  • 28 Posts
                  I have the same problem of the articles not showing. Has anyone found a solution for it?
                    • 17399
                    • 4 Posts
                    I have just done a clean install of modx 2.2 and Articles 1.4.3 and got the same issue, I am unable to manage Articles, that's a bit annoying as I cannot edit any settings.

                    I have tested other browser and computers = same issue, only the Ressources tree is visible.
                      • 34120
                      • 236 Posts
                      I have a similar problem but in reverse. I can add/view/edit my articles in the manager but they are not appearing on the frontend. I've uninstalled articles and completely cleared everything and started again with a clean install but still have the same problem. I can view each individual article without any problem but they don't appear on the article home page. I'm using the default templates provided.

                      I'm not intending to hijack the thread, it's kind of related smiley I'm pretty stumped now so any suggestions appreciated.
                      Many thanks

                      [edit] Solved this. For some reason getResources was not installed. Is this usually installed with Articles? [ed. note: bobwal last edited this post 14 years, 8 months ago.]