I'd really like to give Revo 2.2 a try, but I'm having trouble with my installation. Everything goes well until I log in to the Manager. When I log in, nothing is styled. No CSS, no javascript. I can't see the resource tree, just an unordered list for the main navigation and the content of the dashboard widgets.
I'm using Wampserver 2.2 as my local server:
Apache 2.2.21
php 5.3.8
MySQL 5.5.16
I've tried installing this a number of times with the same result. Funny thing is, this doesn't happen with Revo 2.1.5-pl. I've also tried searching for similar issues in the forums, but haven't found any answers.
Thanks for shedding any light on this for me.
- Any errors in error.log?
- Any errors in JS console?
- What browser?
I'm willing to bet minify is the issue here, and there's something misconfigured with your environment.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
error.log contained the following:
[2011-12-09 19:15:38] (ERROR @ /personal/modx/revo/index.php) Error 42S22 executing statement:
Array
(
[0] => 42S22
[1] => 1054
[2] => Unknown column 'modUser.primary_group' in 'field list'
)
[2011-12-09 19:15:39] (ERROR @ /personal/modx/revo/index.php) Error 42S22 executing statement:
Array
(
[0] => 42S22
[1] => 1054
[2] => Unknown column 'modTemplateVar.source' in 'field list'
)
[2011-12-09 19:15:39] (ERROR @ /personal/modx/revo/index.php) Error 42S22 executing statement:
Array
(
[0] => 42S22
[1] => 1054
[2] => Unknown column 'modTemplate.source' in 'field list'
)
[2011-12-09 19:15:39] (ERROR @ /personal/modx/revo/index.php) Error 42S22 executing statement:
Array
(
[0] => 42S22
[1] => 1054
[2] => Unknown column 'hide_children_in_tree' in 'field list'
)
Not sure where to find the JS console information.
I'm using Firefox 8.0.
This sounds like you had a failed upgrade. Did you use advanced or traditional? Try upgrading again.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
-
MODX Staff
- 10,725 Posts
You can turn off the compress_js and compress_css settings in the system_settings table (then manually clear the cache) and use the manager for now. The minification library we are using is not working if the manager is not within the defined $_SERVER['DOCUMENT_ROOT'] on your system. There is no other solution yet, until the limitations in the minification library are resolved.
-
MODX Staff
- 10,725 Posts
FWIW, the minify issue should now be resolved in the latest nightly. If anyone experiencing this issue can confirm, that would be excellent.