We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33014 ☆ A M B ☆
    • 1,231 Posts
    並行開発なんだと思います。とりあえずは0.9.6.3だけ追っていればよいのでは。
    1.0で目標とする機能と0.9.6.3で盛り込む機能を切り分けるのだと思います。
    現時点ではmanager/processors/ あたりがいろいろ違うみたい。
      • 33014 ☆ A M B ☆
      • 1,231 Posts
      trunkのバージョン表記が今日から「0.9.6.3-RC1」(rev 4291)になりました。
      branchesと状態がかなり離れているのが気になります。可能な限りマージを期待。
        • 33014 ☆ A M B ☆
        • 1,231 Posts
        http://modxcms.com/forums/index.php/topic,29673.0.html
        公式アナウンスが出てました。
          • 33014 ☆ A M B ☆
          • 1,231 Posts
          http://modxcms.com/forums/index.php/topic,29675.0.html

          できれば今週中にまとめたいので、テストにご協力ください。という感じです。(たぶん)
          今回のアップデートの主な目的は例のエンコードまわりのトラブル対応のようなので、
          日本ユーザからの声も聞きたいところではと思います。

          現時点での0963RC版のアップデート内容は以下のとおり。

          MODx 0.9.6.3-RC1 (rev 4291 - October 12, 2008)
          ===================================
          * [#MODX-415] Update German manager file
          * [FS#1011] Minor CSS change to color of Unread Message links
          * [#MODX-365] Fix some hardcoded language strings in the Access Permissions pages
          * [#MODX-389] Convert TV Input Options field to be a textarea
          * [#MODX-394] Updating incorrect language string in installer
          * Updated AjaxSearch to version 1.8.1
          * Fix to user permissions class (thanks Dimmy!)
          * [#MODX-351] Update eForm to version 1.4.4.5
          * [#MODX-352] Update Jot to version 1.1.4
          * [#MODX-304] Update Japanese language file for Quickedit
          * [FS#1052] Fix CC bug in PHPMailer class
          * [FS#806] Allow ’.’,’-’, and ’_’ in TV names - manually encode these as rawurlencode() doesn’t convert them (related to [#MODX-154])
          * [FS#833] Fix inconsistent Stay buttons (use labels like on other pages)
          * [FS#1037] Prevent currently logged-in user password update logging out without displaying the new password
          * [FS#944] Enable RTE for TVs when creating/editing a weblink
          * Fix urldecode() bug with ’refurl’ querystring parameter in WebLogin
          * [FS#548] Preserve querystring parameters when logging in/logging out with WebLogin
          * [FS#1074] Apply DataGrid patch
          * Add default sort order for new template variables, prevents ’$rs not set’ error
          * [FS#900] Fix incorrect system setting for default template on install (without demo content)
          * [FS#392] Add optional separator parameter to $modx->getTemplateVarOutput() for checkbox/multiselect lists
          * [FS#895] Fix Captcha implementation in WebSignup snippet
          * [FS#912] Add charset encoding to page title htmlentities() call in the Manager search
          * [FS#1073] Duplicate TV associations when duplicating a template
          * [FS#283] Allow Weblogin to work with password-less registration forms by generating random password if no password POST value is passed
          * [FS#687] Fix the [+surl+] placeholder in the Weblogin snippet
          * [FS#999] Prevent log error when connecting to a second database
          * [#MODX-154] rawurlencode() TV names so TVs with spaces in the name can be saved when editing/creating a document
          * [FS#1032] Convert TV saving in save_content.processor.inc.php to use three-stage DELETE/INSERT/UPDATE method
          * [FS#978] manage keywords length not limited to varchar(40) DB value
          * [CR-MODX-39] Button Back in Upgrade Existing Install goes to wrong screen.
          * [#MODX-188] Default installation language set to english, patch from CR-MODX-28.
          * [FS#907] Small fix to QuickEdit to correctly include JS/CSS files if friendly alias paths are being used and no <base> tag is specified in the template
          * [#MODX-139] Updated cache_sync.class.processor.php to use $modx->db methods instead of mysql functions.
          * [FS#1003] Amend the top username link to explicitly state a ’change password’ link instead of just linking the username
          * [#MODX-362] Added database version to MySQL DBAPI class and to the System Information report
          * Switched double quotes to single quotes and added minor speed improvements to files.dynamic.php
          * [#MODX-209] File manager can now handle files with illegal url characters (added urlencode escaping).
          * [#MODX-219] Fix broken image paths
          * [#MODX-179] Duplicating resources now duplicates the category setting as well
          * [#MODX-290] Minimum PHP requirement updated in language files to 4.2.0
          * [#MODX-168] Fix issue where phantom keywords metatag could be added to document due to haskeywords setting being out of sync
          * [FS#1078] Fix duplicate content processor for MySQL versions < 4.0.14
          * [#MODX-303] Update DocManager Japanese language file
          * [#MODX-158] Remove broken stylesheet references from DocManager module
          * [#MODX-244] Fix the display of user and web user photos in the manager
          * [#MODX-140] Make Security Notices and News items open in new tab/window
          * [#MODX-341] Ensure duplicate aliases have the number suffix properly incremented
          * [FS#1065] Fix problem with losing selected metatags when editing documents
          * Changing TVs no longer looses the sort order on templates to which they’re assigned (revisited)
          * [FS#1056] Fix error with updateMail JS function being called in header.inc.php
          * [#MODX-126] configure the URL of the Security Notice and modx News feeds in manager Site Settings - patch by Jesse Rochman and Magpie fix for Japanese language by MEGU
          * [#MODX-185] Problems with original SET NAMES vs SET CHARACTER SET patches resolved.
          * [#MODX-289] Fix was not merged into trunk for 0.9.6.2 release.
          * Fix MySQL Strict mode problem in save_content.processor.php
          * [FS#1038] Fix consistency of ’z=manprev’ for document preview in manager code
          * [FS#1066] Fix problem with Newspublisher snippet and the calendar showing a 404 error when using the FormBlog chunk template
          * [FS#1062] Fix Weblogin snippet to correctly block users for period of time specified in system settings if they reach the maximum failed attempts
          * [FS#1079] Apply URL TV patch to Doc Manager module
          * [#MODX-218] Fix broken image paths in Newspublisher snippet
          * [#MODX-266] Stop .svn folder appearing on help screen if MODx install was checked out from SVN
          * [FS#1076] [FS#853] Fix calendar JS error occurring if calendar TV name contains an hyphen
          * Updated TinyMCE to version 3.2.0.1
          * [FS#1036] Moved Rewrite Browser Paths (strip_image_paths) in configuration so that it’s editable even when Enable Resource Browser is set to ’no’.
          * [FS#665] Fixed ViewPort Javascript code errors (thanks to Antonio)
          * [FS#1027] Added ’Path to CSS file’ to user configuration so that it can be overridden on a per user basis
          * [FS#821] Fixed Javascript Error using QuickEdit and IE7 (thanks to Marc [MadeMyDay])
          * [FS#939] Fixed recordset handling for ticker widget and replaced ticker javascript with Moostick.

            • 29908
            • 95 Posts
            こんにちは、thrです。

            MODxバージョン 0.9.6.3
            コードネーム rev 4293
            Database Version: 4.0.25-standard
            サーバー ヘテムル

            上記の内容でインストールしてみました。

            気になった事は下記

            ・インストールのデータベースでWarning
            Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/sites/heteml/users37/d/-/s/d-sity01/web/net/modx-test/install/connection.collation.php on line 14
            以前も確認したものですが、一応

            ・新しい言語ファイルになっているか?
            マネージャ→管理画面、 など翻訳を一部変える予定ありませんでしたっけ? yamaさん

            ・ajaxサーチが動かない(2バイト文字じゃなくても)
            « MODx Parse Error »
            MODx encountered the following error while attempting to parse the requested resource:
            « Execution of a query to the database failed - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ’( DISTINCT CAST(ntv.id AS CHAR) SEPARATOR "," ) AS tv_id, GROUP »
            SQL: SELECT sc.id, sc.pagetitle, sc.longtitle, sc.description, sc.alias, sc.introtext, sc.menutitle, sc.content, sc.publishedon, GROUP_CONCAT( DISTINCT CAST(ntv.id AS CHAR) SEPARATOR "," ) AS tv_id, GROUP_CONCAT( DISTINCT ntv.value SEPARATOR ", " ) AS tv_value FROM `modxtest_site_content` sc LEFT JOIN( SELECT DISTINCT tv.id, tv.value, tv.contentid FROM `modxtest_site_tmplvar_contentvalues` tv WHERE (((tv.value LIKE ’%Install%’))) ) AS ntv ON sc.id = ntv.contentid WHERE ((sc.published=1) AND (sc.searchable=1) AND (sc.deleted=0) AND (sc.type=’document’) AND (sc.privateweb=0)) GROUP BY sc.id HAVING (((sc.pagetitle LIKE ’%Install%’) OR (sc.longtitle LIKE ’%Install%’) OR (sc.description LIKE ’%Install%’) OR (sc.alias LIKE ’%Install%’) OR (sc.introtext LIKE ’%Install%’) OR (sc.menutitle LIKE ’%Install%’) OR (sc.content LIKE ’%Install%’) OR (tv_value LIKE ’%Install%’))) ORDER BY sc.publishedon,sc.pagetitle
            [Copy SQL to ClipBoard]

            Parser timing
            MySQL: 0.0058 s (0 Requests)
            PHP: 1224063744.4159 s
            Total: 1224063744.4217 s
            サンプルコンテンツのajaxサーチでためしたのですが、英語で検索かけても動きませんでした。上記エラーが出ていました。
            データベースのバージョンが低いからかなぁ。。。

            とりあえず、テスト報告です。
              MODx CMS JAPAN
              モデレータ(日本公式とか、広報とか、雑務担当?)
              thr
              • 33014 ☆ A M B ☆
              • 1,231 Posts
              Quote from: thr at Oct 15, 2008, 04:55 AM

              ・インストールのデータベースでWarning
              Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/sites/heteml/users37/d/-/s/d-sity01/web/net/modx-test/install/connection.collation.php on line 14
              このWarningは「@」を1文字追加するだけで出力しないようにできますが、開発チームに
              どう伝えようかと思案してます。あるいは、生WarningじゃなくてちゃんとWarning出力の
              コードを追加するかですね。後者のほうがいいと思いますけど。

              Quote from: thr at Oct 15, 2008, 04:55 AM
              ・新しい言語ファイルになっているか?
              マネージャ→管理画面、 など翻訳を一部変える予定ありませんでしたっけ? yamaさん
              いちおうライアンにもPMで先ほど直接伝えておきました。管理画面に関しては8月ごろに提出したものが
              先日適用されて、だいぶ変わったのではないかと思いますが。他に追加待ちのぶんとしては、Phizeさんに
              最後まできれいに翻訳していただいたdittoの言語ファイル等があります。

              Quote from: thr at Oct 15, 2008, 04:55 AM
              ・ajaxサーチが動かない(2バイト文字じゃなくても)
              « MODx Parse Error »
              MODx encountered the following error while attempting to parse the requested resource:
              « Execution of a query to the database failed - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ’( DISTINCT CAST(ntv.id AS CHAR) SEPARATOR "," ) AS tv_id, GROUP »
              SQL: SELECT sc.id, sc.pagetitle, sc.longtitle, sc.description, sc.alias, sc.introtext, sc.menutitle, sc.content, sc.publishedon, GROUP_CONCAT( DISTINCT CAST(ntv.id AS CHAR) SEPARATOR "," ) AS tv_id, GROUP_CONCAT( DISTINCT ntv.value SEPARATOR ", " ) AS tv_value FROM `modxtest_site_content` sc LEFT JOIN( SELECT DISTINCT tv.id, tv.value, tv.contentid FROM `modxtest_site_tmplvar_contentvalues` tv WHERE (((tv.value LIKE ’%Install%’))) ) AS ntv ON sc.id = ntv.contentid WHERE ((sc.published=1) AND (sc.searchable=1) AND (sc.deleted=0) AND (sc.type=’document’) AND (sc.privateweb=0)) GROUP BY sc.id HAVING (((sc.pagetitle LIKE ’%Install%’) OR (sc.longtitle LIKE ’%Install%’) OR (sc.description LIKE ’%Install%’) OR (sc.alias LIKE ’%Install%’) OR (sc.introtext LIKE ’%Install%’) OR (sc.menutitle LIKE ’%Install%’) OR (sc.content LIKE ’%Install%’) OR (tv_value LIKE ’%Install%’))) ORDER BY sc.publishedon,sc.pagetitle
              [Copy SQL to ClipBoard]

              Parser timing
              MySQL: 0.0058 s (0 Requests)
              PHP: 1224063744.4159 s
              Total: 1224063744.4217 s
              サンプルコンテンツのajaxサーチでためしたのですが、英語で検索かけても動きませんでした。上記エラーが出ていました。
              データベースのバージョンが低いからかなぁ。。。
              うーん。DBのバージョンとしては、公式にサポートされてないバージョンですよね。
              バージョンが古いとこのへんが関係してくるのかな。
              目が慣れてないのでよく分からないすけど、
              Check the manual that corresponds to your MySQL server version for the right syntax
              とか出てますね。
                • 36592
                • 970 Posts
                Quote from: thr at Oct 15, 2008, 04:55 AM
                ・ajaxサーチが動かない(2バイト文字じゃなくても)
                « MODx Parse Error »
                MODx encountered the following error while attempting to parse the requested resource:
                « Execution of a query to the database failed - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ’( DISTINCT CAST(ntv.id AS CHAR) SEPARATOR "," ) AS tv_id, GROUP »
                SQL: SELECT sc.id, sc.pagetitle, sc.longtitle, sc.description, sc.alias, sc.introtext, sc.menutitle, sc.content, sc.publishedon, GROUP_CONCAT( DISTINCT CAST(ntv.id AS CHAR) SEPARATOR "," ) AS tv_id, GROUP_CONCAT( DISTINCT ntv.value SEPARATOR ", " ) AS tv_value FROM `modxtest_site_content` sc LEFT JOIN( SELECT DISTINCT tv.id, tv.value, tv.contentid FROM `modxtest_site_tmplvar_contentvalues` tv WHERE (((tv.value LIKE ’%Install%’))) ) AS ntv ON sc.id = ntv.contentid WHERE ((sc.published=1) AND (sc.searchable=1) AND (sc.deleted=0) AND (sc.type=’document’) AND (sc.privateweb=0)) GROUP BY sc.id HAVING (((sc.pagetitle LIKE ’%Install%’) OR (sc.longtitle LIKE ’%Install%’) OR (sc.description LIKE ’%Install%’) OR (sc.alias LIKE ’%Install%’) OR (sc.introtext LIKE ’%Install%’) OR (sc.menutitle LIKE ’%Install%’) OR (sc.content LIKE ’%Install%’) OR (tv_value LIKE ’%Install%’))) ORDER BY sc.publishedon,sc.pagetitle
                [Copy SQL to ClipBoard]

                Parser timing
                MySQL: 0.0058 s (0 Requests)
                PHP: 1224063744.4159 s
                Total: 1224063744.4217 s
                サンプルコンテンツのajaxサーチでためしたのですが、英語で検索かけても動きませんでした。上記エラーが出ていました。
                データベースのバージョンが低いからかなぁ。。。
                AjaxSearchはMySQL4.1以上のバージョンが必要とのことですよ~
                http://modxcms.com/forums/index.php?topic=27955.0
                  • 29908
                  • 95 Posts
                  こんばんは、thrです。

                  AjaxSearchはMySQL4.1以上のバージョンが必要とのことですよ~
                  http://modxcms.com/forums/index.php?topic=27955.0
                  あっそのとおりですね。ありがとうございます。サーバーを変えようかと考えていたら、ヘテムルそろそろmysql5に対応するみたい。。うーん。まだこのサーバーつかうかな。

                  yamaさん
                  dittoの言語ファイルのバージョンは
                  japanese-utf-8.inc.php
                  Version: 2.0.2
                  でした。これってまだ最新じゃないんですかね。


                  ローカルサーバーでもテストしました。
                  XAMPP 2.5
                  rev 4293
                  Database version 5.0.67-community-nt

                  ajaxサーチも英語、マルチバイト(日本語)両方ちゃんとうごきましたよ。
                  インストール時のデータベースのWarningもでません。

                  とりあえず、報告でした。。。
                  あっなにか、チェックしたほうが良いところありますか?時間があるときにチェックしておきます。
                    MODx CMS JAPAN
                    モデレータ(日本公式とか、広報とか、雑務担当?)
                    thr
                    • 33014 ☆ A M B ☆
                    • 1,231 Posts
                    http://svn.modxcms.com/jira/browse/MODX-430
                    最新の言語ファイル(同梱リソースのぶんも含む)はここに上げてあります。
                    0963の同梱に間に合うかどうか微妙だけど。

                    チェックが特に必要なのは日本語まわりかなと思います。
                    テンプレートやチャンクも日本語普通に書けるかどうかなどですね。
                    僕はまだRCはインストールすらできてません orz
                      • 33014 ☆ A M B ☆
                      • 1,231 Posts
                      0963rc1対象の管理画面langファイルを更新しました。
                      いろいろ変えてます。パッと見て分かるところもあると思います。
                      ご意見ありましたら、お早めに(0963が出るまで?)よろしくお願いします。