Hi,
I did have friendly URLs working fine. However now I have many issues, and I don’t know why it suddenly doesn’t work.
- If friendly URLS are off everything works fine.
- Activating friendly URLs in Manager redirects to a frame giving a 404 error.
- Once friendly URLs are activated in the manager, every save of a page gives, immediatly after the save, a 404 error in the Manager.
- Once friendly URLS are activated in the manager, the URL of links generated, say using WayFinder, are not in their friendly form. However, manually typing in the friendly URL does result in the correct page showing. Thus to me it looks like the .htaccess file is working.
Any suggestions?
Michal.
-
☆ A M B ☆
- 24,524 Posts
After setting up friendly URLs did you clear your cache? If the pages were cached before the configuration, the pages would be taken from cache and still have the old-style urls in the menus.
As some more info: after activating friendly urls, the address of the frame with the 404 error is http://[mydomain]/manager/index.php?a=30
Edit: I have just discovered that everything is fine if "Use friendly alias path" is set to no. If it is set to yes I get the errors above.
Michal.
-
☆ A M B ☆
- 24,524 Posts
Did you rename the ht.access in the /manager folder? It does nothing more than turn off the rewrite engine for the /manager folder.
I have now discovered some othere 404 errors occuring. So in summary:
If friendly urls *and* friendly alias paths are selected
- Saving confuration results in a 404 error in the Manager "content window"
- Saving any page in the manager has the same result (but the save does seem successful)
- Saving any template has the same result
- Pages deeper than the site root are *not* accesible using their friendly url. They only seem to be accessible using index.php?id=[idofpage]
Michal.
... and another strange thing. With friendly aliases enabled, the clear cache button in manager does seem to clear the cache (i.e. removes the docid* files from the cache directory), but the page in the manager does not report this. It just says:
Refresh Site
0 documents were published
0 documents were unpublished.
Michal.
And when the configuration is saved with friendly alias on, I notice a 13mb file named "core" appears in the manager directory.
Michal.