We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19315
    • 84 Posts
    Hi,

    I did have friendly URLs working fine. However now I have many issues, and I don’t know why it suddenly doesn’t work.

    - If friendly URLS are off everything works fine.
    - Activating friendly URLs in Manager redirects to a frame giving a 404 error.
    - Once friendly URLs are activated in the manager, every save of a page gives, immediatly after the save, a 404 error in the Manager.
    - Once friendly URLS are activated in the manager, the URL of links generated, say using WayFinder, are not in their friendly form. However, manually typing in the friendly URL does result in the correct page showing. Thus to me it looks like the .htaccess file is working.

    Any suggestions?

    Michal.
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      After setting up friendly URLs did you clear your cache? If the pages were cached before the configuration, the pages would be taken from cache and still have the old-style urls in the menus.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 19315
        • 84 Posts
        Quote from: sottwell at Mar 24, 2008, 03:17 PM

        After setting up friendly URLs did you clear your cache?
        I have now, but still the same issue.

        Also, the initial 404 error immediately after turning on friendly urls I would imagine should never occur...?

        Michal.
          • 19315
          • 84 Posts
          As some more info: after activating friendly urls, the address of the frame with the 404 error is http://[mydomain]/manager/index.php?a=30

          Edit: I have just discovered that everything is fine if "Use friendly alias path" is set to no. If it is set to yes I get the errors above.

          Michal.
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            Did you rename the ht.access in the /manager folder? It does nothing more than turn off the rewrite engine for the /manager folder.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 19315
              • 84 Posts
              Quote from: sottwell at Mar 24, 2008, 11:48 PM

              Did you rename the ht.access in the /manager folder? It does nothing more than turn off the rewrite engine for the /manager folder.
              Initially no: I, umm, forgot. However, I remember everything working fine: i.e. adding/updating pages worked fine with an un-renamed ht.access. I did once the issues started, but they still occurred even with .htaccess in the /manager folder

              Michal.
                • 19315
                • 84 Posts
                I have now discovered some othere 404 errors occuring. So in summary:

                If friendly urls *and* friendly alias paths are selected
                - Saving confuration results in a 404 error in the Manager "content window"
                - Saving any page in the manager has the same result (but the save does seem successful)
                - Saving any template has the same result
                - Pages deeper than the site root are *not* accesible using their friendly url. They only seem to be accessible using index.php?id=[idofpage]

                Michal.
                  • 19315
                  • 84 Posts
                  ... and another strange thing. With friendly aliases enabled, the clear cache button in manager does seem to clear the cache (i.e. removes the docid* files from the cache directory), but the page in the manager does not report this. It just says:

                  Refresh Site
                  0 documents were published
                  0 documents were unpublished.

                  Michal.
                    • 19315
                    • 84 Posts
                    And when the configuration is saved with friendly alias on, I notice a 13mb file named "core" appears in the manager directory.

                    Michal.
                      • 22303 MODX Staff
                      • 10,725 Posts
                      Quote from: michalc at Mar 25, 2008, 06:49 AM

                      And when the configuration is saved with friendly alias on, I notice a 13mb file named "core" appears in the manager directory.
                      That is an Apache core dump file and tells me there is a significant problem with your PHP configuration in Apache.

                      This discussion is closed to further replies. Keep calm and carry on.