We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15202
    • 6 Posts
    Hi everyone,

    I’m new to Revo/Gallery and deeply sorry that I still have the problem: no images and no thumbs, neither front- nor backend. Everything was fine with Revo 2.1.0 and Gallery 1.2.0. After update to Revo 2.1.1.pl all image were gone and the Gallery update to 1.2.1. didn’t solve the problem.

    additional info:
    - Server: HostEurope WebPack 3.0 L
    - no domain assigned yet (I’m using the root (?) of my webspace: http://complicated.path.blabla.hosteurope.de/folder/hereitis)
    - no multiple contexts
    - didn’t change location of any of the folders
    - gallery.thumbs_prepend_site_url to yes/no - didn’t have any effect
    - clearing cache/different browser - no effect
    - all images are there (via ftp or filebrowser)
    - there is no folder assets/components/phpthumb
    - do I have to install phpthumb?
    - deleting and recreating the albums didn’t help
    - firefox 5.0
    - mysql 5.1.49-3~bpo50+1-log

    Here are some excerpts from core/cache/logs/error.log
    I don’t have the slightest idea what all that means but maybe some of the experts can spot the cause of my problem.

    ...
    [2011-06-30 16:01:00] (ERROR @ /revo/01/index.php) Could not load class: Gallery from gallery.
    [2011-06-30 16:01:00] (ERROR @ /revo/01/index.php) Problem getting service gallery, instance of class Gallery, from path /is/htdocs/blablablabla/www/revo/jcsite/core/components/gallery/model/gallery/
    ...
    [2011-06-30 16:28:41] (ERROR @ /revo/01/manager/index.php) Path specified for package gallery is not a valid or accessible directory: /is/htdocs/blablablabla/www/revo/jcsite/core/components/gallery/model/
    [2011-06-30 16:28:41] (ERROR @ /revo/01/manager/index.php) Could not load class: GalControllerRequest from gallery.request.galcontrollerrequest.
    [2011-06-30 16:32:12] (ERROR @ /revo/01/assets/components/gallery/connector.php) [Gallery] Error outputting thumbnail:
    phpThumb() v1.7.9-200712090829
    ...
    OutputThumbnail() failed - headers already sent in file "phpthumb.class.php" on line 3647
    [2011-06-30 16:32:12] (ERROR @ /revo/01/assets/components/gallery/connector.php) [Gallery] Error outputting thumbnail:
    phpThumb() v1.7.9-200712090829
    ...
    <b>Strict Standards</b>: strftime() [<a href=’function.strftime’>function.strftime</a>]: It is not safe to rely on the system’s timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CEST/2.0/DST’ instead in <b>/is/htdocs/blablablabla/www/revo/01/core/xpdo/xpdo.class.php</b> on line <b>1630</b>

    [2011-07-02 18:44:46] (ERROR @ /is/htdocs/blablablabla/www/revo/01/core/xpdo/xpdo.class.php : 1967) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected
    [2011-07-02 19:05:37] (ERROR @ /revo/01/assets/components/gallery/connector.php) Error caching lexicon topic lexicon/de/gallery/default


    I’m really sorry to bother you all. I guess if nobody can help me, I’ll have to cry and go back to Evo and MaxiGallery ...

    ka8578

      • 28215
      • 4,149 Posts
      1. Is /is/htdocs/blablablabla/www/revo/jcsite/core/ where your MODX core is?
      2. You need to set the date.timezone setting in your php.ini
      3. Ensure the "gallery.*" settings like "gallery.core_path" and "gallery.assets_url" are correct.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 15202
        • 6 Posts
        grin It’s working - finally! Thank you for your hint with the php.ini (this actually wasn’t the root of the problem but it made me call the support of my provider which eventually led to it). Anyway, here is what solved my problem:

        On my webspace, I had to change two script settings
        PHP-allow_url_fopen Off => On
        PHP-allow_url_include Off => On

        And that was it! Days of searching, checking, double-checking, posting, reading, double-reading ... and then: just two clicks.
        I’m just wandering why it had all worked before the upgrade to Revo 2.1.1. - with just the same script settings? Hmmm ...?

        Anyway, I don’t care anymore and I’m so full of joy I just donated a few dollars to modx. THANKS!
          • 36444
          • 2 Posts
          Hey,

          I've got exactly the same problem as this! How would I change the PHP settings you mention above?:

          PHP-allow_url_fopen Off => On
          PHP-allow_url_include Off => On

          Where can I find the option to change this?

          Thanks a million!
          Ben
            • 36444
            • 2 Posts
            I've been told that both of the above PHP settings are set to on, on the server. So it isn't that causing the problem.

            However I checked to see if they had Imagemagick installed, and I got the this reply...

            "The server does not run imagemagick unfortunately, we run something similar called : GD Library (2.0.34 compatible)"

            Will this definitely be the problem? I won't be able to change server, as my client has already purchased the hosting. Any suggestions?

            Also, I'm not sure if everyone else has had *exactly* the same problem as me; all my thumbnails do not always appear broken, it's a random selection that don't load everytime. Different ones each time. So on the whole it's working, but not really! This is why I'm SO confused.


              • 1809
              • 15 Posts
              http://phpsec.org/projects/phpsecinfo/tests/allow_url_include.html

              <<By default, allow_url_include is disabled. We strongly recommend keeping it disabled.>>

              So what?
                • 37031
                • 93 Posts
                This was the solution for my issue. Thanks fux0r!
                  • 38000
                  • 19 Posts
                  Okay I had similar problems... as I tried to watch those images it told me something of a path... and another path for phpthumb - never did anything like this.

                  /var/syscp/webs/kermit/ichspiele.cc/ismodx22/3/2.jpg <--- it tried to reach the image files there. But the file_path was set to /var/syscp/webs/kermit/ichspiele.cc/ismodx22/images/gallery/... don't know why this gallery snippet does not read its own settings.
                    • 38000
                    • 19 Posts
                    Okay I had similar problems... as I tried to watch those images it told me something of a path... and another path for phpthumb - never did anything like this.

                    /var/syscp/webs/kermit/ichspiele.cc/ismodx22/3/2.jpg <--- it tried to reach the image files there. But the file_path was set to /var/syscp/webs/kermit/ichspiele.cc/ismodx22/images/gallery/... don't know why this gallery snippet does not read its own settings.
                      • 41958
                      • 65 Posts
                      Hi,

                      I ahve the latest gallery 1.5.2 and revolution is 2.2.5-pl (traditional).
                      I also have this problem when I can not see the thumbnails in the manager or on thr front end. When I click on the name of the image on the front end it also not showing anything.
                      phpthumbof 1.4.0 is working fine.
                      I also have modx in a sub folder.

                      I discovered that the source code when I click the image has a wrong path:
                      wrong: munkak/modx/munkak//assets/gallery/1/8.jpg
                      should be: munkak/modx/assets/gallery/1/8.jpg

                      Anyone knows shere to fix that?
                      any ideas? [ed. note: openstep last edited this post 13 years, 8 months ago.]