We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 7923
    • 4,213 Posts
    I believe that the fourth parameter of mm_createTab function call should be a Template ID to wich apply the tab and not document ID.


      "He can have a lollipop any time he wants to. That's what it means to be a programmer."
      • 14900
      • 22 Posts
      Thanks Doze, you put me on the right path with that 4th parameter applying to the template ID, not document ID...

      It appears that with the mm_widget_mg_backend_manager, you don’t have to create tabs separately with standard managermanager calls.

      Using only this line in my mm_rules chunk:

      mm_widget_mg_backend_manager(181,’Edit This Gallery’,’’,26);

      unique tabs for each gallery were applied to only documents set to use the template with ID 26

      I think the combination of Maxigallery and this backend manager are pretty amazing, kudos to everyone involved in developing the code.
        • 25803 ☆ A M B ☆
        • 721 Posts
        So, to review.

        Download the MaxiGallery Back End Manager from here:

        http://modxcms.com/forums/index.php/topic,29875.0.html (i.e. this thread)

        Make the following change to the mg_backend_manager.php file:

        Change:

        $('iframe').load(function()


        To:

        \$j('iframe').load(function()


        Upload the assets to the Widgets folder: \assets\plugins\managermanager\widgets.
        Follow the instructions to setup the page, the snippet, etc.

        When editing a Gallery page, select Save and continue to activate seeing the Gallery controls in the back end.

        This is all for Evo 1.2.

        I’m using MaxiGallery 6 and the SmoothGallery components without any results. I’ll try another type of Gallery in MaxiGallery.

        Follow the instructions to install this and setup the snippet and the page.
          • 25803 ☆ A M B ☆
          • 721 Posts
          Got this to work but I have a curious problem. The same gallery shows up in every document when I go to the gallery tab. Even on pages without a MaxiGallery call and even on pages with a MaxiGallery call and a different ID.

          For a page with a gallery on it I include this call:

          [!MaxiGallery?&gal_query_ids=`[*id*]`&display=`embedded`&embedtype=`slimbox`&pics_per_row=`1`&max_thumb_size=`180`&max_pic_size=`0`&thumb_use_dropshadow=`0`!]


          I’ve tried setting the ID manually but no difference is made. I imagine my process is in error?
            • 7455
            • 2,204 Posts
            nope it happens when you start a new document at that point there is no id for the gallery to use so its using the id from the page you call to manage the gallery, I made a moification a while back let me see if I can find it ...

            Here you go:
            http://modxcms.com/forums/index.php/topic,29875.msg210416.html#msg210416

            its a mod on one of the first versions so maybe compare a bit instead of overwriting the whole file.
              follow me on twitter: @dimmy01
              • 24393
              • 83 Posts
              i have been using this modification on a portfolio site and sometimes if i edit a gallery, the entire galleries folder is deleted. i would definitely advise against using this on a live site!
                stevesunderland.com
                GRAPHICS | INTERACTIVE | MARKETING
                xhtml + ajax + seo websites powered by modx
                • 7455
                • 2,204 Posts
                Quote from: rajfantastic at Dec 09, 2009, 10:48 AM

                i have been using this modification on a portfolio site and sometimes if i edit a gallery, the entire galleries folder is deleted. i would definitely advise against using this on a live site!

                I use this on 5 sites already with no problems at all
                the only thing the mod does is when there is no id set then display message to first save if there is an id set then load the iframe, nothing in my mod can make a page delete a gallery.
                  follow me on twitter: @dimmy01
                  • 19002
                  • 32 Posts
                  I’ve successfully implemented maxigallery and the managermanager plugin in the past, but for some reason this time around I’m getting nothing but a head-ache. i’ve been following the thread discussion on getting it to work with EVO but I keep getting this error:

                  "ManagerManager - OnDocFormRender
                  An error occurred while loading. Please see the event log for more information.


                  Parse error: syntax error, unexpected ’<’ in /mnt/w0903/d36/s06/b0303a72/www/purpleorchiddesigns.com/assets/plugins/managermanager/mm.inc.php(350) : eval()’d code on line 1"


                  Anyone come across this or know how I can fix it?
                    • 7455
                    • 2,204 Posts
                    Quote from: mediassassin at Dec 30, 2009, 11:23 AM

                    I’ve successfully implemented maxigallery and the managermanager plugin in the past, but for some reason this time around I’m getting nothing but a head-ache. i’ve been following the thread discussion on getting it to work with EVO but I keep getting this error:

                    "ManagerManager - OnDocFormRender
                    An error occurred while loading. Please see the event log for more information.


                    Parse error: syntax error, unexpected ’<’ in /mnt/w0903/d36/s06/b0303a72/www/purpleorchiddesigns.com/assets/plugins/managermanager/mm.inc.php(350) : eval()’d code on line 1"


                    Anyone come across this or know how I can fix it?


                    maybe you forgot to remove the php tags around the script? snippets neet them plugin must NOT have them
                      follow me on twitter: @dimmy01
                      • 19002
                      • 32 Posts
                      maybe you forgot to remove the php tags around the script? snippets neet them plugin must NOT have them

                      thats exactly what i forgot too do Dimmy, thanks. But now I seem to be having an issue with the mask that mm.inc.php is creating to hide the tab creation.

                      It is just creating a white mask that covers the top portion of the resource editing pane, and no errors are being generated.

                      Has anyone come across this?