We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 1139
    • 8 Posts
    Just wanted to show my appreciation for this widget to Maxigallery & ManagerManager.

    It’s just saved me a huge amount of stress! Thanks so much for all involved! smiley
      • 4455
      • 76 Posts
      Howdy All,

      I’ll start by saying this looks like an awesome little widget!

      I’m just having a bit of trouble using it with manager permissions huh

      I have multiple access permissions in the manager and the pages than need the galleries are all locked to various users. First I gave the gallery holder page access to "All Document Groups" and got a permissions error. Then I checked all the permissions boxes in the manager and I’m still getting the same error...


      PHP error debug
      Error: move_uploaded_file() [function.move-uploaded-file]: SAFE MODE Restriction in effect. The script whose uid is 10037 is not allowed to access /var/www/vhosts/fake.com.au/httpdocs/assets/galleries/4 owned by uid 48
      Error type/ Nr.: Warning - 2
      File: /var/www/vhosts/fake.com.au/httpdocs/assets/snippets/maxigallery/maxigallery.php
      Line: 371
      Line 371 source: move_uploaded_file( $_FILES[’file’.$i][’tmp_name’] , $mg->path_to_gal.$name );

      Any ideas?

      I would guess I need to change the uid of the script? If so, how do I do it?

      BTW - I CHMODed assets/gallery to 777.

      Cheers
      Free
        • 7923
        • 4,213 Posts
        Your server is poorly configured, so PHP scripts who upload files don’t have rights to move them out of the temp directory. To get around this, you have to setup MaxiGallery to use FTP commands to upload the pictures.

        See MaxiGallery wiki page and all the parameters that have ftp in them.


          "He can have a lollipop any time he wants to. That's what it means to be a programmer."
          • 4455
          • 76 Posts
          Quote from: doze at Aug 03, 2009, 02:55 AM

          Your server is poorly configured, so PHP scripts who upload files don’t have rights to move them out of the temp directory.

          Cheers, any idea what I need to change on the server? My host is pretty good in fixing things for me.
            • 28042 ☆ A M B ☆
            • 24,524 Posts
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 4455
              • 76 Posts
              Thanks, I’ll see if they can turn it off for me.
                • 4455
                • 76 Posts
                O.K. I’ve turned off safe mode on the server and everything’s working great in the manager smiley

                Now I only have one more question...

                How do I actually make the images appear on the page?

                MaxiGallery has always done my head in, so I’m sure it’s something fairly simple I’m just too daft to see???

                I’ve tried child galleries calling all ID’s but can’t get anything to appear from any of the galleries on any page.

                Thanks
                Free

                EDIT - Forget that, got it going!

                Thanks for the help and an awesome module!!!
                  • 13137
                  • 204 Posts
                  I just upgraded to MODx v1.0 (Evo), added ManagerManager v0.3.4 and am receiving a javascript error whenever I open a page to edit:

                  ManagerManager: An error has occurred: TypeError - $("iframe") is null


                  I hit OK and everything else seems to be more or less as expected. Any ideas? undecided
                    • 13137
                    • 204 Posts
                    I have narrowed down where the error "null" is coming from in the code:

                    	$('iframe').load(function()
                    			{
                    				setTimeout(iResize, 0);
                    			}


                    But I can not figure out how to fix this.

                    Their aren’t any MODx gods willing to help out on this one? undecided
                      • 10957
                      • 32 Posts
                      Hello Islander, I think your problem has been solved here : http://modxcms.com/forums/index.php/topic,37985.msg232151.html#msg232151