We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 23546
    • 29 Posts
    Quote from: charless at Apr 22, 2010, 01:12 PM


    yeah, the local code depends on each system, but the same results are achieved from the example previously posted; I’ll get the localization of the date time fixed in the next release which will probably early next week

    if you can’t wait let me know and I make it happen sooner

    can’t believe I missed the core date time support on internationalization - sorry everyone
    undecided

    I can wait. Thank you!
      • 34084 ☆ A M B ☆
      • 756 Posts
      ISSUES: CAL_MOD_PATH Error
      Use of undefined constant CAL_MOD_PATH - assumed 'CAL_MOD_PATH'


      FIX:
      In the Snippet code for mxcalendar change the following line (#29):
      if (file_exists(CAL_MOD_PATH.'lang/'.$manager_language.'.lang'))

      -to-
      if (file_exists($modx->config['base_path'].'assets/modules/mxCalendar/lang/'.$manager_language.'.lang'))



      next in the Manager Module Edit code block change line (#24):
      if (file_exists(CAL_MOD_PATH.'lang/'.$manager_language.'.lang'))

      -to-
      if (file_exists($modx->config['base_path'].'assets/modules/mxCalendar/lang/'.$manager_language.'.lang'))


      Will be updated in next release smiley
        Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
        Visit CharlesMx.com for latest news and status updates.
        • 1892
        • 82 Posts
        Hi, just trying out the latest 0.0.5b.5 version. Most things work fine, although I’ve posted a couple of minor corrections on the google code site. However when I try to display an event with the google map enabled I get the following error message

        « MODx Parse Error »

        MODx encountered the following error while attempting to parse the requested resource:
        « PHP Parse Error »

        PHP error debug
        Error: simplexml_load_file(http://maps.google.com/maps/geo?q=HP21 9PP&output=xml) [function.simplexml-load-file]: failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request
        Error type/ Nr.: Warning - 2
        File: /home/sites/scaleseven.org.uk/public_html/modxEvo/assets/modules/mxCalendar/includes/google_geoloc.class.inc
        Line: 61
        Line 61 source: $xml = simplexml_load_file($reqAddress) or die("url not loading");

        I’ve tried putting the http: link into a browser to see if it returned anything which it does. So I’m a little bit stumped. Any clues about how to get this working or things I can try to debug the issue would be appreciated.

        Many thanks

        Adrian

        Post Update Solved: In previewing this post it illustrated the problem. The link in the error message stops half way due to the space in the postcode I’d entered in the location. So "HP21 9PP" doesn’t work but when I change it to "HP219PP" it all starts working (or it will do once I get the google map key sorted!).

        I’m not very proficient in php so I don’t know how it’ll work but is it possible for the link in simplexml_load_file() to be enclosed in quotes so that the location field can handle spaces?

        Thanks

        Adrian
          • 34084 ☆ A M B ☆
          • 756 Posts
          can you confirm your version of mxCalendar, please. There are a couple files that have the version number listed at the top:

          /mxCalendar/mxCalendar.class.php
          /mxCalendar/mxCalendar.tpl.php
          /mxCalendar/includes/calendar.inc.php

          try this for me:
          Edit line 61 of the file /assets/modules/mxCalendar/includes/google_geoloc.class.inc
          $xml = simplexml_load_file(urlencode($reqAddress)) or die("url not loading");
          


          I was not able to duplicate the error message, so please confirm your versions listed in the top of those files for me.

          Cheers
            Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
            Visit CharlesMx.com for latest news and status updates.
            • 34084 ☆ A M B ☆
            • 756 Posts
            I’m also able to use spaces in any address without error, does anyone else have any errors when using the space in the address field?
              Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
              Visit CharlesMx.com for latest news and status updates.
              • 1892
              • 82 Posts
              Thanks for the prompt reply

              /mxCalendar/mxCalendar.class.php
              /mxCalendar/mxCalendar.tpl.php
              are both at version 0.0.5b.5

              I added the urlencode() function to line 61 in google_geoloc.class.inc - yes that works fine. I don’t get any php parsing errors now when I have a space in the location field.

              However the next problem with google maps - although I’ve entered a google map key in the configuration tab, and I checked that the key seems to have been logged into the mxc config database table - when I go to the web page google flags up an invalid key warning. Checking the source it seems to call google maps with the key ABCDEFG rather than the key from the database.
              <script type="text/javascript" src="http://www.google.com/jsapi?key=ABCDEFG"></script>

              Any hints would be appreciated.

              Regards

              Adrian
                • 34084 ☆ A M B ☆
                • 756 Posts
                just removed the code update I had just posted, there is more bugs in the maps - working on the fix and will release an updated class file to fix that issues as I feel it’s a bigger problem.

                Cheers



                  Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
                  Visit CharlesMx.com for latest news and status updates.
                  • 34084 ☆ A M B ☆
                  • 756 Posts
                  FYI:

                  The calendar does support listing multiple addresses (Locations) using a pipe (|) to seperate the locations on the event entry form in the manager.

                  below is an example of the rendered map when the following is placed in the "Location" field:
                  524 Walnut kansas city mo 64106|75th and main kansas city mo 


                  also note the map in the next release is updated to API V3 AJAX for map rendering.

                  will update the package once some additional changes are completed.
                    Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
                    Visit CharlesMx.com for latest news and status updates.
                    • 1892
                    • 82 Posts
                    Thanks for the feedback - I know the updates will be worth waiting for.
                    Adrian
                      • 23546
                      • 29 Posts
                      Hi Charles,

                      I have some feedback for you... smiley

                      1) Could you please advice how to separate upcoming and archived events (list mode)? I don’t remember if it worked in 0.0.4 or not, but seems that currently it does not.

                      2) Current day was highlighted with black background in calendar mode in 0.0.4. In 0.0.5b.5 it does not.

                      3) In 0.0.4 font size of event date like ’25’ (Apr, 25) was 100%, while for the range of dates like ’25-26’ - 75% (list mode). There were 2 different parameters for these 2 cases. In 0.0.5 there is a single parameter for both cases. I would appreciate if you separate these date font-sizes back.

                      Thank you in advance! smiley