Andy,
Mind PMing me your email address and I will test on my end? Also, make sure that sp_compatibility_test.php passes. Both versions you tried use SimplePie.
Jesse R.
Consider trying something new and extraordinary.
Illinois Wine
Have you considered donating to MODx lately?
Donate now. Every contribution helps.
Jesse found my problem - I had events but they were all in the past. Adding an event in the future made the calendar appear.
Thanks Jesse!
Andy
What version of GoogleEvents are you using? Can you use this call and paste the output in here:
[!GoogleEvents? &debug=`1` &email=`
[email protected]`&tpl=`GE`!]
Jesse R.
Consider trying something new and extraordinary.
Illinois Wine
Have you considered donating to MODx lately?
Donate now. Every contribution helps.
Based on the debug info, everything looks alright. Mind PMing me login details?
Jesse R.
Consider trying something new and extraordinary.
Illinois Wine
Have you considered donating to MODx lately?
Donate now. Every contribution helps.
has anyone been able to run this snippet on an environment that has suPHP installed.
Every time i have a page that has a google calendar call I get an internal server error. Once I remove the call, the page does not give the error anymore.
The system test php file also throws a 500 error.
I have been running this script flawlessly and love it, I would love to run this on my server but it has been updated with suphp enabled.
I did some more reserach and it appears that this part in particular is causing the 500 error...
function get_curl_version()
{
$curl = 0;
if (is_array(curl_version()))
{
$curl = curl_version();
$curl = $curl[’version’];
}
else
{
$curl = curl_version();
$curl = explode(’ ’, $curl);
$curl = explode(’/’, $curl[0]);
$curl = $curl[1];
}
return $curl;
}
version_compare(get_curl_version(), ’7.10.5’, ’>=’)
Thanks
Brian
I would make sure to check your permissions on files. Take a look at this:
http://www.lunarforums.com/lunarpages_php_mysql/suphp_inherited_phpini_500_internal_server_errors-t20444.0.html;msg150793#msg150793
GoogleEvents utilizes SimplePie 1.0. If you are unable to run sp_compatibility_test.php, then the problem lies with SimplePie and not GoogleEvents. Unfortunately, a search for "suPHP," "500," and "SimplePie" did not reveal much. So hopefully it is just a permissions issue as mentioned above. Maybe someone more knowledgeable of suPHP or your host can shed some light on this.
Jesse R.
Consider trying something new and extraordinary.
Illinois Wine
Have you considered donating to MODx lately?
Donate now. Every contribution helps.
I’m afraid permissions are set correctly and I am my own host. I will head over to the simplepie boards and see if they can help.
Thanks
Brian
Hey Jesse,
I just download the latest files from simplepie.org and that version of the system test executed properly.
Could GoogleEvents be using a older version of simple pie, if so how can I upgrade it in GoogleEvents?
Would it be as simple as overwriting the php/simplepie.inc file with the new one from simplepie.org?
Thanks
Brian