We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28042 ☆ A M B ☆
    • 24,524 Posts
    It’s all in the functions.php file; in the subscribe and unsubscribe functions it’s hard-coded into the table for the form. Very klunky, but I wanted to just get it working to start with, then start cleaning it out and making it all more elegant and easy to customize. There’s a lot that I have in mind; making the form an optional chunk template with placeholders, and merging the user management into the MODx user system, as well as using MODx documents for the newsletter.

    As far as not working from a chunk, I have no idea why it shouldn’t. I’ll check it out.
      Studying MODX in the desert - http://sottwell.com
      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
      Join the Slack Community - http://modx.org
      • 6926
      • 41 Posts
      Hi,
      Sorry for the late reply, my business is not allowing me to do much of coding lately. Anyways I have fixed the issues and now it works perfectly fine.

      Thanks for making such a wonderful plugin.

      Best Regards,
      Deep
        Deep Ganatra
        Web1 Solutions
        • 17615
        • 4 Posts
        hello,

        i tried to use koopsmailinglistx but it not easy for me... i’m not a specialist of modx..

        i have installed module and snippets file
        the table have been create...

        but i have 2 problem now...
        first :when i tried to see my page : where the only code is [[koops...]]

        Fatal error: Cannot redeclare subscribe() (previously declared in /home/users2/a/assoacier/www/modx921/assets/modules/koopsmailinglist/functions.php:30) in /home/users2/a/assoacier/www/modx921/assets/modules/koopsmailinglist/functions.php on line 30


        second:
        in my log, i have also ’The mailer failed to connect. Errors: . Log:’
        is this a probleme in my config file?
        $mailserver = ’http://pop.wanadoo.fr’; is it the true type of $mailserver

        someone have a solution ?

        ps: my english is bad because i’m french..
          • 6926
          • 41 Posts
          For the 2nd error remove http:// and it should fix the issue....
            Deep Ganatra
            Web1 Solutions
            • 17615
            • 4 Posts
            thanks...

            i have change them

            but i think the most important is the first problem for me
              • 7923
              • 4,213 Posts
              Quote from: luckyluk at Sep 19, 2006, 07:26 AM

              but i think the most important is the first problem for me
              You have the snippet running twice on the page, if you need it running twice, you could try adding:

              if(!function_exists(subscribe)) {

              }

              around that function in the snippet code. You’d need to do that for every function.


                "He can have a lollipop any time he wants to. That's what it means to be a programmer."
                • 7455
                • 2,204 Posts
                I am getting the foloing error when i want to compose a mail:

                Not Acceptable
                An appropriate representation of the requested resource /assets/modules/koopsmailinglist/FCKeditor/editor/fckeditor.html could not be found on this server.

                on my test server it worked fine

                when i moved it to another server I got this error.

                I looked at the path and it looks exectly the same no typo’s etc.

                I even changed the FCK base path to the whole url including http://www.mydomain... but it gave the same error.

                any idea what this can be?


                Dimmy

                  follow me on twitter: @dimmy01
                  • 7455
                  • 2,204 Posts
                  I also saw that the image uls is not good the image for the delete funktion is this manager/images/delete.png but it should be this assets/modules/koopsmailinglist/images/delete.png
                    follow me on twitter: @dimmy01
                    • 2847
                    • 9 Posts
                    I have no email being sent out for new users to confirm their account - running with smtp server address in the config.php - is this correct?

                    thanks for any help..
                      • 8790
                      • 526 Posts
                      Hi all,

                      Hi Susan,


                      Here I am with another ’stupid’ question (I did not find any doc in the Koops-project’s site)

                      When editing the config.php file in order to ’match’ my needs, there’s a simple line for ’mail server’

                      Can u confirm this is the outbound server only ( smtp )

                      I presume this tool is only sending mail through a specified smtp mail server and do not need at all any imap/pop definition.

                      Just to be sure ..



                      thank you
                        Schtroumpf Grognon - Grouchy Smurf
                        ---------------------------------
                        Faites pas attention.. - Don't pay attention
                        http://www.dzi-neo.net