On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I had a same problem and none of mentioned methods helped.
    I contacted my hosting company and they resolved the issue disabling the mod_security for my server.
    • I’ve had the same problem for awhile now as well. If none of the other solutions help, try checking the names of your subfolders. I found the the MCPUK file browser will allow you to put "&" in the folder name, but this was causing the browser to error out, and not show any of my subfolders. Once I renamed the subfolders on the file system, all was okay.
        Mark Macatee
        President
        Power 10 Solutions
        http://www.power10solutions.com
      • I had a similar problem, but none of the solutions here worked for me. In my case, I had overridden the default TinyMCE control surface using the controls in Tools -> Configuration -> Interface & Features (MODx 1.0.2), selecting "Custom" for the TinyMCE Theme. I specified some additional plugins for TinyMCE, one of which was ’inlinepopups’. This plugin actually worked fine, right up until the point the file browser launched. Then, not so much; same symptoms everyone here is talking about. Removing the ’inlinepopups’ plugin specifier from my "Custom Plugins" field in Interface & Features solved the problem.

        MODx should do a deal with Moxiecode to include MCFileManager and MCImageManager in MODx distros, if such a deal can be done. Moxie’s file and image managers are really hot, work beautifully and don’t run into problems like this. I’m sure MODx put a lot of time and effort into hacking up FCKEditor’s file manager to be halfway usable, and I commend them for that effort, but there’s a better solution out there staring us in the face!

        Has anyone made MCFileManager and MCImageManager work with MODx?
        • The fix for this, in my case, was as follows:

          A user had uploaded a pdf file with a character that the file browser, in Firefox only, didn't like (a long MS Word hyphen which modx had changed to –)

          Deleting / renaming the file solved the problem.

          Edit - just realised how old this thread was...
          • I've just upgraded to Evo 1.0.14 and I am having a similar problem again. I have previously fixed the file manager and resource path etc... I have also set the directory and file permissions to 777, and checked over every thread I can find I found the file manager and resource path settings under the user tab in edit User and still no joy. When I try to insert an image through either TinyMCE or NevoSlider I get "Cannot create image folder" pop up. (screenshot attached)