Quote from: WeBe at Aug 26, 2008, 10:19 AM
Users should be aware that the MODx mode (mysql = 3) should not be used in a restore process. The MODx information could be damaged, that’s why you want to perform a restore, right? 
So, would it be an idea to display an error message in that case or, perhaps even better, ask for host/user/password?
I really think this would make BkupMODx even a greater tool and a big help in case of emergency! I wish you luck creating this 
Good catch! It’s funny you mention that because earlier this morning I added additional file_exists checks for both the BkupMODx bkup_config.php and the MODx config.inc.php files. These checks should help accomplish the same objective.
If a restore is attempted with mysql=3 and MODx is not already installed then the script will fail when it looks for the MODx config.inc.php file and display an error. The user will have to change to modx=2 and add the host/user/pass in the bkup_config.php file for the restore to proceed. That should also help reinforce the need to create the dbase(s) prior to the restore.
If a restore is attempted and MODx already exists on the restore system that changes the game again. If the bkup_config.php values are different on the restore system from the backup system then the values on the restore system have to be used. That’s why the bkup_config.php file can’t be overwritten.
This is a big feature to add and I’m not expecting it will release until sometime in early September. I’m avoiding input forms for the time being just for KISS reasons. If you think of any other gotchas let me know.