On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • This is an auto-generated support/comment thread for Auditor.

    Use this forum to post any comments about this addition or any questions you have regarding its use.

    Brief Description:
    Auditor allows database level historying of the main MODx database for auditing/versioning purposes.
      Use MODx, or the cat gets it!
    • Very exciting stuff!

      Also no data comparison/versioning/recovery/rollback facilities are provided yet. These will have to be done by other external tools. I intend to implement some of this by adding future ’plugins’ to the Auditor module for say document content management, snippets etc.

      I hope everyone gets onboard and create some plugins.

        DropboxUploader -- Upload files to a Dropbox account.
        DIG -- Dynamic Image Generator
        gus -- Google URL Shortener
        makeQR -- Uses google chart api to make QR codes.
        MODxTweeter -- Update your twitter status on publish.
      • Let the development begin!
        • OK version 1.1 of Auditor is now in preparation, this is needed to allow data recovery fronm the history databse as marked by the Auditor analysis tool, hopefully this will only take a few days, stay tuned.
            Use MODx, or the cat gets it!
          • Auditor 1.1 is now available form the resources section.
              Use MODx, or the cat gets it!
            • I’ve just downloaded and installed MODx 0.9.6.2 to check its OK with Auditor and it seems to be.

              As far as I can see a column named ’empty_trash’ has been added to the ’user_roles’ table but Auditor will just ignore this, ie it will not be copied to the history database. The rest of the database seems unchanged.

              I’ll put a fix in to allow Auditor to work with both 0.9.6.1 and 0.9.6.2 in version 1.2, along with a few minor bug fixes.
                Use MODx, or the cat gets it!
              • Just tried in modx 0.9.6.2 and not looks like to work (new install)

                More info: http://thana.no-ip.org/shots/deleteme-auditor.jpg
                • Hi Thanatermesis, yes I got your mail OK, now onto the prob, it appears that either your

                  ../assets/modules/auditor/php

                  directory doesn’t exist or is not readable by your webserver user.

                  Auditor sets its path relative to the MODx base path setting i.e it uses $modx->config[’base_path’], from your screenshot this would appear to be OK.

                  Please check that the auditor directory and its sub-directories exist and are readable.
                    Use MODx, or the cat gets it!
                  • Ok i found the bug/problem

                    The reason is that the unziped directory (so i don’t have renamed it), its called auditor_1.1 and i have found a line in these errors that says that search the directory auditor and no auditor_1.1, so i have moved the dirname to just auditor and it has worked smiley (please use the "auditor" name in the zip file that works for everybody)

                    Btw i have read your before lines about a small problem in this version with 0.9.6.2 about "empty_trash" that you need to made a fix in Auditor_1.2, when you plan to upload this version ? (so maybe i will wait to continue with the install of Auditor)

                    Thanks!


                    Thanatermesis
                    • Yes, sorry about that, bit of a bug, I’ll look at this for the Auditor 1.2 release.

                      An extra column was added in 0.9.6.2 that Auditor currently wont history as its really based on 0.9.6.1, as far as I can see its to do with an empty trash check
                      or some such, its very minor, most people are only concerned with recovering the content of snippets, documents, chunks etc. which this wont affect at all.

                      This will be added in Auditor 1.2 but this release is about 2 weeks away at the moment.

                      If you really need to get up and running now I’d install Auditor and carry on, this shouldn’t affect you at all.
                        Use MODx, or the cat gets it!