-
☆ A M B ☆
- 24,524 Posts
That will work as long as you’re not using Friendly URLs. $modx->makeUrl() will generate such a URL with the appropriate query string automatically; MODx determines whether or not you’re using Friendly URLs and uses a ? or & for the first item as appropriate. So the $uriQS.’&CatId=\’+this.value’ part should be concatenated before the makeUrl() call and added to the parameters.
string makeUrl(int $id[, mixed $alias[, mixed $args[, mixed $scheme]]]);
When not using Friendly URLs, your full URL will be
domain.com/index.php?id=x&key=value&key=value
When using Friendly URLs it needs to be
domain.com/alias.html?key=value&key=value
I can’t seem to get this to work...
After I create a new module with the contents of mxCalendar.module.txt copied into the code section, click save and then click run, I just get a blank page. No errors no nothing. If I log out and back in, remove locks, clear cache, click on Modules, click on back in mxcalendar, nothing. Just a big white space in the business area of the Manager. No error message or anything.
Anyone else have this problem or know how to fix it. I’m using the latest rev of Evo 1.0.5.
Update: Installed just fine on my live server. Difficulty is something to do with MAMP Pro
-
☆ A M B ☆
- 756 Posts
Quote from: featherodd at Mar 27, 2011, 03:28 AM
I can’t seem to get this to work...
After I create a new module with the contents of mxCalendar.module.txt copied into the code section, click save and then click run, I just get a blank page. No errors no nothing. If I log out and back in, remove locks, clear cache, click on Modules, click on back in mxcalendar, nothing. Just a big white space in the business area of the Manager. No error message or anything.
Anyone else have this problem or know how to fix it. I’m using the latest rev of Evo 1.0.5.
Update: Installed just fine on my live server. Difficulty is something to do with MAMP Pro
Have you check the Reports log and/or your server error log? If so was there anything pointing to any issues with mxCalendar files? I’ve not tested on MAMP, but will try to see if I can reproduce the issue.
Cheers
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.
-
☆ A M B ☆
- 756 Posts
Quote from: nevyn100 at Mar 26, 2011, 11:06 PM
Just in case anyone else is dealing with the ? issue, I found it in mxCalendar.class.php line 1812
This will be part of the bug fix in the very very soon release of mxCalendar.
Cheers
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.
great job btw... loving this mod
charless: yeah, modx logs the following system error when the mxcalendar tab is clicked:
mxcalendar - Module - System Events
Error
Event Id: 1 Source: mxcalendar - Module
Date: 28-03-2011 19:19:36 User: admin
syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING
any update on new release?
-
☆ A M B ☆
- 756 Posts
Quote from: noahlearner at Apr 02, 2011, 08:15 PM
any update on new release?
Yeah, working on it today to get ready to post tonight.
Cheers
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.
-
☆ A M B ☆
- 756 Posts
newest version of mxCalendar will be ready in just a couple hours.
... I can’t wait to get this version out to everyone ...
cheers
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.