We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 34084 ☆ A M B ☆
    • 756 Posts
    Laurie,

    Can you download this file and replace the current on on your site for mxCalendar and then view the event list. There had been some various bugs in the past with repeat events. If that file update only doesn't make the change then open the event in the editor, after updating the file, and then just save the event with no changes and review on the front end.

    http://code.google.com/p/mxcalendar/source/browse/trunk/mxCalendar.class.php

    Cheers
      Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
      Visit CharlesMx.com for latest news and status updates.
      • 34084 ☆ A M B ☆
      • 756 Posts
      Laurie,

      Thanks again for your patience, as noted your issue has been resolved and I updated the file on your site to ensure you wouldn't have any further issues.

      Please let me know if you have any further questions or concerns.

      Cheers
        Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
        Visit CharlesMx.com for latest news and status updates.
        • 4675
        • 38 Posts
        Hi, me again.

        I moved the site in question over to a new server, and as mentioned in an email to you, I'm at a loss to find out why the stylesheet is not being picked up. I've tried all configurations, and still doesn't work.

        Attached are 2 screenshots, one of the old server's styling, and the new server's styling. As you can see, it's gone awry.

        Also, I can see the source code if I enter in the url of the css, such as, but when I actually type in the css file right in the chosen theme, I get bounced to the home page. On the old server, I can actually see the css file in my browser, but on the new server, I get bounced to the home page rather than seeing the CSS code.

        http://www.centralcaribooarts.com/assets/modules/mxCalendar/themes/default/css/mxCalendar.css
        (I can see up to themes.)


        Website: centralcaribooarts.com
          • 34084 ☆ A M B ☆
          • 756 Posts
          Sorry for the delay, based on your environment I had to change the folder permissions for the /assets/modules/mxCalendar/* to 755. That was the lowest I could make them and still have them display as needed.

          Cheers
            Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
            Visit CharlesMx.com for latest news and status updates.
            • 41824
            • 19 Posts
            Hi all,

            I've heard of people having this issue, but I haven't found a solution. mxcalendar wasn't saving data entries properly, so I updated it. Then I started getting this error:

            Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING in /home/xxx/public_html/xxx.com/manager/processors/execute_module.processor.php(114) : eval()'d code on line 12

            I updated to Evo 1.0.6 and reinstalled mxcalendar 0.1.3b. Still get the same error. I get this error when I paste in the module code and "run module". I've cleaned the ModX cache. Any ideas on how to fix this?

            SOLVED: This was an issue that was solved by changing the magic_quotes_gpc setting in the php.ini to OFF. See this thread: https://forums.modx.com/thread/?thread=33391&page=1 [ed. note: x-the_piper-x last edited this post 13 years, 11 months ago.]
              • 41824
              • 19 Posts
              Hi all,

              Just trucking my way through issues. I've got the module installed but now I get this error:

              « MODx Parse Error »
              MODx encountered the following error while attempting to parse the requested resource:
              Execution of a query to the database failed - Unknown column 'disable' in 'where clause'

              Any ideas?
                • 34084 ☆ A M B ☆
                • 756 Posts
                have you done any recent version upgrades? if so do you remember from which version and the curent version your using of mxCalendar?

                Cheers
                  Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
                  Visit CharlesMx.com for latest news and status updates.
                  • 41824
                  • 19 Posts
                  Sorry I omitted that info. I think the version of ModX I was running was 1.0.3, and I was using mxcalendar 0.0.6. The events I was editing in mxcalendar were not saving info, so I updated ModX to 1.0.6 and mxcalendar to 0.1.3b. That led me to the current issues. Thanks for the help!
                    • 34084 ☆ A M B ☆
                    • 756 Posts
                    So it looks like then some of the database changes in the versions didn't get applied as needed. If you can provide me with access we can try to resolve, alternative would be to review the database changes since the 0.0.6 release tothe 0.1.3b version and re-execute those updates to ensure proper schema.

                    Let me know either way and we can try to get this resolved ASAP.

                    Cheers
                      Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
                      Visit CharlesMx.com for latest news and status updates.
                      • 4675
                      • 38 Posts
                      I just upgraded to the latest EVO version (1.0.9); and for the most part, mxCalendar (0.3b) works, except for the Details field, in which there is no text box showing up, so my client cannot add in any details about new events. Where would be a good place to look at why this is happening?