We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 31136
    • 72 Posts
    Quote from: rossco at Dec 25, 2008, 05:35 AM

    1. My preview area disappeared in the manager and I was like WTF has gone wrong here.
    2. Is there anyway you can allow access to this to webusers?  Have a frontend admin webgroup that can edit pages but not see the whole backend manager?

    1. The Idea of Quim is:
    A. Make content management more easy.
    B. Enhance backend.
    Enhancements: hide fields/tabs in manager for some users/groups, automaticaly set templates by parent, automatically set pagetitles and other. Preview area now is disabled by default (in future Preview will not be hidden by default).

    2. I will test that and include (if need) this possibility.

    What is "WTF"?

    Thanks 4 comments — sorry 4 english  wink
      • 7231
      • 4,205 Posts
      Urique; this is a great plug-in. I like the approach of using the Manager interface in the front end editor.

      I found a bug regarding Date TVs, the label is in the right location but the widget is at the bottom of the page. This in both the front end editor and the manager views.
        [font=Verdana]Shane Sponagle | [wiki] Snippet Call Anatomy | MODx Developer Blog | [nettuts] Working With a Content Management Framework: MODx

        Something is happening here, but you don't know what it is.
        Do you, Mr. Jones? - [bob dylan]
        • 25551 ☆ A M B ☆
        • 1,231 Posts
        Is there anymore on if you can allow web user groups access to this manager or if you can limit it to a specific users page like how a social network site would allow a user to edit their own page? Looks really nice
          Ross Sivills - MD AugmentBLU Edinburgh, Scotland UK
          AugmentBLU - MODX Partner

          BLUcart - MODX Revolution E-Commerce & Shopping Cart
          • 31136
          • 72 Posts
          Quote from: rossco at Jan 02, 2009, 06:13 AM

          Is there anymore on if you can allow web user groups access to this manager or if you can limit it to a specific users page like how a social network site would allow a user to edit their own page? Looks really nice

          Good Idea!
          But trouble is (how I understand): MODx do not give access to backend for webusers. And I have no ideas yet, how to do this.

          Did you think about — to use Managers against WebUsers?
            • 31136
            • 72 Posts
            Quote from: dev_cw at Dec 25, 2008, 05:21 PM

            I found a bug regarding Date TVs, the label is in the right location but the widget is at the bottom of the page.

            Thanks for report. Fixed!
            Wait for a next version.
              • 15286
              • 79 Posts
              При редактировании постоянная ошибка:

              Quim - OnDocFormSave
              An error occurred while loading. Please see the event log for more information.

              Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in /home/bla-bla-bla/mcc.class.php on line 66

              Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in /home/bla-bla-bla/mcc.class.php on line 81

              Что делать?
                • 31136
                • 72 Posts
                К сожалению нет времени на то чтобы вникнуть в описанный тарбл и найти причину его возникновения.
                В ближайшее время собираюсь обновить Quim более новой и стабильной версией, возможно это поможет.

                А чтобы хоть чем-то быстро помочь Вам, даю линк, который нашел поиском по форуму.
                Здесь рассмотрена та же ошибка и метод ее решения путем добавления строчки в .htaccess:

                В корневом .htaccess добавьте строчку: php_flag allow_call_time_pass_reference On

                Источник: http://modxcms.com/forums/index.php/topic,25115.msg154297.html#msg154297
                  • 15286
                  • 79 Posts
                  Quote from: Urique at Jan 29, 2009, 04:29 AM

                  К сожалению нет времени на то чтобы вникнуть в описанный тарбл и найти причину его возникновения.
                  В ближайшее время собираюсь обновить Quim более новой и стабильной версией, возможно это поможет.

                  А чтобы хоть чем-то быстро помочь Вам, даю линк, который нашел поиском по форуму.
                  Здесь рассмотрена та же ошибка и метод ее решения путем добавления строчки в .htaccess:

                  В корневом .htaccess добавьте строчку: php_flag allow_call_time_pass_reference On

                  Источник: http://modxcms.com/forums/index.php/topic,25115.msg154297.html#msg154297

                  Спасибо за отклик!
                  Не помогло... sad

                  Есть ещё один момент, плагин просто не открывает для редактирования вложенные страницы (страницы находящиеся в контейнере) - чистый лист...

                  В общем и целом, считаю данный плагин правильным с точки зрения подхода к редактированию страниц.
                  Буду ждать модификаций.

                    • 32873
                    • 9 Posts
                    Hey,

                    I cannot manage to install Quim correctly. I always get an error like this when I open the frontend:

                    Fatal error: Call to undefined function include_once() in /home/simon/public_html/modx/manager/includes/document.parser.class.inc.php(745) : eval()’d code on line 1

                    I checked everything twice but I could not find a mistake. Any idea?
                    Further Information: There are 3 Plugins set to "OnWebPagePrerender": 1. AdvancedSearchHighlighting, 2. CountPageHit, 3. Quim.

                    Please help my, I need this plugin!
                    Thanks!

                    EDIT: I confirmed this on another server!

                    Simon
                      • 31136
                      • 72 Posts
                      Quote from: ximarix at Feb 14, 2009, 11:42 AM

                      Fatal error: Call to undefined function include_once() in /home/simon/public_html/modx/manager/includes/document.parser.class.inc.php(745) : eval()’d code on line 1
                      Fixed. Wait 4 updates.

                      Project moved to http://www.modxcms.com/Qm-QuickManager-1.0.1-2366.html and RENAMED to "Qm"

                      This discussion is closed to further replies. Keep calm and carry on.