We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 2912
    • 315 Posts
    I think I know what you are experiencing as I’ve been there too in some way or another. I asked the question and now as in the past FileDownload only serves 1 download at a time and whilst you receive your download cannot continue to surf the same site.

    I have also looked into the download counter too. It counts but doesn’t count on completion of a succesful download but when a download is requested. Cancelling a partial file would leave you with a count increase but no transfer of file.

    Having type all that I have just thought that you could possible change the template for your FileDownload or content page to fire the download link into another browser instance or type. I haven’t tried it myself but maybe add
    target="_blank"

    to the
    <a href= ...... > 

    call which relates to your file download.
      BBloke
      • 11190
      • 109 Posts
      Alas, that didn’t work but, you’re right - one can’t even navigate the site while the download is occurring. Sadly, this makes the file download snippet virtually useless for any but the smallest downloads. Are there other good option for counting downloads? Thanks - John
        http://www.spiritualoutreach.com
        Making Christianity intelligible to secular society
        • 6531
        • 154 Posts
        I’m a complete newb, so bear with me.

        I’ve installed FileDownload.

        It worked for one ’launch’, but now, instead of a page, I get this error:
        « MODx Parse Error »
        MODx encountered the following error while attempting to parse the requested resource:
        « PHP Parse Error »
         
        PHP error debug
          Error: 	main(data.db.class.inc.php): failed to open stream: No such file or directory	 
          Error type/ Nr.: 	Warning - 2	 
          File: 	/home/hybridtv/public_html/v2/assets/snippets/filedownload/filedownload.class.inc.php	 
          Line: 	12	 
          Line 12 source: 	include_once "data.db.class.inc.php"; 	 
         
        Parser timing
          MySQL: 	0.0030 s	(1 Requests)
          PHP: 	0.0505 s	 
          Total: 	0.0536 s	 
          • 11190
          • 109 Posts
          Ah, the problem with blocking appears to be the plugin rather than the snippet. I wonder if that is because it is bound to prerender. Perhaps it cannot allow other pages to be rendered while it is being used? When I disable it, I am able to run concurrent downloads and navigation but it looks like memory is now more heavily taxed and, of course, I reveal the entire file path.
            http://www.spiritualoutreach.com
            Making Christianity intelligible to secular society
            • 12027
            • 63 Posts
            I only have the snippet, but I have no problem with loading/browsing speeds. Tested with 3x400KB/s downloads while browsing, was fine. How it behaves with 100 users downloading at the same time I don’t know wink
              • 11190
              • 109 Posts
              Yes, I have pretty well confirmed that it is the plugin and not the snippet causing the problem. Unfortunately, we need the plugin since without it we do not have the download count and we run too hot on the server.

              The problem is even worse than first thought in that it completely "blocks," i.e., the user cannot even navigate the web site while a download is taking place even in another tab as long as they are within the same browser. Does anyone know how to correct this blocking problem in the plugin? Thanks - John
                http://www.spiritualoutreach.com
                Making Christianity intelligible to secular society
                • 4097
                • 15 Posts
                I have fileDownload installed and running properly. My only problem is that the links to the files themselves aren’t working. For instance, the directory path to a partcular PDF is /assets/templates/mytemplate/Marketing/stcosts.pdf

                The link that it takes me to is: http://www.brightpathmortgage.com/marketing_materials.html/stcosts.pdf

                I have friendly URLS turned on and would like to keep them on. The resulting page that I am brought to is the homepage when i click any of the links.

                Any ideas?
                  • 11190
                  • 109 Posts
                  I do not know if this applies to you but I had a similar problem until I realized the TV was not being inherited. Perhaps it was a problem in the way I set it up or maybe it’s a problem in the Plugin. I had a top level document for a section of downloads and set the File Download Plugin Path to /assets/downloads (or whatever it was). I then created subdocuments with @INHERIT as the TV and it could not find the download documents. I had to specify the TV for every single page. Since I no longer use the plugin (wish I could as I really like it but it did not play well with the hosting company and the large video downloads - www.spiritualoutreach.com/journeydownload.html - so using friendly URLs), I never followed up the problem. Hope this helps - John
                    http://www.spiritualoutreach.com
                    Making Christianity intelligible to secular society
                    • 4097
                    • 15 Posts
                    I just found a different set of instructions that included the code you need to add to .htaccess if you are using friendly urls. Here it is:

                    RewriteRule ^([^/]*)/?(.*)$ index.php?q=$1&d=$2 [L,QSA]

                    That fixed it.

                    Thanks!
                      • 11190
                      • 109 Posts
                      Ah, yes, didn’t think to ask if you had done that. I do recall it being somewhere in the documentation. Glad it’s working for you - John
                        http://www.spiritualoutreach.com
                        Making Christianity intelligible to secular society