We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 2690
    • 148 Posts
    Hello,

    I encountered a very weird issue with a new install of Modx 1.0 (running on php 5.2.6) with mysql 5


    In the templates if i type <html> i will get a 400 error.

    All the other html tags and regular text saves just fine. Tried searching for similar topic here on the forums, but found nothing.

    any ideas will be greatly appreciated!

    Thanks!

    Aleks
      MODx Revo 2.0.6-pl (Traditional) | Apache 2.2.3 | PHP 5.2.14 | MySQL 5.0.77 | MAC OS 10.6.5 | FF 3.6/Chrome 9.0.5
      • 2690
      • 148 Posts
      even if i just type <html - its still generating the 400 error.

      Validate HTTP_REFERER headers is turned off, just in case.


      And i tried to reinstall everything from scratch with no luck.
        MODx Revo 2.0.6-pl (Traditional) | Apache 2.2.3 | PHP 5.2.14 | MySQL 5.0.77 | MAC OS 10.6.5 | FF 3.6/Chrome 9.0.5
        • 12584
        • 208 Posts
        I cant help but I almost teh same error, when I try to create a new template and hit save it gives me the default 404 page on the preview pane inside the manager.

        I have not yet tried I.E this is only in firefox however this is on a fresh install I dont have the same problem on another site which was an upgrade that site works fine but nice to know I am not the only person having a few probs.

        Cheers

        Quick Update

        If I had just a few characters at a time I can update things and create new catorgories but if I slap in a whole template code then it fails and send me the site default 404 page inside the manager.

        Cant understand what is causing this issue the site does not hang once save is entered most odd
          • 2690
          • 148 Posts
          Yeah, i’m running another site on the same hosting and have no problems with it at all.

          what kills me is that its just one tag which breaks it all - <html>, seems like something very simple and stupid (like a security setting i overlooked or some configuration issue)
            MODx Revo 2.0.6-pl (Traditional) | Apache 2.2.3 | PHP 5.2.14 | MySQL 5.0.77 | MAC OS 10.6.5 | FF 3.6/Chrome 9.0.5
            • 23653
            • 10 Posts
            having the same issue. Please help
              • 27708 MODX Staff
              • 2,502 Posts
              Can you please post your template code please. In addition do you have a .html file in your web root?
                Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub
                • 2690
                • 148 Posts
                yeap, removing .html files from the root helped it.

                thanks for the fix!
                  MODx Revo 2.0.6-pl (Traditional) | Apache 2.2.3 | PHP 5.2.14 | MySQL 5.0.77 | MAC OS 10.6.5 | FF 3.6/Chrome 9.0.5
                  • 12584
                  • 208 Posts
                  I have nothing in the root of the account other than the default MODx install including .htaccess and sample-robots.txt

                  Below is the template I am trying to paste into place:

                  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
                  
                  
                  <html xmlns="http://www.w3.org/1999/xhtml">
                  <head>
                    <title>[(site_name)] | [*pagetitle*]</title>
                    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
                    
                  <link href="assets/templates/codling/css/layout.css" rel="stylesheet" type="text/css">
                  </head>
                  
                  <body>
                  <div id="wrapper">
                  	<div id="header">
                  	
                  		<div id="header_topstrip">
                  		Breadcrumb to go here
                  		</div> <!-- /end of header-topstrip -->
                  	<h1>site logo</h1>
                  			<h2>dynamic content maybe here</h2>
                  	
                         </div><!-- header end div-->
                  
                   
                  
                  
                  <div id="content">
                  
                  
                  		
                  		
                  		
                  	<div id="colOne">
                  	
                  	<!-- get rid of info box idea
                  		<div id="logo">
                  			<h1>logo</h1>
                  			<h2>box if needed</h2>
                  		</div>
                                  -->
                  		<!--menu start-->
                  		
                  Menu to go here with wayfinder
                  
                  
                  
                  		
                  		<!-- menu finish-->
                  		<!-- search form start-->
                  		 Search form going here
                  		
                  
                      </div>
                  	<div id="colTwo">
                  	
                  	
                  	  <div id="menu_horizontal">
                  Page title to go here
                     </div>
                  	
                            [*#content*]
                  
                  
                   
                   
                   </div>
                             <div style="clear: both; margin:0; padding:0; height:1px;"> </div>
                  
                  	<div id="footer">
                  	© 2009 <a href="#">footer text here</a> All rights reserved <br> 
                  
                  Tel: 1234567890
                  	</div>
                  </div>
                  </body>
                  </html>


                  I can get things added by doing a line at a time but something fails when I add the full lot very odd.

                  another quick edit:

                  I have another site using evolution which was an upgrade, earlier when I tested I only added a few lines to a new template which worked, however if I try to add this full html to that site then I get the same error by being sent to the default 404 page in the manager preview window, this site is on the same server so I am wondering could there be anything in the server firewall stoping an insert commmand under certain conditions.
                  I just dont understand enough about that magical programming voodoo stuff to know if this is possible.

                  Also get the same problem if i try to edit an existing page by adding the template code to it.

                  I have now added the above code bit by bit and it has all been taken fine, I just cant add stuff in big chunks huh

                  Cheers all
                    • 27708 MODX Staff
                    • 2,502 Posts
                    ian_m

                    Not sure I really get the issue you are having. You are being redirected to your error page when you try to convert pages to this template? Have you tried with a blank template? You can’t edit an existing template and paste in content? Are you able to create an entirely new template? I don’t see anything wrong in your template other than a tonne of extraneous whitespace.

                    There should be no reason templates aren’t saving? Did you say this was a new install? Did you reupload all the /manager files (save for config.inc.php)? Can you give us your php, apache and mysql info?
                      Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub
                      • 12584
                      • 208 Posts
                      Downloaded new package of evolution unzipped and reuploaded just the manager section.

                      First test everything worked perfect thought problem was solved. An hour later I start working on the site but the problem is back I have changed nothing since successful test.

                      Apache version 2.2.13 (Unix)
                      PHP version 5.2.6
                      MySQL version 5.0.81-community

                      Totally confused as to what could cause this just does not make any sence.

                      In the site error log i see thisa error everytime the update fails

                      [Wed Oct 14 12:06:50 2009] [error] [client 90.217.30.251] File does not exist: /home/username/public_html/manager/assets, referer: http://mysitesname.co.uk/manager/index.php

                      This error is on a brandnew install have same problem on an upgraded site.