We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 2401
    • 17 Posts
    Hi - Did this issue of "Content Encoding Error" on the Manager MAIN welcome page get resolved? Just done a fresh install and tried all the fixes above (except one) to fix it but to no avail. The one I did not try was that I could not find any php.ini file to edit...
    Is this welcome page important? Can I carry on without it?!
    Thanks
    A.
      • 2401
      • 17 Posts
      Ignore last post - I just changed the "mutate_settings.dynamic.php" manually as described above and that fixed it. I haven’t done this long enough yet to work out how SVN works yet... wink
        • 24472
        • 1 Posts
        Quote from: pixelchutes at Aug 04, 2009, 06:11 PM

        I believe I have found the issue. It appears to be related to http://svn.modxcms.com/jira/browse/MODX-851

        I rolled back my mutate_settings.dynamic.php to revision 5566 and the Content Encoding Error has gone away w/ Zlib enabled!

        However, replacing w/ revision 5567 breaks it again... cool

        It seems to be related to the use of the output buffer in get_lang_options():



        Yeah, I stumbled upon the same issue, and after some debugging I found a errer in the function you mention.

        Moving the ob_start() call a few lines up (to ensure that it actually runs in all casese when ob_get_clean() is called) seems to fix this issue. Looks like some outputbuffer with garbage is returned or something, when ob_get_clean() is called without ob_start.
          • 27733
          • 99 Posts
          OK, get this: I have the zlib directive set to off, and still get this behavior (home and config pages being blank). The host in this case is running php 5.2.9. Any clues???
          Cheers,
          Jim

          P.S.: I’ve attempted to fetch the aforementioned mutate...php file, but crucibal has been down since last night.
            ------
            Server: *nix, ModX Evo 1.0.4, Apache 2.x, PHP 5.x, Mysql 5.x.
            • 27733
            • 99 Posts
            Sorry folks, scratch that! It’s always after finally sending a post that I find the right clue ... after reading another thread mentioning the memory_limit possibly being an issue, I took to examining the hosts error logs. Wah-la, there it was: The language includes were eating up memory beyond the limit. Upped the limit (the default 8M was too low) ... now no probs.
              ------
              Server: *nix, ModX Evo 1.0.4, Apache 2.x, PHP 5.x, Mysql 5.x.