We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3866 ☆ A M B ☆
    • 350 Posts
    Hi there,
    I've downloaded this package and followed all the instructions, however, when I've added slides these do not appear under the album or on the front end. The images seem to be uploading - all .jpgs and are the correct size etc but nothing appears.
    I'm working on a 2.1.3 Revo site and would like to get this slide show working.
    I've checked the database and the tables have been added and so have the slides - it shows 3 entries have been made but nothing is appearing in the Slideshow Manager - what am I missing?
    Thanks

    UPDATE: There looks as if an extra '/' is being added to the url prior to the /assets/components/slideshowmanager/nivo-slider/nivo-slider.css and other similiar urls - will dig a bit more and see if I resolve this.

    UPDATE: Ok, modified the nivo_headTpl to remove extra '/' but unfortunately still no images. The images are definitely in the file manager but just not appearing in the Slide Show Manager or the front end [ed. note: boomerang last edited this post 15 years ago.]
      Helen Warner
      Number one pixel!
      Proud to be linked with MODX at Crimson Pixel
      • 33983 ☆ A M B ☆
      • 181 Posts
      @boomerang,

      1. Can you verify that the images are getting uploaded? Look in the folder assets/components/slideshowmanger/uploads/. If you call them from the browser do they display?

      2. If the images are not there, can you check you PHP error log or the MODX error log? Are there any messages stating permissions denied? If so you will need to set the uploads folder to writable.

      3. Does your template have the <head> element? If it does not have this then the JS will not be injected.

      4. Is your MODX in a folder like site.com/MODX? I am not sure but this might affect the images.
        • 3866 ☆ A M B ☆
        • 350 Posts
        Ok, decided to uninstall and reload the package. And initially didn't think it was going to work because the first slide I uploaded didn't appear in the back end manager, but the subsequent slides did.

        I've now managed to get everything work and it looks great.

        Only comment would be an issue re dates, in the UK, as I'm sure you are aware, we put DD/MM/YY and it throws an error although self corrects.

        Also it would be nice to leave the end date as optional.

        Otherwise all working very well - good stuff.

        Not sure what happened first time, there were no error messages and there is a <head> in the template. And for info the site is configured as site.com.

        Thanks for getting back to me.
          Helen Warner
          Number one pixel!
          Proud to be linked with MODX at Crimson Pixel
          • 35395
          • 12 Posts
          I'd just like to say that, though I have not used this extensively, this is a really useful module and now that some of these bugs have been worked out it'd be great to tighten this up and productionalize it. Good job though!
            • 37104
            • 19 Posts
            Hi there,

            I am having the same troubles that others have indicated above. Namely, that the images are not showing up in my album in the manager, unless they are in the 'tbd' category. I've uninstalled, reinstalled, gone through every trick/tip I found in this thread, everything seems to be in order and still I get nothing. The images are DEFINITELY uploading, I can see them in the file manager: assets/components/slideshowmanager/uploads but nothing in the CMP.

            I did notice that my installation has a 'slideshow-manager' in addition to a 'slideshowmanager' directory in assets/components/slideshowmanager, could that be problematic?

            MODX Revolution 2.2.0-pl2 (traditional)
            Installed in a subdomain
            Plesk 9.5 on VPS at KnownHost
            mysql 5.0.77-4.el5_4.1
            php 5.2.17-1.el5.art (safe mode off)

            MacBook Pro, using Firefox 10.0 and Chrome 17.0.963.46

            No errors in the MODx error log.
            No errors in my server log.

            I remembered an error during the installation process, so I just did a 'reinstall' to see if it turned up again, and it did. Here's the output from the install:

             Console running...
            Attempting to install package with signature: slideshowmanager-1.0.0-pl
            Package found...now preparing to install.
            Grabbing package workspace...
            Workspace environment initiated, now installing package...
            Running PHP Resolver.
            Script resolver actions completed
            Attempting to preserve files at /var/www/vhosts/frontrangeskibus.com/subdomains/newbus/httpdocs/core/components/slideshowmanager into archive /var/www/vhosts/frontrangeskibus.com/subdomains/newbus/httpdocs/core/packages/slideshowmanager-1.0.0-pl/modCategory/2017ba2fd58ccaacad853f32cd9b04d4.1.preserved.zip
            Attempting to preserve files at /var/www/vhosts/frontrangeskibus.com/subdomains/newbus/httpdocs/assets/components/slideshowmanager into archive /var/www/vhosts/frontrangeskibus.com/subdomains/newbus/httpdocs/core/packages/slideshowmanager-1.0.0-pl/modCategory/2017ba2fd58ccaacad853f32cd9b04d4.2.preserved.zip
            Could not load package metadata for package slideshowmanager.
            Tables resolver actions completed
            xPDOVehicle resolver failed: type php (/var/www/vhosts/frontrangeskibus.com/subdomains/newbus/httpdocs/core/packages/slideshowmanager-1.0.0-pl/modCategory/2017ba2fd58ccaacad853f32cd9b04d4.setupoptions.resolver.resolver)
            Could not resolve vehicle for object of class modCategory; criteria: Array ( [category] => SlideshowManager ) 
            Successfully installed package slideshowmanager-1.0.0-pl
              The older I get, the faster I was.

              http://www.evanchute.com/
              • 33983 ☆ A M B ☆
              • 181 Posts
              @full trucker

              Did you set the start date before today and end date after today? Is the status set to Live/Active? Is there a sequence number?
                • 37104
                • 19 Posts
                Quote from: jgulledge19 at Feb 15, 2012, 01:11 PM
                @full trucker

                Did you set the start date before today and end date after today? Is the status set to Live/Active? Is there a sequence number?

                I set the start date as today, and left the end date blank since I don't want the slide to expire. There is no option for "Live/Active" when adding a slide for the first time, but I did tick the radial button for 'Insert Slide'. Yes, I entered a number for Slide Sequence. All things went as planned, and after I hit the 'Create' button, I was given a message that indicated my slide had been created. But again, no image is showing on the front end or in the CMP.

                Also, I did set the URL to [[~3]], not sure what the correct context is there.
                  The older I get, the faster I was.

                  http://www.evanchute.com/
                  • 33983 ☆ A M B ☆
                  • 181 Posts
                  I think that the way I set the query up you have to have an end date. So set it like 2 years out and see if that works.
                    • 37104
                    • 19 Posts
                    Excellent. Working now, thank you. The 'End Date' field is not required, so I assumed it wasn't the issue. Possibly make that required in future releases?

                    Now I just need to do some styling to make it pretty.
                      The older I get, the faster I was.

                      http://www.evanchute.com/
                      • 9674
                      • 170 Posts
                      Hi,

                      I posted on github, in the relased version the snippets does not appear to work with a babel multilingual environment.

                      https://github.com/jgulledge19/Slideshowmanager/issues/2