-
☆ A M B ☆
- 2,213 Posts
If you check the error log in cpanel it should tell you this, but giving too much permission as you have noted earlier will cause issues (500 errors to be exact).
You want 644/755 for files/folders and everything should be happy. You can use this command in shell "chmod -R u=rwX,go=rX ~/public_html/" (without quotes) to set the permissions to what’s needed.
If you have the core folder in another location make sure you run that command for the correct folder.
The other typical cause of 500 errors is with you htaccess, so change .htaccess to ht.access and see if the problem persists. In either case the issues aren’t with MODx, but with your server in some way.
Hope that helps some,
AMDbuilder
how does your script differentiate between the different permissions req’d for directories and files?
Radified,
VPS guide, Revo 206 Traditional, PHP 534, suPHP, MySQL 5151, Apache 2217, CentOS 5.5 on Virtuozzo VPS.
it installed!
after i set permissions on all directories to 755 and on all files to 644.
not a single error.
beautiful when it works.
the problem is that the traditional package i unzipped on my server (shell > unzip -a filename.zip) gave all my directories 775 and all files 664. suPHP must not have liked those settings.
by the way, the shell scripts i used to change all permissions were:
find ./ -type d -exec chmod 755 {} \;
and
find ./ -type f -exec chmod 644 {} \;
The {} gets replaced by the name of each file that was found.
The ; tells find where the end of the exec command is.
The \ escapes the ; so the shell passes it into the command instead of interpreting it itself.
Somebody might appreciate that. I use bash.
Need to be IN the target directory, or use absolute path in place of "./"
Radified,
VPS guide, Revo 206 Traditional, PHP 534, suPHP, MySQL 5151, Apache 2217, CentOS 5.5 on Virtuozzo VPS.