We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22244
    • 144 Posts
    I have this error for a couple of days now...

    [2010-10-17 15:25:27] (ERROR @ /home/user/domains/domain.com/public_html/core/xpdo/xpdo.class.php : 1754) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected

    More people having this?
      • 11055 ☆ A M B ☆
      • 3,112 Posts
      perhaps bcoz of codeMirror.
      you can ignore that logs.
        Rico
        Genius is one percent inspiration and ninety-nine percent perspiration. Thomas A. Edison
        MODx is great, but knowing how to use it well makes it perfect!

        www.virtudraft.com

        Security, security, security! | Indonesian MODx Forum | MODx Revo's cheatsheets | MODx Evo's cheatsheets

        Author of Easy 2 Gallery 1.4.x, PHPTidy, spieFeed, FileDownload R, Upload To Users CMP, Inherit Template TV, LexRating, ExerPlan, Lingua, virtuNewsletter, Grid Class Key, SmartTag, prevNext

        Maintainter/contributor of Babel

        Because it's hard to follow all topics on the forum, PING ME ON TWITTER @_goldsky if you need my help.
        • 11919
        • 7 Posts
        I had a problem with the json_ecode setting filling the error log.
        The solution for me was in the .htaccess file and the ExpiresActive On configuration where the # comment symbol is removed from the supplied file renamed from ht.access in the advanced version of modx-2.0.4-pl2-advanced.
        AND setting the Caching to the corresponding expiry dates in the SystemSettings.
        Fixed the problem for me, over three MODx web sites.
          • 22244
          • 144 Posts
          Thanks for the feedback!

          I just set the cache active in the system settings for the JSON Data.
          So far no more json errors in the log... I hope this will stay like that smiley

          Many thanks!
            • 22303 MODX Staff
            • 10,725 Posts
            Quote from: onepack at Oct 23, 2010, 04:42 AM

            I just set the cache active in the system settings for the JSON Data.
            What cache settings did you change and to what? I’m confused here and what the problem is and could use some clarification.

            Quote from: heathenjimmy at Oct 22, 2010, 11:31 PM

            I had a problem with the json_ecode setting filling the error log.
            The solution for me was in the .htaccess file and the ExpiresActive On configuration where the # comment symbol is removed from the supplied file renamed from ht.access in the advanced version of modx-2.0.4-pl2-advanced.
            AND setting the Caching to the corresponding expiry dates in the SystemSettings.
            Fixed the problem for me, over three MODx web sites.
            Can you provide more specific details on what System Settings you changed and to what values?
              • 22244
              • 144 Posts
              I Activated the Json caching... it seemed to work at first but after I checked again later on the log was full with errors again.
              "domainstuff/public_html/core/xpdo/xpdo.class.php : 1754) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected"

              I don’t know about the settings in the htaccess file because I’m unaware how to set json system settings in that file.
                • 11919
                • 7 Posts
                The error message that I receive in the log is /public_html/core/xpdo/xpdo.class.php : 1754) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected
                There are many of them. The system setting value changed in the Cache json data to yes. Expiration time 86400.
                It seems that I’m going in circles on this minor issue. It’s too difficult to find any simple solution and the web site appears to function properly.
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Yeah, don’t worry, be happy. laugh

                  But seriously, we have been trying to figure this one out for a while; it has nothing to do with caching actually, but so far I cannot reproduce in my environments. We simply have been unable to identify any problems caused by or causing the error as of yet.
                    • 22244
                    • 144 Posts
                    My backend almost crashed when I wanted to check the error log on a second environment that I have setup with MODx Revo.
                    Check the screenprint.. I will clear the log now before it get’s too large.
                      • 22303 MODX Staff
                      • 10,725 Posts
                      Feel free to debug in your environment since you are experiencing the issue and help us get some insight into why this is happening...