We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 17207
    • 23 Posts
    After update from 2.0.0-pl to 2.0.4-pl2 (both traditional), every time I want to edit a resource (when some user is logged in frontend), nothing below the menu bar appears on the screen.
    If I go to home or any other page from the menu I get the whole modx back again. This doesn’t seem to happen when I logout of the frontend.

    There are no errors regarding any of this in the error logs...

    This is simmilar to bugs #79 and #2080

    Environment:
    Win7, Apache 2.2, php 5.3, mysql 5.1.41, PDO enabled, FireFox 3.6


    Also, I’m posting here because Jira is not working for me... tried several times to login after creating account, with no luck.
      • 28215
      • 4,149 Posts
      Can you answer:

      - if you are using any opcode caching such as eAccelerator, APC, winCache, xCache, etc
      - any relevant errors in core/cache/logs/error.log
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 17207
        • 23 Posts
        Hi Shaun

        There are no errors at all in the logs... I cleaned the log, reproduced the error and the logs still clean.

        About the opcode caching... well I don’t know what you are talking about, so I guess I’m not using any, at least not that I know of...
        I installed modx (2.0.0-pl and now i upgraded it to 2.0.4-pl2) and I’m using it as it comes, with just some site settings changes.

        Thanks.
          • 28215
          • 4,149 Posts
          Did you try completely clearing your browser cache?

          Does this only occur on Firefox?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 17207
            • 23 Posts
            Quote from: splittingred at Oct 15, 2010, 11:14 PM

            Did you try completely clearing your browser cache?

            Does this only occur on Firefox?

            I just tried it in IE8(64 bits) and the same happened.
            In FF my default is to clear all the cache on exit, so every time i open a new FF instance i start fresh.

            It sounds really weird, but this might also help... a couple weeks ago I was dealing with getting the logged in [[+username]] and all i was getting was the OS environment var ’username’
              • 22303 MODX Staff
              • 10,725 Posts
              Did you upload the new release by FTP? Sounds an awful lot like an upload failed or got corrupted on a critical file...
                • 17207
                • 23 Posts
                Quote from: OpenGeek at Oct 16, 2010, 04:50 PM

                Did you upload the new release by FTP? Sounds an awful lot like an upload failed or got corrupted on a critical file...

                I just downloaded it from the web page to my laptop and installed from there... everything was smooth so i doubt about corrupted files, but i don’t discard it. I’ll try the download again.
                  • 1434
                  • 23 Posts
                  Hi,

                  I’ve a simmilar problem after upgrade from 2.0.3 to 2.0.4-pl2. If I log with admin account in the home url resources are blank and if I click in any menu item modx redirect me to login screen again and if a login again then I get into the correct location and resources appears. Very extrange becouse if I click to "Home" then resource dissapears and repeat the same issue.

                  My enviorenment:

                  Debian Lenny with apache 2.2.14 with mod_fcgid and xcache and php from dotdeb. In front there is a nginx for caching (manager is not cached).

                  I have tried disabling xcache and the problem persist and access directly to apache with the same issue.

                  Any suggestion ?

                  Thanks.
                    • 22303 MODX Staff
                    • 10,725 Posts
                    What PHP version, MySQL version, xCache version etc? I certainly can’t reproduce on any of my sites, so more information is needed to diagnose.
                      • 1434
                      • 23 Posts

                      PHP 5.2.14-0.dotdeb.0
                      Mysql 5.0.51a-24+lenny4
                      Xcache 1.2.2 but its disabled and the problem persist.

                      I have found in error.log from modx this error:

                      (ERROR @ /var/www/core/xpdo/xpdo.class.php : 1754) PHP warning: json_encode() [<a href=’function.json-encode’>function.json
                      -encode</a>]: Invalid UTF-8 sequence in argument

                      but I don’t know if its related.

                      Tell me if you need more info,
                      thanks.