Thank you so much for your reply:
1. You have a Form Customization rule that is overriding your template values.
2. Your install didn’t copy over all the files, either because:
2a. your upload failed (or missed files), which is most likely
2b. or you selected the advanced distribution without the proper permissions or didn’t uncheck the boxes on the options page.
I did not make any form rules yet, this site is installed since yesterday.
I’ve now also uploaded all the files again from the connector, core and manager dir.
I did not select the advanced distribution but the standard.
After uploading, clearing the cache and clearing the sessions I still run into the issue....
This behavior occurs in IE7 and Firefox 3.6.10