Since the update to Rev 2.0.2 I get some trouble when I try to update a template. The category is always pointed to "1" and not to the saved category. However the category is stored correct in the database and the template is right positioned in the template tree.
On verion 2.0.0 I hadn´t this issue. I was able to rebuild this issue in a second installation on the same server.
The system runs on CentOS and PHP 5.2.10 with MySQL 5.0.77. pdo_mysql is in installed. The installation type of modx is the traditional one.
I tried it on different Browser: esp. Firefox an Chrome on Win7. Cleared the cache and cookies. Also flushed all permissions, sessions and caches.
Clear your browser cache.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
Thanks for your reply. As you can read in my first post, I´ve done this already an tried it in different browsers as well. I also did a second installation on the same server and run into the same issue after updating it from 2.0.0 to 2.0.2.
Maybe an other idea?
Try uploading again and running setup; it seems that some files may have not been upgraded.
If that doesnt work, disable any plugins you have running, and tell us if you have any JS errors or errors in core/cache/logs/error.log.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
I´ve checked it again.
After a new installation on an other server (Ubuntu) I get exactly the same problems with the categories in the templates as mentioned. I get no JS errors for this. But if I update a template with the quick update function all things are working fine.
As many others in this forum I have also the problems with the Package Retriever. If I select a package category like "RichtextEditors" there are no Packages in the grid on the right to download and firbug shows an js error:
"g is undefined [Break on this error] Ext.DomHelper=function(){var w=null,k=...lclick",this.onNodeDblClick,this)}});"
I have the same issue when setting a specific category for a template. After the initial save it shows fine. But when I reload the template after the save the category is back to (in my case breadcrumbs) the old category. It happens on all my templates.
Next to that the setting "clear cache on save" is selected again but I keep on deselecting and saving it.
Clearing the site cache and logging out and in again in a fresh browser window doesn’t resolve anything.
This *is* resolved in 2.0.2, but you have to explicitly *clear* your browser cache to refresh your javascript. You can also hold shift while reloading.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
I’m using a complete new 2.0.2 installation and yes the tree loads with the template in the right category that I assigned it too. But then when I Load the Template to edit it it gets the wrong category assigned and so if I save it now it gets loaded into the wrong category.
I cleared all the modx sessions, the modx site cache, the browser cache and history. Closed the browser (firefox) and opened it again did a ctrl f5 and then went to the new site, logged in and all was still like it was with the same error like I described.
I can handle this by checking I select the correct category every time I save the template just wanted to let you guys know I still run into this, even in 2.0.2
Thanks
It sounds like either:
1. You have a Form Customization rule that is overriding your template values.
2. Your install didn’t copy over all the files, either because:
2a. your upload failed (or missed files), which is most likely
2b. or you selected the advanced distribution without the proper permissions or didn’t uncheck the boxes on the options page.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com