We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14428
    • 5 Posts
    Hi guys,

    I’ve just installed Revolution 2.0.0 (Edit: Normal, not advanced!) to my server, but I’m unable to get any further after completing the setup process, with either a blank page or zero bytes returned.

    I’ve checked the usual suspects (in fact I needed to install pdo_mysql and upgrade my MySQL from 5.0.51a, which I’ve now completed), and even completely removed the install, and attempted once again by unzipping it directly on the server, chowning all the files and chmodding everything to writable.

    I know safe mode is disabled on the account, and theres no eaccelerator or caching running either. I still can’t get anything other than an error (zero content) or a blank page (depending on which browser used).

    Theres no signs of anything in the PHP error log either, and strangely nothing logged in the access log either.

    The only signs in the log were:

    [Wed Sep 01 02:12:37 2010] [error] [client XXXXXX] PHP Fatal error: Class ’modContext_’ not found in /usr/local/www/vhosts/towerstimes.co.uk/subdomains/test/httpdocs/core/xpdo/xpdo.class.php on line 537
    [Wed Sep 01 02:12:40 2010] [error] [client XXXXXX] PHP Fatal error: Class ’modContext_’ not found in /usr/local/www/vhosts/towerstimes.co.uk/subdomains/test/httpdocs/core/xpdo/xpdo.class.php on line 537
    [Wed Sep 01 02:12:40 2010] [error] [client XXXXXX] PHP Fatal error: Class ’modContext_’ not found in /usr/local/www/vhosts/towerstimes.co.uk/subdomains/test/httpdocs/core/xpdo/xpdo.class.php on line 537

    ... but that was during the time I’d tried to delete/check the config.inc.php file to ensure nothing was wrong in there. Now thats been restored, theres no sign of any attempt to access the modx installation in the access or error logs!

    The install is at: http://test.towerstimes.co.uk and manager at http://test.towerstimes.co.uk/manager/

    PHP info at http://test.towerstimes.co.uk/info.php

    Can anyone shed any further light on this at all please? sad

    Thanks.
      • 3749
      • 24,544 Posts
      That’s an odd error. There are references to "modContext" but no references to "modContext_" in the code that I can find. I suspect that either your memory_limit is too low and you ran short of memory during setup, or a file got corrupted during the download/upload.

      Opengeek may have a better idea.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 14428
        • 5 Posts
        Hi BobRay,

        Thanks for the reply. The errors I’d seen had only been caused because I removed the config.inc.php file, and is almost unrelated to the blank page issue as far as I can see (which appears to be logging no errors at all in the error_log, nor even a hit in the access_log for that matter!).

        I tried downloading, unzipping and uploading the first time, got blank page issue.
        Second time I tried wget direct from server, and unzipped via SSH directly. Still got blank page issue after setup.

        The memory limit on the server is 128M, so I’ll be suprised if its that - I’m not sure if I can boost it any higher! laugh
          • 22303 MODX Staff
          • 10,725 Posts
          Please provide enough information about your environment for us to be able to diagnose the problem. The phpinfo link is dead and I have no idea what version of PHP, MySQL, etc. you are using.
            • 14428
            • 5 Posts
            Apologies OpenGeek, I’d reinstalled yet again to see if I could resolve the issue and forgot to throw the PHP info back up.

            http://test.towerstimes.co.uk/info.php

            Its Apache 2.0.63 on FreeBSD running with PHP 5.2.6 as an Apache module. MySQL is 5.1.25-rc, again with same client and PDO client library version.

            I’ve even tried using a die(’test’); check to see where in the index.php it was falling over. The file seems to work fine and output data until the line:

            /* Initialize the default ’web’ context */
            $modx->initialize(’web’);

            ...is called, at which point it just returns the zero bytes and conks out instead. I’m gonna take an inexperienced-with-modx guess that this is where the real deep calls and page construction happens, as everything before just seemed to be about logging etc. and worked fine.
              • 6561
              • 139 Posts
              I also get the blank page, on the webpage index page as well as on the modX manager page.

              My system info:


              Xampp 1.7.3 - Modx Revo Traditional, Windows XP, Firefox 3.6.8

              * Apache 2.2.14 (IPv6 enabled) + OpenSSL 0.9.8l
              * MySQL 5.1.41 + PBXT engine
              * PHP 5.3.1
              * phpMyAdmin 3.2.4
              * Perl 5.10.1
              * FileZilla FTP Server 0.9.33
              * Mercury Mail Transport System 4.72

              Root is http://localhost/ (C:\programs\xampp-win32-1.7.3\xampp\htdocs)



              My error.log :

              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/5a856a37bdf50f28d671e6ea07a90141/0/ to index.php
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/5a856a37bdf50f28d671e6ea07a90141/1/ to ht.access
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/3c26ee6549ac7e8bdce550a356f28056/0/ to assets
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/3c26ee6549ac7e8bdce550a356f28056/1/ to controllers
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/3c26ee6549ac7e8bdce550a356f28056/2/ to templates
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/3c26ee6549ac7e8bdce550a356f28056/3/ to ht.access
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/3c26ee6549ac7e8bdce550a356f28056/4/ to index.php
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/711232ee3c8bcf08f040bae302d42ee9/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/3577758e663acf99c5480a462fbee026/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/240faac57dadc073b57a015b009a9bf0/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/885614c946e2e55774f01b76dfb096c4/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/556677619e64d3f3311379d844c62d76/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/c66007f45f34dd1a3ed8fcff8b507951/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/235ffff7f73c95c8c5e0111c58299297/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/a37f2d7e3aef1651e5bbb30271a146be/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/e10a5fd59c24a7bdb70df68058c28a1d/ to
              [2010-07-15 09:32:18] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/67cff377347b825d978d4bb48770bd93/ to
              [2010-07-15 09:33:17] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\core\model\modx\xmlrss\rssfetch.class.php : 242) User warning: MagpieRSS: Failed to fetch http://feeds.feedburner.com/modx-announce (HTTP Error: connection failed (1006)
              [2010-07-15 09:33:17] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 62) PHP warning: array_keys() expects parameter 1 to be array, null given
              [2010-07-15 09:33:17] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 62) PHP warning: Invalid argument supplied for foreach()
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/0/ to index.php
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/1/ to ht.access
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/0/ to assets
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/1/ to controllers
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/2/ to templates
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/3/ to ht.access
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not copy C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/4/ to index.php
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/788c3d8c5ceea2081e0e45beea59445c/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/cfb6e044acfd4380af21297330d6e10a/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/4ad20f2590e41758af884f8f50cf9e90/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/c9366179780330a60397dc65652071a9/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/70496e8c8b2f20b1a5475b6a53d8ae08/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/62dfa0c3aa4f49d0842fcd1e508daddb/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/d095a33f0877ac62fc7e084c26b68f9b/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/479db3a211064595e3407956f5d5e1bc/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/f33b0387efe09cd9b3c233b2d05ca7e0/ to
              [2010-08-26 14:33:26] (ERROR @ /setup/index.php) Could not install files from C:/programs/xampp-win32-1.7.3/xampp/htdocs/core/packages/core/xPDOFileVehicle/6d1e6577b5c6677358691d2ad56ad8e1/ to
              [2010-08-26 14:34:30] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\core\model\modx\xmlrss\rssfetch.class.php : 242) User warning: MagpieRSS: Failed to fetch http://feeds.feedburner.com/modx-announce (HTTP Error: connection failed (1006)
              [2010-08-26 14:34:30] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: array_keys() expects parameter 1 to be array, null given
              [2010-08-26 14:34:30] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: Invalid argument supplied for foreach()
              [2010-08-26 14:35:36] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\core\model\modx\xmlrss\rssfetch.class.php : 242) User warning: MagpieRSS: Failed to fetch http://feeds.feedburner.com/modx-announce (HTTP Error: connection failed (1006)
              [2010-08-26 14:35:36] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: array_keys() expects parameter 1 to be array, null given
              [2010-08-26 14:35:36] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: Invalid argument supplied for foreach()
              [2010-08-26 14:36:26] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\core\model\modx\xmlrss\rssfetch.class.php : 242) User warning: MagpieRSS: Failed to fetch http://feeds.feedburner.com/modx-announce (HTTP Error: connection failed (1006)
              [2010-08-26 14:36:26] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: array_keys() expects parameter 1 to be array, null given
              [2010-08-26 14:36:26] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: Invalid argument supplied for foreach()
              [2010-09-02 08:50:17] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\core\model\modx\xmlrss\rssfetch.class.php : 242) User warning: MagpieRSS: Failed to fetch http://feeds.feedburner.com/modx-announce (HTTP Error: connection failed (1006)
              [2010-09-02 08:50:17] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: array_keys() expects parameter 1 to be array, null given
              [2010-09-02 08:50:17] (ERROR @ C:\programs\xampp-win32-1.7.3\xampp\htdocs\manager\controllers\default\welcome.php : 64) PHP warning: Invalid argument supplied for foreach()

                • 8599
                • 2 Posts
                Hi folks!

                I also got the blank screen on my index page after installation (traditional distribution).
                And /manager/ page redirects me back on itself when i try to login.

                My info:

                CentOS release 4.8 (Final)

                Apache/2.2.8
                Mysqld/5.1.50
                PHP/5.3.3

                My error.log:
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not copy /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/0/ to index.php
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not copy /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/1/ to ht.access
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not copy /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/0/ to assets
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not copy /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/1/ to controllers
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not copy /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/2/ to templates
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not copy /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/3/ to ht.access
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not copy /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/4/ to index.php
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/788c3d8c5ceea2081e0e45beea59445c/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/cfb6e044acfd4380af21297330d6e10a/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/4ad20f2590e41758af884f8f50cf9e90/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/c9366179780330a60397dc65652071a9/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/70496e8c8b2f20b1a5475b6a53d8ae08/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/62dfa0c3aa4f49d0842fcd1e508daddb/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/d095a33f0877ac62fc7e084c26b68f9b/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/479db3a211064595e3407956f5d5e1bc/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/f33b0387efe09cd9b3c233b2d05ca7e0/ to
                [2010-08-31 21:10:09] (ERROR @ /setup/index.php) Could not install files from /home/admin/domains/mydomain.com/public_html/smile/core/packages/core/xPDOFileVehicle/6d1e6577b5c6677358691d2ad56ad8e1/ to

                I had no warnings or errors during installation.
                I’ve tried to set permissions for all directories to 777 and 775 - and the same problem.
                Memory limit on the server is 128M. I have PDO drivers for mysql enabled.
                I don’t use opcode caching such as eAccelerator, etc. PHP safe_mode is off.
                I’ve also tried to set php_value session.auto_start to 0 in my .htaccess.
                  • 8599
                  • 2 Posts
                  Thank you all for attention. Problem solved. I had been just to run setup not accessing it through my subdomain (subdomain.domain.com/setup).
                    • 2019
                    • 1 Posts
                    Instead of starting a new topic, I’d thought I would continue this one with a same/similar issue.

                    I ONLY get a blank page on the main page of the modx site after install. All management/admin pages work fine.

                    Here’s my setup:
                    Linux CentOS 5.2
                    PHP Version 5.2.10
                    MySQL 5.0.77
                    Server API Apache 2.0

                    Error Log shows:
                    [2010-09-02 09:35:00] (ERROR @ /modxcms/setup/index.php) Could not install files from /var/www/html/tomsremote/modxcms/core/packages/core/xPDOFileVehicle/479db3a211064595e3407956f5d5e1bc/ to /var/www/html/tomsremote/modxcms/connectors/
                    [2010-09-02 09:35:00] (ERROR @ /modxcms/setup/index.php) Could not install files from /var/www/html/tomsremote/modxcms/core/packages/core/xPDOFileVehicle/f33b0387efe09cd9b3c233b2d05ca7e0/ to /var/www/html/tomsremote/modxcms/connectors/
                    [2010-09-02 09:35:00] (ERROR @ /modxcms/setup/index.php) Could not install files from /var/www/html/tomsremote/modxcms/core/packages/core/xPDOFileVehicle/6d1e6577b5c6677358691d2ad56ad8e1/ to /var/www/html/tomsremote/modxcms/connectors/

                    /var/www/html/tomsremote/modxcms/connectors/ is chmod 775 and chown apache/user. All other directories/files during install have same permissions and worked just fine.
                    I guess I should add this is not the advanced install and is a fresh install I just downloaded today.
                      • 22303 MODX Staff
                      • 10,725 Posts
                      The main page is blank by default after installation. You can install a Sample Site via Package Management in the admin interface.