Quote from: Tobys at Aug 29, 2010, 05:36 PM
Same issue here. Even if I remove all entries from the .htaccess file it throws a 500 error. I need to have friendly URL’s active, but this is ridiculous. If I had know Revolutions still had bugs I would have stayed with Evolution which I know works!
Yes, I do have a php.ini file with globals off. Still no luck.
I’m not sure an empty .htaccess file is acceptable. In any event, it has nothing to do with Revolution. Revolution doesn’t access or use the .htaccess file at all. That’s all done by the server. What happens if you rename it to ht.access. The server and MODx will both ignore it completely. That will tell you if it’s the .htaccess file that’s generating the 500 error.
Did you edit any of the MODx config files manually? Sometimes whitespace before the opening <?php or after the closing ?> will cause a 500 error.
If it *is* your .htaccess file that’s causing the 500 error, try one with just this content:
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]