We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 32071
    • 26 Posts
    In my admin panel I have the error message:
    Configuration warning: register_globals is set to ON in your php.ini configuration file
    Not sure why my host has php.ini set this way.

    I have a standard php.ini file that I drop in root folder for various installs to set register_globals to off.

    When I dropped the php.ini file in the modx root I got the white screen of death. I remove the php.ini file and admin panel restores.
    This is the first time this has happened to me.

    Can anyone either point out what I may have set in the php.ini file to cause this or point me to the right documentation that may help me out?

    Thanks,
    William
      • 32071
      • 26 Posts
      Sorry to waste anyones time. I found some info on white screen.
      http://rtfm.modx.com/display/revolution20/Troubleshooting+Installation

      Regards,
      William
        • 3749
        • 24,544 Posts
        I’m glad you got it sorted. Thanks for reporting back. smiley
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 32071
          • 26 Posts
          I am still having issues.
          Every time I set register_globals Off I get a white screen.
          Every time I remove or hash the #register_globals I get my manager panel back with the comment:
          One or more configuration details didn’t check out OK:
          Configuration warning: register_globals is set to ON in your php.ini configuration file

          Here is info and steps I’ve taken:
          OS Linux
          MySQL version 5.1.48
          Apache version 2.2.15
          PHP version 5.2.13
          HostGator - Reseller account

          Per HostGator support forums they intentionally run register_globals On. (I guess to many other scripts require it?)
          I already moved my php.ini file through out the directory structure to try and trouble shoot where the problem is. root(php.ini), public_html (php.ini), my modox directory root (php.ini), my modox directory manager (php.ini)

          I hashed out all settings in the php.ini file # except register_globals off

          and every time the file was dropped in a directory folder the modx manager panel goes blank white. I hash out # register_global and manager panel re-appears. With register_global on message.

          I did some research at HostGator again and found this little comment for the .htaccess file.
          It is meant to be used in conjunction with the php.ini file.

          <IfModule mod_suphp.c>
          suPHP_ConfigPath /home/username
          <Files php.ini>
          order allow,deny
          deny from all
          </Files>
          </IfModule>

          No luck. Still white screen of death.

          I dropped back and went through the entire rigmarole again only utilizing the php_flag register_globals Off in the
          .htaccess file. no luck.
          Every time the file was placed where it was picked up by the manager I get the white screen of death. I hash out the comment #php_flag register_globals Off and manager panel is back up.

          This is freaking frustrating.
          Am I missing a setting in the system settings?

          It seams this is not a hosting issue as 1. utilizing the php.ini and .htaccess files have worked for dozens of other applications and 2 every time the modx manager reads the register_globals off I get the white screen of death.

          Any help or guidance would be appreciated.

          Thanks,
          William

            • 28042 ☆ A M B ☆
            • 24,524 Posts
            The MODx manager has nothing at all to do with it; MODx has no interest whatsoever in .htaccess or php.ini files. Those are only read by the server (Apache and the PHP executable). If Apache is unhappy about something it will throw a 500 error. PHP will throw its own errors; the white screen is because the display of PHP error messages is suppressed. Check your php error logs.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 3749
              • 24,544 Posts
              If your host won’t allow that directive in the .htaccess file (many don’t), you’ll need to put it in php.ini.

              register_globals = off


              Or send this link to the host: http://php.net/manual/en/security.globals.php. No one should have it on. As you probably know, it’s both deprecated and unsafe.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 25389
                • 1 Posts
                I am experiencing the same problem on my Virtual Server.

                After uploading (modx-2.0.0-pl) to the webroot, making core/cache and core/config writable by user,group and even other (777) I get a white screen.
                I noticed also that after running the setup script a folder has been created in core/cache named setup. It does not contain anything.


                PHP Version 5.2.11
                MySQL 5.0.67 server and client

                PDO support enabled
                PDO drivers mysql, sqlite, sqlite2

                register_globals Off

                I must be overlooking something ... but what?
                I really want to use Revolution 2.0 but this makes it very difficult.

                Help will be much appreciated.

                Roelof
                  • 30224
                  • 11 Posts
                  Same issue here. Even if I remove all entries from the .htaccess file it throws a 500 error. I need to have friendly URL’s active, but this is ridiculous. If I had know Revolutions still had bugs I would have stayed with Evolution which I know works!
                  Yes, I do have a php.ini file with globals off. Still no luck.
                    • 3749
                    • 24,544 Posts
                    Quote from: Tobys at Aug 29, 2010, 05:36 PM

                    Same issue here. Even if I remove all entries from the .htaccess file it throws a 500 error. I need to have friendly URL’s active, but this is ridiculous. If I had know Revolutions still had bugs I would have stayed with Evolution which I know works!
                    Yes, I do have a php.ini file with globals off. Still no luck.

                    I’m not sure an empty .htaccess file is acceptable. In any event, it has nothing to do with Revolution. Revolution doesn’t access or use the .htaccess file at all. That’s all done by the server. What happens if you rename it to ht.access. The server and MODx will both ignore it completely. That will tell you if it’s the .htaccess file that’s generating the 500 error.

                    Did you edit any of the MODx config files manually? Sometimes whitespace before the opening <?php or after the closing ?> will cause a 500 error.

                    If it *is* your .htaccess file that’s causing the 500 error, try one with just this content:

                    RewriteEngine On
                    RewriteBase /
                    RewriteCond %{REQUEST_FILENAME} !-f
                    RewriteCond %{REQUEST_FILENAME} !-d
                    RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 3749
                      • 24,544 Posts
                      Quote from: roelof at Aug 23, 2010, 02:37 PM

                      I am experiencing the same problem on my Virtual Server.

                      After uploading (modx-2.0.0-pl) to the webroot, making core/cache and core/config writable by user,group and even other (777) I get a white screen.
                      I noticed also that after running the setup script a folder has been created in core/cache named setup. It does not contain anything.


                      PHP Version 5.2.11
                      MySQL 5.0.67 server and client

                      PDO support enabled
                      PDO drivers mysql, sqlite, sqlite2

                      register_globals Off

                      I must be overlooking something ... but what?
                      I really want to use Revolution 2.0 but this makes it very difficult.

                      Help will be much appreciated.

                      Roelof

                      See if anything here helps: http://bobsguides.com/modx-installation-faq.html

                      The most common cause of a blank page when running setup is having safe_mode on. http://php.net/manual/en/features.safe-mode.php
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting