We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26334
    • 77 Posts
    OK upgrade went smoothly to the PL version.

    No errors reported.

    Core is located below the web root level.

    Site now presents nothing -
    http://www.treadly.com/

    The manager when I try to log in downloads data in the status bar for a while then nothing. Sits at login screen.

    I have cleared the browser cache, cleared the core cache (actually deleted the directory then recreated it with full write permissions).

    I have tried logging in from the forgot password link via email - same problem.

    I have 3 admin accounts - none of them work. Tried on Vista machine and a Mac, on both FF and IE.

    Main install at one domain (where the manager lives)
    http://www.awm.com.au/manager/

    Also running 2nd domain
    http://www.treadly.com/

    In main install I have
    /assets/
    /connectors/
    /manager/
    .htaccess
    config.core.php
    index.php

    at treadly I have
    /assets/ (where I keep css, images etc)
    /connectors/ (seem to recall I needed that in the beta release)
    .htaccess
    index.php

    All config.core.php files are pointing to the correct location below the web root that worked for previous installs.

    Any ideas??
      • 26334
      • 77 Posts
      Additional info:

      Apache, Debian with latest stable Debian distros for php/mysql.
      Apache/2.2.9 (Debian)
      PHP Version 5.2.6-1+lenny3
      MySql version 5.0.51a
        • 3749
        • 24,544 Posts
        Did you check the rewrite rules in .htaccess in the MODx root?

        Did you run an upgrade install?

        It appears that there’s no index.php file in your manager folder (or no Manager folder) or the .htaccess there isn’t correct (it should just have rewrite engine off).

        Another possiblity is that you have a corrupted file or that one or more of the new files failed to overwrite an old one.

        [update] I just noticed your MySQL version. The 5.0.51 version has a lot of known bugs and could be causing your problems.

          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 26334
          • 77 Posts
          htaccess is the same one as was working with beta4 and I noticed the date stamp on the pl release wasn’t upgraded so didn’t update the htaccess file (same date stamp, same size).

          it was an upgrade from beta 4

          There is a manager folder as linked to:
          http://www.awm.com.au/manager/

          The one install manages at this stage 2 domains, down the track probably 4 or 5.

          it has a index.php file and loads the login screen but wont let me proceed past that.

          - corrupted file, I guess that is possible do I just re-upload every file and "upgrade" again?

          - MySQL version -> There is no option on that my ISP tells me, it is the latest release for Debian which they run all their linux web servers on. It caused no problems that I noticed in beta 4.
            • 26334
            • 77 Posts
            Another bit of info, not sure what may or may not help.

            If I use the wrong login user I get the error:
            That account could not be located. Check the username and re-type the password to try again.

            If I use the wrong login password for a valid user I get the error:
            The username or password you entered is incorrect. Please check the username, re-type the password, and try again.

            If I use a valid user/pwd then I get nothing, the page refreshes but goes nowhere.

            The .htaccess file in the manager directory is only one line and the one that comes with the distro.
            RewriteEngine Off

            The .htaccess file in the main public root directory is the one that comes with the distro and is about 3.5k in size.

              • 3749
              • 24,544 Posts
              Do you know what memory_limit is set to. In my experience, the most common cause of ending up back at the Manager login page is running short of memory during the install. The second most common cause is a corrupted file somewhere.

              BTW, there is no .htaccess file in the standard install. There is an ht.access file, but it is ignored by the server.

              You might try turning off FURLS (if on) by changing the friendly_urls setting in the system_settings table from 1 to 0 in PhpMyAdmin and renaming .htaccess to ht.access.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 26334
                • 77 Posts
                memory_limit = 120M, requirements say 64Mb so that shouldn’t be an issue.

                changed the .htaccess to ht.access and turned the friendly urls to 0 in the database, no change.

                Looks like I will try re-installing.



                  • 26334
                  • 77 Posts
                  Still no joy.

                  I have re downloaded the zip file.

                  Deleted everything from the server.

                  Re-uploaded everything.

                  Re-installed as an upgrade to keep my old database stuff intact (don’t want to lose the work done previously) and still the same problem.

                  There is plenty of memory, the file permissions all check out. No error are reported on setup, everything SEEMS to work, but the site doesn’t come up and I can’t log into the manager (although it errors if I use the wrong user or pwd) so it is clearly checking that the username is correct but then stuffs up. sad

                  The apache error log doesn’t report any errors.

                  Just don’t know what to try now.
                    • 26334
                    • 77 Posts
                    Things I am trying - in case this gives any clues.

                    edit index.php on one of the root pages of the domains using this (not the manager)

                    I can get a response right the way through - so the page isn’t hanging somewhere and none of the error checks are flagging - ie the Error 503 responses in the code.


                    if (!MODX_API_MODE) {
                    echo ’hello’;
                    $modx->handleRequest();
                    }

                    Works - in that it returns ’hello’ to the screen but nothing else.

                    but
                    if (!MODX_API_MODE) {
                    $modx->handleRequest();
                    echo ’hello’;
                    }

                    Doesn’t return hello.

                    So there is a fail in the handleRequest() call somehow. No idea how as yet.

                    Tried changing line 86 to:
                    $modx->setDebug(true);

                    But it doesn’t return anything.
                    http://svn.modxcms.com/docs/display/revolution/modX.setDebug

                    Doesn’t give me any clues how to access the debug info.
                      • 26334
                      • 77 Posts
                      In the manager index.php

                      $modx->initialize(’mgr’);
                      echo ’hello’;
                      $modx->getRequest();
                      $modx->getParser();

                      Works at line 68 but if I move it after the getRequest() nothing is returned suggesting perhaps something dies there.