We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28626
    • 87 Posts
    before the collation part, so the first step



    I also tried it with a new login instead of root but I get the same error
      • 28215
      • 4,149 Posts
      Quote from: stofke72 at Mar 24, 2010, 12:19 PM

      before the collation part, so the first step



      I also tried it with a new login instead of root but I get the same error

      To be honest, we’re clueless at this point.

      We have setups very similar to yours, and it works fine. My only guess is that there’s some sort of corruption on your uploaded files, or a misconfiguration between PDO and PHP on your server.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 28626
        • 87 Posts
        I remove xampp which I used before as webserver and set up a new webserver using "tasksel install lamp-server" in ubuntu. Start with a new download, did everything again and still the same error.
          • 28626
          • 87 Posts
          I ran an Ubuntu 9.10 install within virtualbox and it works just fine. I suppose it’s something with being on Ubuntu Lucid
            • 13197
            • 21 Posts
            I had a similar problem with the installer failing to connect to the database on my hosted service.

            I had not had any problems when installing locally on MAMP. I had also never had problems with this host and previous versions of MODx up to 1.0.2.

            The host is ICDSoft, who run a SuExec Linux.

            Their solution was quite simple and maybe what I am writing here is blindingly obvious to most people!

            I had done all the stuff advised regarding php.ini files and that had not helped.

            When installing I had tried these three options
            localhost
            localhost:3307
            mysql5.s441.sureserver.com:3307

            Their solution was to enter:
            mysql5.s441.sureserver.com; port=3307

            This worked perfectly and I am now installed.

            Please be aware that for this to work it was necessary to enable ’remote access’ to the database through their control panel. It is also possible that other users of the ICDSoft serviec may have to enter a slightly different server address (in the s441 bit).

            I hope this helps someone else. I had been battling with it for a long time!
              • 26401
              • 247 Posts
              I’m using ICD soft too smiley

              were you able to get into the manager? after I installed I just got more errors, so I went back to evo
                • 13197
                • 21 Posts
                Good, another ICDSoft user! We will have to keep each other informed of any quirks etc.

                I have not yet done much, but I can access the manager, and was able to use package management to install the modxss sample site.

                If there is anything specific you are trying to do that is failing let me know and I’ll try out the same function on my installation.

                The only things I have done, that may differ from your install are:
                1. On installation I told the installer to set the following privileges for new components:
                Folders: 755
                Files: 644
                2. I have the following php.ini file. ICDSoft said that for a php.ini file to work it has to be present in every folder that contains a php file that requires it. I do not know which files require it so I put a copy of the file into every folder that contains a php file. Perhaps someone can advise whether this is necessary, and if not which folders it would be required in?
                register_globals = off  
                post_max_size = 20M 
                memory_limit = 200M 
                upload_max_filesize = 20M 
                max_execution_time = 120 
                expose_php = off
                mysql.default_socket=/tmp/mysql5.sock  
                mysqli.default_socket=/tmp/mysql5.sock
                pdo_mysql.default_socket=/tmp/mysql5.sock
                
                  • 26401
                  • 247 Posts
                  thanks
                  I’ve tried that and re-installed and it’s still not working.

                  I’ll wait ’till the next version
                    • 10487 MODX Staff
                    • 1,535 Posts
                    I might have a solution, if anybody who is having the connection troubles with RC1 wants to try the following patch: http://pastie.org/890259

                    You can either apply the diff or manually alter the files - there’s only a few minor changes in two files.
                      Garry Nutting
                      Senior Developer
                      MODX, LLC

                      Email: [email protected]
                      Twitter: @garryn
                      Web: modx.com