We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 16474
    • 5 Posts
    I’m trying to install Revolution on HelioHost, but nothing happens when I click the "Create or test selection of your database" button (no error messages either). "Test database server connection and view collations" gives me a success message though. The database I’m using was one I created in the cPanel, and I assigned a user to the database with all privileges. The server has MySQL 5.0.89 and PHP 5.2.9.

    I noticed that the exact same problem was described in this thread, but there doesn’t seem to be a solution there:
    http://modxcms.com/forums/index.php/topic,43432.0.html
      • 3749
      • 24,544 Posts
      The only thing I can think of is a low memory_limit setting or a permission problem with the MODx directories.

      Is there anything helpful in the server error log?
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 9207 ☆ A M B ☆
        • 2,475 Posts
        Yeah, the installer has some bugs... I had problems using Safari, so I had to use Firefox, but I still have a server simply cannot get past this step. It’s maddening. Nothing in the error logs, but I suspect I’m missing a PHP module or have PHP misconfigured (since this is MY server, and my attempts at being a sysadmin, this is entirely possible).
          • 16474
          • 5 Posts
          As Everett said, there’s nothing in the error logs. I think I may try to find a different host or just install Evolution if there’s no fix for it.
            • 1778
            • 659 Posts
            hello

            Seems to be a problem of socket, I resolved it just in specifying the ’pdo_mysql.default_socket=/var/run/mysqld/mysqld.sock’ (not sure it’s the same on your OS) in my php.ini and all is fine now... Install runs normally, all is working like a charm.

            Hope this helps
              • 9207 ☆ A M B ☆
              • 2,475 Posts
              That’s a good tip... I tried it, but I saw no difference in the behavior... nothing in the apache error log. I’m gonna have to get more heavy handed in my debugging. If there’s an error somewhere, it must be getting logged somewhere, right?
                • 22303 MODX Staff
                • 10,725 Posts
                Quote from: Everett at Feb 11, 2010, 05:24 PM

                That’s a good tip... I tried it, but I saw no difference in the behavior... nothing in the apache error log. I’m gonna have to get more heavy handed in my debugging. If there’s an error somewhere, it must be getting logged somewhere, right?
                Everett:

                I assume you have looked in the Apache error_log configured for that location? Also, have you tried editing the call to error_reporting() in the beginning of the setup/index.php file to use a value of -1 (this enables all PHP error reporting)? And don’t feel bad, very few people seem to be able to configure a PHP web server environment correctly these days without a lot of trial and tribulation; seems like more complexity is introduced daily with the newer releases and various new extensions.

                FWIW, the socket issues are generally related to the use of the new mysqlnd client libraries, and generally does not affect the use of the more well established mysqllib client.
                  • 9207 ☆ A M B ☆
                  • 2,475 Posts
                  Thanks Jason. Yeah, I’ve checked the Apache error logs, and there’s nothing except the error about the missing fav.icon. Changing the runtime PHP config for error_reporting in the setup/index.php made no difference... I still end up with a blank page on the 3rd page of the setup (http://mydomain.com/setup/?action=options). So if there is an error occurring, I don’t know where it’s being logged.

                  I know it’s hard to setup a server... I probably owe Victor several beers at this point.
                    • 32796
                    • 5 Posts
                    Same error here

                    lighttpd/1.4.13
                    PHP Version 5.2.0-8
                    MySQL: 5.0.32

                    max_execution_time 120
                    max_input_time 60
                    memory_limit 128M


                    I’ve tested defining the default mysql socket by default (even before it was "MYSQL_SOCKET /var/run/mysqld/mysqld.sock" trough phpinfo() ), does nothing.

                    mysql/i configuration trough phpinfo http://pastebin.com/m49d5b9c2

                    edit: pdo
                      • 22303 MODX Staff
                      • 10,725 Posts
                      You need to configure PDO_mysql to use that socket as described earlier in this thread.

                      If that’s not it, others with 5.2.0-8 have reported problems and I’ll have to defer to folks who insist on using this environment to debug it. Will add notes to the System Requirements documentation about this environment not working until someone does.