We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 23374
    • 5 Posts
    I get the following error message after initial install of MODx Revolution 2.0.0-beta-3 on the /modx/manager/index.php page
    Error! Permission denied! [ Logout ] Apparently I am logged in but have no permission to view the page. What can cause this problem?
      • 22303 MODX Staff
      • 10,725 Posts
      Sounds like the installation did not complete fully. Did you create a different user to login with by chance? This problem can occur if you did not assign the user to the appropriate User Group (Administrators) with the Super User Role. If you did not create a user after installation, then again, it sounds like all of the data was not installed properly.
        • 23374
        • 5 Posts
        Is there a way to check that? I repeated the install, but the result is the same.
          • 3749
          • 24,544 Posts
          Can you verify your memory_limit setting in PhpInfo? Sometimes the install runs short of memory without telling you and the installation is not complete.

          Reports | System Info | Server Tag | View link.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 23374
            • 5 Posts
            PHP Memory limit is at 128M. Tried version 1.0.0. It installed without a problem.
              • 23374
              • 5 Posts
              Anyone? I’m stuck. Installed on a different machine with exactly the same result! After login the manager page displays "permission denied" with the logout hyperlink.
                • 22303 MODX Staff
                • 10,725 Posts
                Quote from: pietpiet at Oct 14, 2009, 11:40 AM

                Anyone? I’m stuck. Installed on a different machine with exactly the same result! After login the manager page displays "permission denied" with the logout hyperlink.
                I’m not sure what to tell you unless you want to provide details about your environments. I cannot reproduce this. You might just wait for beta4.
                  • 23374
                  • 5 Posts
                  Quote from: OpenGeek at Oct 14, 2009, 12:30 PM

                  Quote from: pietpiet at Oct 14, 2009, 11:40 AM

                  Anyone? I’m stuck. Installed on a different machine with exactly the same result! After login the manager page displays "permission denied" with the logout hyperlink.
                  I’m not sure what to tell you unless you want to provide details about your environments. I cannot reproduce this. You might just wait for beta4.

                  php version 5.2.9, Apache 2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8k DAV/2 PHP/5.2.9 mod_jk/1.2.27, MySQL 5.1.30 running on an opensolaris machine SunOS amp 5.11 snv_123 i86pc. Opensolaris comes with a complete "webstack".

                  Thanks for your effort. Maybe you can tell me where the permission for the manager page is set. I can login, but I am no allowed to view a page.
                    • 8907
                    • 11 Posts
                    I have same trouble on OpenSolaris(2009.06) and beta4.
                    The installation looks completed successfully(I installed beta4 into Windows too, but I could not found any difference between the two).
                    I think that the first user might be registered correctly, because MODx warned me when I input incorrect password. "Permission denied" is appeared just after logged-in.

                      • 28215
                      • 4,149 Posts
                      Can you all show us the contents of these tables:

                      modx_users
                      modx_access_context
                      modx_access_policies
                      modx_membergroup_names
                      modx_member_groups
                      modx_user_group_roles

                      Thanks.
                        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com