I get the following error message after initial install of MODx Revolution 2.0.0-beta-3 on the /modx/manager/index.php page
Error! Permission denied! [ Logout ] Apparently I am logged in but have no permission to view the page. What can cause this problem?
-
MODX Staff
- 10,725 Posts
Sounds like the installation did not complete fully. Did you create a different user to login with by chance? This problem can occur if you did not assign the user to the appropriate User Group (Administrators) with the Super User Role. If you did not create a user after installation, then again, it sounds like all of the data was not installed properly.
Is there a way to check that? I repeated the install, but the result is the same.
Can you verify your memory_limit setting in PhpInfo? Sometimes the install runs short of memory without telling you and the installation is not complete.
Reports | System Info | Server Tag | View link.
PHP Memory limit is at 128M. Tried version 1.0.0. It installed without a problem.
Anyone? I’m stuck. Installed on a different machine with exactly the same result! After login the manager page displays "permission denied" with the logout hyperlink.
I have same trouble on OpenSolaris(2009.06) and beta4.
The installation looks completed successfully(I installed beta4 into Windows too, but I could not found any difference between the two).
I think that the first user might be registered correctly, because MODx warned me when I input incorrect password. "Permission denied" is appeared just after logged-in.
Can you all show us the contents of these tables:
modx_users
modx_access_context
modx_access_policies
modx_membergroup_names
modx_member_groups
modx_user_group_roles
Thanks.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com