Hi,
I am having similar problems. I get an error every time i click to download a package. The error log is as follows:
[2011-08-16 19:53:05] (ERROR @ /connectors/workspace/packages-rest.php) MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
[2011-08-16 19:53:05] (ERROR @ /connectors/workspace/packages-rest.php) Could not download package at: http://modx.com/extras/download/?id=4e020ba6f2455475f00000da
The hosting company have said the following:
We’ve checked the logs and it’s not modsec or suphp, it appears more to be a scripting issue.
Is there anything else i could ask the hosting company to check?
Thanks for any help
j
www.9thwave.co.uk
WEB | DESIGN | PRINT
Further to my last post i have heard the following from my hosts:
If this should fall over to use curl it would not matter if allow_url_fopen is disabled, this is disabled on all servers for security. What should happen is the script uses curl insttead of this which it does not appear to be using despite it being available to use.
This is something you would need to take up with the script developers and have them look into, chances are it’s a bug and the fall over is not functioning as it should.
Can anyone suggest a work around?
Thanks
J
www.9thwave.co.uk
WEB | DESIGN | PRINT
-
☆ A M B ☆
- 3,141 Posts
It definitely should be attempting cURL first and attempt fopen only if that isn’t available..
When you go to Reports > System Info > phpinfo(), and do a search for curl, does it say it’s enabled from there?
Hi Mark,
Yes it does.
curl
cURL support enabled
cURL Information libcurl/7.21.6 OpenSSL/0.9.8n zlib/1.2.3 libidn/0.5.6
Thing is, it was working a while ago!!
i have about 5 sites running on Revo and none of them now install packages when they did last time used.
I’m awaiting a response from the hosts to see if anything might have changed on the server.
Could yuo suggest anything else in the meantime?
Cheers
J
www.9thwave.co.uk
WEB | DESIGN | PRINT
Two things to try, though they may not help:
1. Set the compress_js and compress_css system settings to 0.
2. Check the date_timezone System Setting to make sure it matches the setting used by PHP and MySQL (if any).
These two have fixed various odd problems for people, so they're worth a try.
---------------------------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using . . . PLEASE!
MODx info for everyone:
http://bobsguides.com/MODx.html