Solved -
I realized this must be a problem with php 5.3.6 the latest release and it not supporting the mb_strtolower() function.
I did some quick research and i replaced mb_strtolower() with strtolower - then the filemanager worked again
This was in getlist.php which controls the folder/file fetching for file manager
-
☆ A M B ☆
- 3,141 Posts
While I am glad you got this solved, I would 1have no idea where to look for to fix this in case someone finds the same problem....
What was plugin 4, and what did you exactly (file, line) change to make this work again? If this is part of the core distribution that needs to be addressed in future releases.
Please help others by sharing specifics.
It didn’t have anything to do with plugin 4
If you look at the firebug error on my first image - it’s trying to POST to the php file getlist.php but its failing because of php 5.3.6 deprecation
My error log specified the path exactly core/model/modx/processors/browser/directory/getlist.php on line 129
Used to read
$ext = $useMultibyte ? mb_strtolower($ext,$encoding) : strtolower($ext);
Now it reads
$ext = $useMultibyte ? strtolower($ext,$encoding) : strtolower($ext);
-
☆ A M B ☆
- 3,141 Posts
Am I right in assuming your "use_multibyte" system setting is set to "yes"?
If so, just set that to "no" instead of making changes to core files that will break on upgrade. If it is already set to "no" that is worth a bug report as that if-statement should be respecting that setting..
The error you posted from your error log...
[2011-06-01 10:26:06] (ERROR @ /home/ourdomain/public_html/ourdomain.org/public/core/cache/includes/elements/modplugin/4.include.cache.php : 38) Un-recoverable error 8192: Function eregi_replace() is deprecated
... comes from the cache for plugin 4. May not be a direct problem for your file tree, but probably something that needs to be solved.
-
☆ A M B ☆
- 3,141 Posts
Thanks for sharing. Sorry for being a pain. XD