We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14349
    • 44 Posts
    Solved -

    I realized this must be a problem with php 5.3.6 the latest release and it not supporting the mb_strtolower() function.

    I did some quick research and i replaced mb_strtolower() with strtolower - then the filemanager worked again

    This was in getlist.php which controls the folder/file fetching for file manager
      • 18373 ☆ A M B ☆
      • 3,141 Posts
      While I am glad you got this solved, I would 1have no idea where to look for to fix this in case someone finds the same problem....


      What was plugin 4, and what did you exactly (file, line) change to make this work again? If this is part of the core distribution that needs to be addressed in future releases.


      Please help others by sharing specifics.
        Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

        Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
        • 14349
        • 44 Posts
        It didn’t have anything to do with plugin 4

        If you look at the firebug error on my first image - it’s trying to POST to the php file getlist.php but its failing because of php 5.3.6 deprecation

        My error log specified the path exactly core/model/modx/processors/browser/directory/getlist.php on line 129

        Used to read
        $ext = $useMultibyte ? mb_strtolower($ext,$encoding) : strtolower($ext);

        Now it reads
        $ext = $useMultibyte ? strtolower($ext,$encoding) : strtolower($ext);
          • 18373 ☆ A M B ☆
          • 3,141 Posts
          Am I right in assuming your "use_multibyte" system setting is set to "yes"?

          If so, just set that to "no" instead of making changes to core files that will break on upgrade. If it is already set to "no" that is worth a bug report as that if-statement should be respecting that setting..


          The error you posted from your error log...
          [2011-06-01 10:26:06] (ERROR @ /home/ourdomain/public_html/ourdomain.org/public/core/cache/includes/elements/modplugin/4.include.cache.php : 38) Un-recoverable error 8192: Function eregi_replace() is deprecated
          ... comes from the cache for plugin 4. May not be a direct problem for your file tree, but probably something that needs to be solved.
            Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

            Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
            • 14349
            • 44 Posts
            The actual error was

            [Thu Jun 02 13:44:34 2011] [error] [client 208.89.ipwithheld] PHP Fatal error:  Call to undefined function mb_strtolower() in /home/mydomain/public_html/mydomain.org/public/core/model/modx/processors/browser/directory/getlist.php on line 129


            But you are RIGHT about the above error being caused by plugin #4 which was directresize - I just removed

            Went back into settings and changed multibyte to NO and changed my core hack back to original.

              • 18373 ☆ A M B ☆
              • 3,141 Posts
              Thanks for sharing. Sorry for being a pain. XD
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                • 1892
                • 82 Posts
                Quote from: JNet at Jun 02, 2011, 09:59 AM

                But you are RIGHT about the above error being caused by plugin #4 which was directresize - I just removed


                Hi,

                just as an aside I’m looking at updating directresize, replacing the deprecated php code, and updating it to the latest highslide version. If I get time this weekend I’m updating to Revo 2.1 so I can test it, it currently works on my 2.0.8 install.
                At the moment
                the source code is on github, https://github.com/apcherry/directresize, and if the tests go well then I hope to have a transport package available next week and submitted as an update to Extras.

                It’s my first attempt at github and packages so I’m still feel as though I’m fumbling through it at the moment, so go easy on me but any feedback is gratefully received.
                Adrian