We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14349
    • 44 Posts
    First off, this isn’t just an upgrade to 2.1, it’s a migration from one server to another server (the upgrade happened first)


    I’ve attached an image of what the File manager looks like. I’m SURE there is some setting somewhere thats causing this. I just can’t figure out what.

    I never needed to have the Filemanger paths in system settings specified before (I’m on an almost identical system) The only things that’s different is i’m using the newest version of php on my centos box.

    Ok so back to the migration - Migrated - changed paths in config file, changed mox_workspace path in the database, re-ran setup - still to no avail.
      • 28215
      • 4,149 Posts
      HEY YOU, READ THIS! If you’re posting about a bug, please state all of your Environment information in your post: Version of MODx, Traditional or Advanced distribution (for Revo), Server OS, Server Version, PHP Version, MySQL Version (client and server), is pdo_mysql installed, your Browser type and version, if you are using any opcode caching such as eAccelerator, APC, winCache, xCache, etc; any relevant errors in core/cache/logs/error.log, and any other environment data we should know. We can’t help you without that information.

      Also:

      - filemanager_* settings
      - Ensure paths are correct in core/config/config.inc.php
      - Any errors in core/cache/logs/error.log
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 14349
        • 44 Posts
        Centos 5.5
        php 5.3.6
        mysql 5.0.77
        Revo 2.1


        no errors in error.log
        filemanger settings are empty (on the previous server they where empty and it worked fine - previous server was also centos)
        Correct paths in core/config/configfile
          • 28215
          • 4,149 Posts
          Any JS errors?
          Any custom ACLs?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 14349
            • 44 Posts
            I get the following error from firebug which I’ve attached as an image.

            Also a possible unrelated/related error is visiting the System Info page and losing the ability to scroll down. This yields a separate JS error. I’ve also attached that image (named error console)
              • 14349
              • 44 Posts
              Also ran across this error but i’m not sure if it means anything

              [2011-06-01 10:26:06] (ERROR @ /home/ourdomain/public_html/ourdomain.org/public/core/cache/includes/elements/modplugin/4.include.cache.php : 38) Un-recoverable error 8192: Function eregi_replace() is deprecated
                • 18373 ☆ A M B ☆
                • 3,141 Posts
                What is the plugin with id 4?

                From that first error you get in Firebug it seems something is going wrong on the server level. Check out your server error log at that specified date/time and see what that says.
                  Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                  Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                  • 14349
                  • 44 Posts
                  I can confirm the first screenshot from firebug is the error (it happens when i Press on the File browser tab)
                  Errors from apache log:

                  - PHP Deprecated: Function eregi_replace() is deprecated -

                  Also more specific to the first screen shot of the firebug error
                  - PHP Fatal error: Call to undefined function mb_strtolower() in browser/directory/getlist.php


                  looks like its a php 5.3 issue?

                  I’ve upgraded to 2.1.1 still the same
                    • 18373 ☆ A M B ☆
                    • 3,141 Posts
                    What plugin has id 4? Check in the elements tab, plugin tree, and then the one with (4) at the end of its name. Also check (when editing it) the Events tab and tell us what events it fires on.

                    That plugin is using a deprecated function and would need to be updated for your new server. It may be firing specifically on file tree load and because it doesn’t complete, the file manager tab fails.
                      Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                      Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                      • 14349
                      • 44 Posts
                      Ok - i updated my post above btw