We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22308
    • 2 Posts
    I upgraded from 2.0.8-pl to 2.1.0-pl. When I now try to change the template for a resource
    it appears the "change template" warning, and it appears the "Please wait ... saving" message,
    but it does not reload the resource. When I reload the site in the browser, still the old template is active.
    Please help I almost had finished my project ... argh!

    After upgrading I clicked on "Warnings" (see screenshot) and get some table update errors.
    Maybe this could be the Problem?

    PHP MySQL Library 5.0.90, MySQL Server 5.1.57, PHP Version 5.3.6, Apache/2.2.3 (CentOS), System Linux
      • 22308
      • 2 Posts
      Changing the Template only works with quick edit ...
        • 28215
        • 4,149 Posts
        - Traditional or Advanced distro?
        - your Browser type and version?
        - Are you using any opcode caching such as eAccelerator, APC, winCache, xCache, etc
        - any relevant errors in core/cache/logs/error.log?
        - Using any RTEs?
        - Any other environment data we should know?
          shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
          • 22308
          • 2 Posts
          - Traditional distro
          - Safari 5.05 (OS X 10.6.5)
          - where can I see if I use opcode caching? php info?
          - core/cache/ ist completely empty
          - no RTEs or additional packages are installed

          The only thing was when I tried a fresh 2.1.0 install that it fails because of no connection (see screenshot)
          to the database. So I installed the 2.0.8 (traditional) and upgrade it. Thanks for helping ...
            • 28215
            • 4,149 Posts
            Quote from: opentype at May 27, 2011, 09:10 AM

            The only thing was when I tried a fresh 2.1.0 install that it fails because of no connection (see screenshot)
            to the database. So I installed the 2.0.8 (traditional) and upgrade it. Thanks for helping ...

            Uhm, can you elaborate on this? You installed 2.0.8? How? I thought this was for 2.1.0?
              shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
              • 22308
              • 2 Posts
              first I tried to install a completely new 2.1.0, but it fails because of no connection
              to the database (screenshot above)

              I started again from scratch and tried to install 2.0.8 (successfully) and made an upgrade to 2.1.0
                • 22308
                • 2 Posts
                OK, again I started from scratch with 2.1.0 trad.

                and again I got this error when I "test database server connection and view collations":
                Connecting to database server:
                Could not connect to the database server. Check the connection properties and try again.

                [2011-05-27 17:46:05] (ERROR in xPDO::connect @ /httpdocs/core/xpdo/xpdo.class.php : 344) SQLSTATE[HY000] [2019] Can’t initialize character set (path: /usr/share/mysql/charsets/)

                [2011-05-27 17:46:05] (ERROR in xPDO::connect @ /httpdocs/core/xpdo/xpdo.class.php : 344) SQLSTATE[HY000] [2019] Can’t initialize character set (path: /usr/share/mysql/charsets/)


                this will only happen when installing 2.1.0
                any idea to solve this?
                  • 24068
                  • 4 Posts
                  Quote from: opentype at May 27, 2011, 10:57 AM

                  OK, again I started from scratch with 2.1.0 trad.

                  and again I got this error when I "test database server connection and view collations":
                  Connecting to database server:
                  Could not connect to the database server. Check the connection properties and try again.

                  [2011-05-27 17:46:05] (ERROR in xPDO::connect @ /httpdocs/core/xpdo/xpdo.class.php : 344) SQLSTATE[HY000] [2019] Can’t initialize character set (path: /usr/share/mysql/charsets/)

                  [2011-05-27 17:46:05] (ERROR in xPDO::connect @ /httpdocs/core/xpdo/xpdo.class.php : 344) SQLSTATE[HY000] [2019] Can’t initialize character set (path: /usr/share/mysql/charsets/)


                  this will only happen when installing 2.1.0
                  any idea to solve this?

                  It looks like the problem described in this thread: http://modxcms.com/forums/index.php/topic,64171.0.html
                    • 22308
                    • 2 Posts
                    Thanks pureppl! This was exactly my problem and with the little hack I installed 2.1.0 successfully!

                    Quote from: shamblett at May 27, 2011, 05:15 AM

                    Yes, it was a bit of a hack and I wouldn’t recommend doing this but what I did was this :-

                    Just above line 341 of XPDO.class.php add this :-
                    $this->config['dsn'] = $this->config['dsn'] . 'utf8';


                    This will get you past the collation stage and get your correct collation back, DON’T press the next step which is ’connect to database’ or something like that.

                    Comment out the code you’ve just put in(or restore your original file).

                    Now press the connect to database link, should be good to go from here.

                    There’s probably a much better place to do this in the setup code, you just need to default the charset to utf8(or any valid one I suspect) I just didn’t have time
                    to look further.

                    It may be worth looking at the bug, the real fix may have been done.
                      • 22308
                      • 2 Posts
                      But unfortunately my other problem is still alive! huh
                      All works fine except the possibility to change templates in resources.
                      Only "Quick Update Resource" works but doesn´t help me ...