We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 31037
    • 358 Posts
    About swedish characters:

    Instread of å and ö I get ö and ä and such, so It’s just an encoding problem. Tried empty chache and everything, no change. But let me try this one more time on another install.

    Note that it was a clean install at my web host that got me the "Could not load context: mgr", not an upgrade.

    I’ll do some more testing soon.
      • 22303 MODX Staff
      • 10,725 Posts
      Quote from: Uncle68 at Dec 21, 2006, 01:42 PM

      Note that it was a clean install at my web host that got me the "Could not load context: mgr", not an upgrade.
      If possible, uncomment line 91 in index.php to set debug mode and it might reveal more information. However, be careful not to leave this up for long on a public site, as some of the information output in debug mode could reveal important database credentials. Even though I think I have resolved most cases of this kind of output, better safe then sorry.

      When you do enable debug mode, feel free to PM me the output or email it to me at [email protected] so I can help you get to the bottom of the problem quickly...
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        --with-pdo-mysql=shared,/Applications/MAMP/bin/mysql4’ ’--with-pdo-pgsql=shared,/Applications/MAMP/Library/pg’

        the MAMP version I have is using mysql 5.0.19, but it looks like the pdo was compiled against a version 4.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          edit: once I logged in to the Manager, the error on the home page disappeared. Or maybe just refreshing the page made it go away. Anyway, it looks like php4 is working OK.

          Ok, I switched my MAMP from php5 to php4. The home page loads, with this error at the top:
          [2006-12-21 22:07:52] (ERROR)

          Error SQLER executing statement:
          Array
          (
          [0] => SQLER
          [1] => 1146
          [2] => Table ’097alpha.modx_session’ doesn’t exist
          )
          Manager seems to be working ok.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 22303 MODX Staff
            • 10,725 Posts
            Quote from: sottwell at Dec 21, 2006, 02:09 PM

            edit: once I logged in to the Manager, the error on the home page disappeared. Or maybe just refreshing the page made it go away. Anyway, it looks like php4 is working OK.

            Ok, I switched my MAMP from php5 to php4. The home page loads, with this error at the top:
            [2006-12-21 22:07:52] (ERROR)

            Error SQLER executing statement:
            Array
            (
            [0] => SQLER
            [1] => 1146
            [2] => Table ’097alpha.modx_session’ doesn’t exist
            )
            Manager seems to be working ok.

            Great!

            Yep, that’s the error that gets trapped and logged (in this case to HTML output) when a table does not exist, but xPDO then attempts to create that table upon encountering this error. With $modx->setLogLevel(XPDO_LOG_LEVEL_FATAL) instead of XPDO_LOG_LEVEL_ERROR, this error would not be shown to an end user, and that will be the level that is set by default in the upcoming public alpha.
              • 28042 ☆ A M B ☆
              • 24,524 Posts
              The only thing that seems to be having trouble using php4 (MAMP) is a weird javascript error when saving the configuration, as the whole frameset refreshes, the mootools causes an error that document.getElementById is not a function.

              Now if we can sort out why the upgraded version on my remote hosted site won’t log in, but just refreshes the login form page, I’ll be happy. I think it has something to do with the line about the site_sessionname not being in the GLOBALS array (I checked, and it’s not there), probably because this is an upgrade, and I manually edited the sample config.inc.php file.

              As far as php and odd libraries, that’s not an unusual problem; look at how many people have problems with the gd libraries from time to time.
                Studying MODX in the desert - http://sottwell.com
                Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                Join the Slack Community - http://modx.org
                • 22303 MODX Staff
                • 10,725 Posts
                Quote from: sottwell at Dec 21, 2006, 02:33 PM

                The only thing that seems to be having trouble using php4 (MAMP) is a weird javascript error when saving the configuration, as the whole frameset refreshes, the mootools causes an error that document.getElementById is not a function.
                I imagine some of my merges just weren’t completed properly with the latest changes from 0.9.5 trunk. I had branched this off before that final push of fixes that occurred right before 0.9.5 release, and some of the changes were not easy to merge back in.

                Quote from: sottwell at Dec 21, 2006, 02:33 PM

                Now if we can sort out why the upgraded version on my remote hosted site won’t log in, but just refreshes the login form page, I’ll be happy. I think it has something to do with the line about the site_sessionname not being in the GLOBALS array (I checked, and it’s not there), probably because this is an upgrade, and I manually edited the sample config.inc.php file.
                Hmm, I wonder if I’ve even updated that config file properly. Let me review it and check out the site_sessionname stuff...

                Quote from: sottwell at Dec 21, 2006, 02:33 PM

                As far as php and odd libraries, that’s not an unusual problem; look at how many people have problems with the gd libraries from time to time.
                Yeah, just a little bigger of an issue with database extensions when trying to deploy a database-driven application. rolleyes
                  • 6726
                  • 7,075 Posts
                  Quote from: OpenGeek at Dec 21, 2006, 01:01 PM
                  @davidm -- yeah, I’m not at all happy with some of these compilation requirements (my server admin has some choice words for the PHP developers in this regard) and after this fiasco, I’m looking for a way to fall back on my PDO emulation classes in cases where PDO is configured, but the PDO mysql driver is not compiled or configured properly for any reason.

                  Indeed. I have asked my server admin to upgrade my server and compile PDO for MySQL 5, which he has done pretty fast using PECL but it seems it changes nothing 0.9.7 does not work (yet). I guess phpinfo returning PDO as installed does not vouch for the system actually working. Maybe something to do with the way it was compiled, or maybe the driver is not the issue... I’ll try to find out if pdo really works. From the debug info I get from 0.9.7 I’d say yes and the manager issue is not tied to the pdo stuff but some other corner case issue I am not yet aware of...

                  I’ll go on investigating and report...

                  @Susan : I’ll try to switch MAMP to PHP4 too, to give this a shot, at least ! Thanks for the info smiley
                    .: COO - Commerce Guys - Community Driven Innovation :.


                    MODx est l'outil id
                    • 28042 ☆ A M B ☆
                    • 24,524 Posts
                    Looks like we’re not the only ones with this problem... http://forum.mamp.info/viewtopic.php?t=653&highlight=pdo
                      Studying MODX in the desert - http://sottwell.com
                      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                      Join the Slack Community - http://modx.org
                      • 6726
                      • 7,075 Posts
                      Yeah well, as I said the default php.ini is missing one important line (extension=pdo.so) to begin with, I saw that thread but it wasn’t really very explicit to me...
                        .: COO - Commerce Guys - Community Driven Innovation :.


                        MODx est l'outil id