We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 6726
    • 7,075 Posts
    Great. Lots of public beta users are not using SVN and were far back with beta3, now we’ll have up to date bug reports smiley

    I have been very pleased with 1732 already, how about making this a RC1 rather than Beta5 (is the road to the final release so far away ?). I know it’s bickering on details, yet this could be a little signal for the impatients tongue
      .: COO - Commerce Guys - Community Driven Innovation :.


      MODx est l'outil id
      • 6726
      • 7,075 Posts
      Sorry to bring that back on the table, I seem to remember this discussion took place already and problem was solved but Gildas attracted my attention on a possible "short_open_tag turned off" issue with latest rev :

      Quote from: Gildas at Oct 20, 2006, 02:14 AM

      In MODx 0.9.5 rev 1751 (beta 5), /manager/frames/tree.php use short PHP opening tag <? on lines 386, 389, 399,399, 432 instead of the preferred <?php. As a result, for installations that have short_open_tag turned off, the documents tree isn’t display. So, if you have this version you can modify the code or change your PHP.INI wink

      Thought I would make sure this wouldn’t go under the radar...
        .: COO - Commerce Guys - Community Driven Innovation :.


        MODx est l&#39;outil id
        • 2762
        • 1,198 Posts
        Quote from: rthrash at Oct 19, 2006, 02:51 PM

        Finally, a real beta 5 test build... if no one finds any serious issues with it, I’d like to push it out to the public side:

        http://modxcms.com/testbuilds/modx-0.9.5-beta5-rev1745.zip

        Tested with two live sites:

        - first site update (from rev 1738) only system without sample content works fine
        - second site , same server, (from rev 1738) update system and sample content get error after installation:
        MODx setup couldn't install/alter some tables inside the selected database.
        
        The following errors had occurred during installation
        
        Column count doesn't match value count at row 1 during the execution of SQL statement REPLACE INTO `modx_site_templates` VALUES ('1','MODxCSS','MODx CSS template','0','1','','0','\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n[(site_name)] | [*pagetitle*]\r\n\r\n\r\n\r\n\r\n\r\n \r\n \r\n [(site_name)]\r\n {{slogan}}\r\n \r\n Main menu\r\n [!Wayfinder?startId=`0` &hereClass=`current` &level=`1` &outerClass=`topnav`!]\r\n \r\n \r\n \r\n \r\n Menu\r\n [!Wayfinder?startId=`0` &hereClass=`` &selfClass=`current` &outerClass=`sidemenu`!]\r\n \r\n Search\r\n [[AjaxSearch? &AS_landing=`8` &moreResultsPage=`8` &showMoreResults=`1` &addJscript=`0` &extract=`0` &AS_showResults=`0`]]\r\n News\r\n [[Ditto? &startID=`2` &summarize=`1` &total=`1` &commentschunk=`FormBlogComments` &tpl=`nl_sidebar` &showarch=`0` &truncLen=`100` &truncSplit=`0`]]\r\n Login\r\n [!WebLogin? &tpl=`FormLogin` &loginhomeid=`[(site_start)]`!]\r\n Styles\r\n {{styles}} \r\n \r\n [*longtitle*]\r\n [*#content*] \r\n \r\n {{footer}}\r\n MySQL: [^qt^], [^q^] request(s), PHP: [^p^], total: [^t^], document retrieved\r\n from [^s^].\r\n \r\n\r\n\r\n\r\n','0').
        
        
        Column count doesn't match value count at row 1 during the execution of SQL statement REPLACE INTO `modx_site_templates` VALUES ('3','MODxCSS Wide','Wide Template','0','1','','0','\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n[(site_name)] | [*pagetitle*]\r\n\r\n\r\n\r\n\r\n\r\n \r\n \r\n [(site_name)]\r\n {{slogan}}\r\n \r\n Main menu\r\n [!Wayfinder?startId=`0` &hereClass=`current` &level=`1` &outerClass=`topnav`!]\r\n \r\n \r\n \r\n [*longtitle*]\r\n [*#content*] \r\n \r\n {{footer}}\r\n MySQL: [^qt^], [^q^] request(s), PHP: [^p^], total: [^t^], document retrieved\r\n from [^s^].\r\n \r\n\r\n\r\n\r\n','0').Column count doesn't match value count at row 1 during the execution of SQL statement REPLACE INTO `modx_site_templates` VALUES ('4','MODxHost','MODxHost Template','0','1','','0','\r\n\r\n\r\n[(site_name)] | [*pagetitle*]\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\nimage1 = new Image();\r\nimage1.src = \"[(base_url)]assets/templates/modxhost/images/array_332x28_roll.jpg\";\r\n\r\n\r\n\r\n\r\n\r\n \r\n \r\n \r\n \r\n \r\n [(site_name)]\r\n \r\n News:\r\n [[Ditto? &startID=`2` &summarize=`2` &total=`20` &commentschunk=`FormBlogComments` &tpl=`nl_sidebar` &showarch=`0` &truncLen=`100` &truncSplit=`0`]]\r\n \r\n Most Recent:\r\n [[ListIndexer?LIn_root=0]] \r\n Login:\r\n [!WebLogin? &tpl=`FormLogin` &loginhomeid=`[(site_start)]`!]\r\n Meta:\r\n Valid XHTML\r\n Valid css\r\n MODx\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n [*longtitle*]\r\n [*#content*] \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n [(site_name)]\r\n SEARCH[[AjaxSearch? &AS_landing=`8` &moreResultsPage=`8` &showMoreResults=`1` &addJscript=`0` &extract=`0` &AS_showResults=`0`]] \r\n [[Wayfinder?startId=`0` &outerTpl=`mh.OuterTpl` &innerTpl=`mh.InnerTpl` &rowTpl=`mh.RowTpl` &innerRowTpl=`mh.InnerRowTpl` &firstClass=`first` &hereClass=``]] \r\n \r\n \r\n \r\n \r\n \r\n Powered\r\n by MODx  Template © 2006\r\n modXhost.com\r\n MySQL: [^qt^], [^q^] request(s), PHP: [^p^], total: [^t^], document retrieved\r\n from [^s^]. \r\n \r\n \r\n \r\n \r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n','0').
        
        
        Column count doesn't match value count at row 1 during the execution of SQL statement REPLACE INTO `modx_site_templates` VALUES ('5','MODxHostWithComments','MODxHost Template with comments','0','3','','0','\r\n\r\n\r\n[(site_name)] | [*pagetitle*]\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\nimage1 = new Image();\r\nimage1.src = \"[(base_url)]assets/templates/modxhost/images/array_332x28_roll.jpg\";\r\n\r\n\r\n\r\n\r\n\r\n \r\n \r\n \r\n \r\n \r\n [(site_name)]\r\n \r\n News:\r\n [[Ditto? &startID=`2` &summarize=`2` &total=`20` &commentschunk=`FormBlogComments` &tpl=`nl_sidebar` &showarch=`0` &truncLen=`100` &truncSplit=`0`]]\r\n \r\n Most Recent:\r\n [[ListIndexer?LIn_root=0]] \r\n Login:\r\n [!WebLogin? &tpl=`FormLogin` &loginhomeid=`[(site_start)]`!]\r\n Meta:\r\n Valid XHTML\r\n Valid css\r\n MODx\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n [*longtitle*]\r\n [*#content*]\r\n\r\n[!Jot? &customfields=`name,email` &subscribe=`1` &pagination=`10`!]\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n [(site_name)]\r\n SEARCH[[AjaxSearch? &AS_landing=`8` &moreResultsPage=`8` &showMoreResults=`1` &addJscript=`0` &extract=`0` &AS_showResults=`0`]] \r\n [[Wayfinder?startId=`0` &outerTpl=`mh.OuterTpl` &innerTpl=`mh.InnerTpl` &rowTpl=`mh.RowTpl` &innerRowTpl=`mh.InnerRowTpl` &firstClass=`first` &hereClass=``]] \r\n \r\n \r\n \r\n \r\n Powered\r\n by MODx  Template © 2006\r\n modXhost.com\r\n MySQL: [^qt^], [^q^] request(s), PHP: [^p^], total: [^t^], document retrieved\r\n from [^s^]. \r\n \r\n \r\n \r\n \r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n','0').
        
        Some tables were not updated. This might be due to previous modifications.



        EDIT: in the failed upgrade manager styles does not work and homepage give me an error:
        	
        « MODx Parse Error »
        MODx encountered the following error while attempting to parse the requested resource:
        « Too many forward attempts. »
              SQL: The request could not be completed due to too many unsuccessful forward attempts. 


        EDIT2: in the /manager login page:
        Warning: fopen(/var/www/html/manager/media/style//login.html): failed to open stream: No such file or directory in /var/www/html/manager/includes/accesscontrol.inc.php on line 83
        
        Warning: filesize(): Stat failed for /var/www/html/manager/media/style//login.html (errno=2 - No such file or directory) in /var/www/html/manager/includes/accesscontrol.inc.php on line 84
        
        Warning: fread(): supplied argument is not a valid stream resource in /var/www/html/manager/includes/accesscontrol.inc.php on line 84
        
        Warning: fclose(): supplied argument is not a valid stream resource in /var/www/html/manager/includes/accesscontrol.inc.php on line 85
          Free MODx Graphic resources and Templates www.tattoocms.it
          -----------------------------------------------------

          MODx IT  www.modx.it
          -----------------------------------------------------

          bubuna.com - Web & Multimedia Design
          • 6726
          • 7,075 Posts
          Woosh banzai could you wrap that in code tags rather than quote (pretty huge as it is, takes up the whole screen) wink ?
            .: COO - Commerce Guys - Community Driven Innovation :.


            MODx est l&#39;outil id
            • 2762
            • 1,198 Posts
            Quote from: davidm at Oct 20, 2006, 07:47 AM

            Woosh banzai could you wrap that in code tags rather than quote (pretty huge as it is, takes up the whole screen) wink ?

            Done smiley

            Sorry

            I have used the wrong button grin
              Free MODx Graphic resources and Templates www.tattoocms.it
              -----------------------------------------------------

              MODx IT  www.modx.it
              -----------------------------------------------------

              bubuna.com - Web & Multimedia Design
              • 22815
              • 1,097 Posts
              Woah.
              Column count doesn't match value count at row 1 during the execution of SQL statement
               REPLACE INTO `modx_site_templates` VALUES (...

              Assuming that the error system isn’t omitting a key part of the code, that SQL is nasty. As the fieldnames are not specified, the replace command is not just assuming that there’s that number of rows, it is assuming that they are in that order. I’ve not looked at the rest of the SQL, but that sort of thing needs fixing - it’ll mean a heavier SQL statement but it will cause less issues.

              I recently needed to connect two templates together for a custom function, and decided to use a custom table, but I could easily have decided to use an extra field in modx_site_templates - this replace command would not have been happy with such a change. I’m glad I didn’t, but in the absense of an edict saying "thou shalt have these fields in this order and no more fields", we can’t make assumptions about databases in the upgrade function.

              Can someone fix this before it goes to the general forum users?
                No, I don&#39;t know what OpenGeek&#39;s saying half the time either.
                MODx Documentation: The Wiki | My Wiki contributions | Main MODx Documentation
                Forum: Where to post threads about add-ons | Forum Rules
                Like MODx? donate (and/or share your resources)
                Like me? See my Amazon wishlist
                MODx "Most Promising CMS" - so appropriate!
                • 22303 MODX Staff
                • 10,725 Posts
                Quote from: PaulGregory at Oct 20, 2006, 07:58 AM

                Woah.
                Column count doesn't match value count at row 1 during the execution of SQL statement
                 REPLACE INTO `modx_site_templates` VALUES (...

                Assuming that the error system isn’t omitting a key part of the code, that SQL is nasty. As the fieldnames are not specified, the replace command is not just assuming that there’s that number of rows, it is assuming that they are in that order. I’ve not looked at the rest of the SQL, but that sort of thing needs fixing - it’ll mean a heavier SQL statement but it will cause less issues.

                I recently needed to connect two templates together for a custom function, and decided to use a custom table, but I could easily have decided to use an extra field in modx_site_templates - this replace command would not have been happy with such a change. I’m glad I didn’t, but in the absense of an edict saying "thou shalt have these fields in this order and no more fields", we can’t make assumptions about databases in the upgrade function.

                Can someone fix this before it goes to the general forum users?

                "thou shalt have these fields in this order and no more fields"

                There you go, it’s official...

                I also don’t think this is going to be solved in this version Paul; every statement in the installer uses this same format. The entire process of installation needs to be completely rewritten to handle this better, but for now, core tables should never be modified; at least not in this version of MODx.
                  • 21255
                  • 215 Posts
                  Is just stumbled over that feature request: Confirmation when quiting an edited manager page without saving. Seems the checkDirt() function isn’t working anymore...

                  Edit: Can confirm that on Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.7) Gecko/20060921 Ubuntu/dapper-security Firefox/1.5.0.7
                    • 33337
                    • 3,975 Posts
                    Quote from: netnoise at Oct 22, 2006, 04:58 AM

                    Is just stumbled over that feature request: Confirmation when quiting an edited manager page without saving. Seems the checkDirt() function isn’t working anymore...

                    Edit: Can confirm that on Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.7) Gecko/20060921 Ubuntu/dapper-security Firefox/1.5.0.7

                    Confirmed the bug on Firefox, in IE it seems to be working right.

                    regards.
                      Zaigham R - MODX Professional | Skype | Email | Twitter

                      Digging the interwebs for #MODX gems and bringing it to you. modx.link
                      • 21255
                      • 215 Posts
                      This error occurs from time to time in 0.9.5:
                      [tt]
                      PHP error debug
                      Error: mysql_insert_id(): A link to the server could not be established
                      Error type/ Nr.: Warning - 2
                      File: /srv/lighttpd/rockwire.tv/www/manager/includes/extenders/dbapi.mysql.class.inc.php
                      Line: 224
                      Line 224 source: $lid = mysql_insert_id();
                      [/tt]

                      MySQL runs fine. There are no further errors/warning except this one.

                      This discussion is closed to further replies. Keep calm and carry on.