Ah, it only shows errors when I’m logged in. As I understand it, there are plans for the 1.0 Manager to be written "in" MODx, and would thus need to use the parser in order to show the log in screen. So add one to the "Writing Manager In MODx Itself Potentially Bad Idea" column.
Quote from: xwisdom at Aug 20, 2006, 06:23 PM
@Paul: the parseText() function belong to the Parser class object. You might want to make sure that the file /manager/includes/extenders/parser.class.php does exists and that you have permission to execute it.
I have /manager/includes/extenders/parser.class.php; and I’ve made sure I have permission to execute it.
I’ve searched through all the files and eventually found that the file is loaded by this reference:
$this->loadExtension('Parser');
Thus the reason it didn’t work for me - on a Linux server - is that loadExtension looks for..
if(!file_exists($xpath.$extname.'.class.php')) return false;
and didn’t find "Parser.class.php", because it doesn’t understand that this is the same as "parser.class.php", and that part of the code doesn’t raise an error.
Please change line 550 of document.parser.class.inc.php to $this->loadExtension(’parser’); - and please can we all remember that case matters. Am I the only one testing on a Linux box?
Quote from: xwisdom at Aug 20, 2006, 06:23 PM
The parser now requires two additional cache files: siteSnippets.cache.php and sitePlugins.cache.php
I know this is obvious, but these need to be added to the Clear Cache function. Presently, hitting that button doesn’t clear out these files.